aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-08-22 16:40:17 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-08-22 16:40:17 +0800
commit596bf2e4418764c25d9a090179cdebf43a2fa6f0 (patch)
treed9150d8d07b524c52d3f775ee7b442c99594b594 /mail
parent3d60b2a279dad3fb69d36982cd368b5180807735 (diff)
downloadfreebsd-ports-gnome-596bf2e4418764c25d9a090179cdebf43a2fa6f0.tar.gz
freebsd-ports-gnome-596bf2e4418764c25d9a090179cdebf43a2fa6f0.tar.zst
freebsd-ports-gnome-596bf2e4418764c25d9a090179cdebf43a2fa6f0.zip
Move mail/sylpheed3 to mail/sylpheed.
Diffstat (limited to 'mail')
-rw-r--r--mail/sylpheed/Makefile100
-rw-r--r--mail/sylpheed/distinfo4
-rw-r--r--mail/sylpheed/files/patch-libsylph-defs.h (renamed from mail/sylpheed/files/patch-ac)16
-rw-r--r--mail/sylpheed/files/patch-src-printing.c22
-rw-r--r--mail/sylpheed/pkg-descr4
-rw-r--r--mail/sylpheed/pkg-plist127
6 files changed, 186 insertions, 87 deletions
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 07d5dcdfcafa..9225e945602f 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -6,64 +6,70 @@
#
PORTNAME= sylpheed
-PORTVERSION= 1.0.6
-PORTREVISION= 9
+PORTVERSION= 3.1.1
+PORTREVISION= 2
CATEGORIES= mail ipv6
-MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v1.0/
+MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v${PORTVERSION:C/\.[^\.]*$//}/ \
+ CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
-DEPRECATED= Use mail/sylpheed3 instead
-EXPIRATION_DATE= 2011-08-27
-
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_ICONV= yes
-USE_GNOME= gtk12
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
-NO_LATEST_LINK= yes
+USE_LDCONFIG= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+# Sylpheed needs pthread if GnomeVFS is installed (GtkFileChooser uses it)
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-ipv6 \
--prefix=${PREFIX} \
--with-libintl-prefix=${LOCALBASE} \
--program-transform-name=''
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-.endif
+CONFLICTS= sylpheed-1.[0-8]* sylpheed-2.[0-9]* sylpheed-gtk2-[0-9]*
-.if defined(WITH_PIXBUF)
-USE_GNOME+= gdkpixbuf
-.else
-USE_GNOME+= imlib
-.endif
+OPTIONS= GPGME "Enable GnuPG support using GPGME." off \
+ COMPFACE "Enable X-Face support." off \
+ JPILOT "Enable JPilot support." off \
+ LDAP "Enable LDAP support." off \
+ SSL "Enable OpenSSL support." on \
+ GTKSPELL "Enable Spell checking support" on \
+ ONIGURUMA "Enable Oniguruma support" off
.include <bsd.port.pre.mk>
-.if defined(WITH_PIXBUF)
-CONFIGURE_ARGS+=--disable-imlib
+.if !defined(WITHOUT_SSL)
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+CONFIGURE_ARGS+=--enable-ssl
.else
-CONFIGURE_ARGS+=--disable-gdk-pixbuf
+CONFIGURE_ARGS+=--disable-ssl
.endif
+
.if defined(WITH_GPGME)
LIB_DEPENDS+= gpgme.19:${PORTSDIR}/security/gpgme
-RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
+RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg \
+ pinentry-gtk-2:${PORTSDIR}/security/pinentry-gtk2
CONFIGURE_ARGS+=--enable-gpgme
.else
CONFIGURE_ARGS+=--disable-gpgme
.endif
+
.if defined(WITH_COMPFACE)
LIB_DEPENDS+= compface.1:${PORTSDIR}/mail/faces
CONFIGURE_ARGS+=--enable-compface
.else
CONFIGURE_ARGS+=--disable-compface
.endif
+
.if defined(WITH_JPILOT)
LIB_DEPENDS+= pisock.9:${PORTSDIR}/palm/pilot-link
RUN_DEPENDS+= jpilot:${PORTSDIR}/palm/jpilot
@@ -71,44 +77,48 @@ CONFIGURE_ARGS+=--enable-jpilot
.else
CONFIGURE_ARGS+=--disable-jpilot
.endif
+
.if defined(WITH_LDAP)
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--enable-ldap
.else
CONFIGURE_ARGS+=--disable-ldap
.endif
-.if !defined(WITHOUT_SSL)
-CONFIGURE_ARGS+=--enable-ssl
+
+.if defined(WITH_GTKSPELL)
+LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+CONFIGURE_ARGS+=--enable-gtkspell
.else
-CONFIGURE_ARGS+=--disable-ssl
+CONFIGURE_ARGS+=--disable-gtkspell
+.endif
+
+.if defined(WITH_ONIGURUMA)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libonig.a:${PORTSDIR}/devel/oniguruma5
+CONFIGURE_ARGS+=--enable-oniguruma
+.else
+CONFIGURE_ARGS+=--disable-oniguruma
.endif
MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
faq/en/Makefile.in faq/es/Makefile.in faq/fr/Makefile.in \
faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
- manual/ja/Makefile.in src/Makefile.in
-
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_PIXBUF=yes Enable GDK Pixbuf support"
- @${ECHO} " WITH_GPGME=yes Enable GnuPG support using GPGME."
- @${ECHO} " WITH_COMPFACE=yes Enable X-Face support."
- @${ECHO} " WITH_JPILOT=yes Enable JPilot support."
- @${ECHO} " WITH_LDAP=yes Enable LDAP support."
- @${ECHO} ""
- @${ECHO} " WITHOUT_SSL=yes Disable OpenSSL support."
- @${ECHO} ""
+ manual/ja/Makefile.in src/Makefile.in libsylph/Makefile.in \
+ src/icons/Makefile.in
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g; ' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
+ s|libs gtkspell-2\.0`|& -laspell|g;' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/etc|${LOCALBASE}&|g' \
- ${WRKSRC}/src/procmime.c
+ ${WRKSRC}/libsylph/procmime.c
+
+# to prevent breaking cc of ldif.c because of a base64.h in PREFIX/include
+ @${REINPLACE_CMD} -e 's|^\(DEFS.*\.\.\)$$|\1 -I../libsylph|' \
+ ${WRKSRC}/src/Makefile.in
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's|^SUBDIRS = ac m4 po intl src manual faq$$|SUBDIRS = ac m4 po intl src|g' \
+ @${REINPLACE_CMD} -e 's|^SUBDIRS = ac libsylph src plugin po manual faq nsis$$|SUBDIRS = ac libsylph src plugin po nsis|g' \
${WRKSRC}/Makefile.in
.else
.for i in ${MAKEFILES}
@@ -123,8 +133,12 @@ post-install:
@${MKDIR} ${DOCSDIR}
.for i in ChangeLog INSTALL README TODO
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/${i}.jp ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${i}.ja ${DOCSDIR}
.endfor
.endif
+ @${MKDIR} ${PREFIX}/share/pixmaps
+ @${MKDIR} ${PREFIX}/share/applications
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${PREFIX}/share/pixmaps/
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed.desktop ${PREFIX}/share/applications/
.include <bsd.port.post.mk>
diff --git a/mail/sylpheed/distinfo b/mail/sylpheed/distinfo
index c612665c0886..9df20a3dff34 100644
--- a/mail/sylpheed/distinfo
+++ b/mail/sylpheed/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sylpheed-1.0.6.tar.bz2) = a3bf2c61ef40bd38a39b1cbf0f6654f9cfd9977144dcac5f68b17f167f939787
-SIZE (sylpheed-1.0.6.tar.bz2) = 2377710
+SHA256 (sylpheed-3.1.1.tar.bz2) = c4801601013326dcf53512552f8a903dc7289aa56ae9bd7e28e103c5aae19b9f
+SIZE (sylpheed-3.1.1.tar.bz2) = 3234408
diff --git a/mail/sylpheed/files/patch-ac b/mail/sylpheed/files/patch-libsylph-defs.h
index 86cde54e6a53..7881004694d3 100644
--- a/mail/sylpheed/files/patch-ac
+++ b/mail/sylpheed/files/patch-libsylph-defs.h
@@ -1,17 +1,17 @@
---- src/defs.h.orig Mon Sep 3 01:07:32 2001
-+++ src/defs.h Mon Sep 3 04:50:35 2001
-@@ -58,8 +58,8 @@
- #define MARK_VERSION 2
-
- #define DEFAULT_SIGNATURE ".signature"
+--- libsylph/defs.h.orig Tue Sep 13 16:55:49 2005
++++ libsylph/defs.h Mon Sep 19 03:23:15 2005
+@@ -81,8 +81,8 @@
+ #else
+ # define DEFAULT_SIGNATURE ".signature"
+ #endif
-#define DEFAULT_INC_PATH "/usr/bin/mh/inc"
-#define DEFAULT_INC_PROGRAM "inc"
+#define DEFAULT_INC_PATH ""
+#define DEFAULT_INC_PROGRAM ""
/* #define DEFAULT_INC_PATH "/usr/bin/imget" */
/* #define DEFAULT_INC_PROGRAM "imget" */
- #define DEFAULT_SENDMAIL_CMD "/usr/sbin/sendmail -t"
-@@ -67,7 +67,7 @@
+ #define DEFAULT_SENDMAIL_CMD "/usr/sbin/sendmail -t -i"
+@@ -91,7 +91,7 @@
#ifdef _PATH_MAILDIR
# define DEFAULT_SPOOL_PATH _PATH_MAILDIR
#else
diff --git a/mail/sylpheed/files/patch-src-printing.c b/mail/sylpheed/files/patch-src-printing.c
new file mode 100644
index 000000000000..f13f0b756bfd
--- /dev/null
+++ b/mail/sylpheed/files/patch-src-printing.c
@@ -0,0 +1,22 @@
+--- src/printing.c.orig Wed Dec 27 15:50:14 2006
++++ src/printing.c Wed Dec 27 16:28:28 2006
+@@ -149,8 +149,6 @@
+
+ desc = pango_font_description_from_string(prefs_common_get()->textfont);
+ size = pango_font_description_get_size(desc);
+- pango_font_description_free(desc);
+- desc = gtkut_get_default_font_desc();
+ pango_font_description_set_size(desc, size);
+ pango_layout_set_font_description(layout, desc);
+ pango_font_description_free(desc);
+@@ -406,10 +404,6 @@
+ }
+ g_print("count = %d\n", count);
+
+- desc = gtkut_get_default_font_desc();
+- pango_font_description_set_size(desc, font_size);
+- pango_layout_set_font_description(layout, desc);
+- pango_font_description_free(desc);
+ g_snprintf(buf, sizeof(buf), "- %d -", pinfo->page_nr_per_msg + 1);
+ pango_layout_set_text(layout, buf, -1);
+ pango_layout_set_alignment(layout, PANGO_ALIGN_CENTER);
diff --git a/mail/sylpheed/pkg-descr b/mail/sylpheed/pkg-descr
index de9e3ff200cf..67705605f74a 100644
--- a/mail/sylpheed/pkg-descr
+++ b/mail/sylpheed/pkg-descr
@@ -1,4 +1,4 @@
-Sylpheed is an e-mail client (and news reader) based on GTK+, running on
+Sylpheed is an e-mail client (and news reader) based on GTK+ 2, running on
X Window System, and aiming for:
* Quick response
* Graceful, and sophisticated interface
@@ -9,4 +9,4 @@ Currently, many features are supported including POP3, IMAP, NNTP,
multiple accounts, threading, filtering, MIME attachments, APOP, SMTP
AUTH, SSL, IPv6, GnuPG, internalization, and more.
-WWW: http://sylpheed.good-day.net/en/
+WWW: http://sylpheed.sraoss.jp/en/
diff --git a/mail/sylpheed/pkg-plist b/mail/sylpheed/pkg-plist
index 7a04dc2a0cd3..ac50c9159e9e 100644
--- a/mail/sylpheed/pkg-plist
+++ b/mail/sylpheed/pkg-plist
@@ -1,39 +1,59 @@
bin/sylpheed
+include/sylpheed/plugin.h
+include/sylpheed/sylph/account.h
+include/sylpheed/sylph/base64.h
+include/sylpheed/sylph/codeconv.h
+include/sylpheed/sylph/customheader.h
+include/sylpheed/sylph/defs.h
+include/sylpheed/sylph/displayheader.h
+include/sylpheed/sylph/enums.h
+include/sylpheed/sylph/filter.h
+include/sylpheed/sylph/folder.h
+include/sylpheed/sylph/html.h
+include/sylpheed/sylph/imap.h
+include/sylpheed/sylph/mbox.h
+include/sylpheed/sylph/md5.h
+include/sylpheed/sylph/md5_hmac.h
+include/sylpheed/sylph/mh.h
+include/sylpheed/sylph/news.h
+include/sylpheed/sylph/nntp.h
+include/sylpheed/sylph/pop.h
+include/sylpheed/sylph/prefs.h
+include/sylpheed/sylph/prefs_account.h
+include/sylpheed/sylph/prefs_common.h
+include/sylpheed/sylph/procheader.h
+include/sylpheed/sylph/procmime.h
+include/sylpheed/sylph/procmsg.h
+include/sylpheed/sylph/quoted-printable.h
+include/sylpheed/sylph/recv.h
+include/sylpheed/sylph/session.h
+include/sylpheed/sylph/smtp.h
+include/sylpheed/sylph/socket.h
+include/sylpheed/sylph/socks.h
+include/sylpheed/sylph/ssl.h
+include/sylpheed/sylph/stringtable.h
+include/sylpheed/sylph/syl-marshal.h
+include/sylpheed/sylph/sylmain.h
+include/sylpheed/sylph/unmime.h
+include/sylpheed/sylph/utils.h
+include/sylpheed/sylph/uuencode.h
+include/sylpheed/sylph/virtual.h
+include/sylpheed/sylph/xml.h
+lib/libsylph-0.la
+lib/libsylph-0.so
+lib/libsylph-0.so.2
+lib/libsylpheed-plugin-0.la
+lib/libsylpheed-plugin-0.so
+lib/libsylpheed-plugin-0.so.2
+share/applications/sylpheed.desktop
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.jp
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.ja
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.jp
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.ja
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.jp
+%%PORTDOCS%%%%DOCSDIR%%/README.ja
%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/TODO.jp
-share/locale/cs/LC_MESSAGES/sylpheed.mo
-share/locale/bg/LC_MESSAGES/sylpheed.mo
-share/locale/da/LC_MESSAGES/sylpheed.mo
-share/locale/de/LC_MESSAGES/sylpheed.mo
-share/locale/el/LC_MESSAGES/sylpheed.mo
-share/locale/es/LC_MESSAGES/sylpheed.mo
-share/locale/et/LC_MESSAGES/sylpheed.mo
-share/locale/fr/LC_MESSAGES/sylpheed.mo
-share/locale/gl/LC_MESSAGES/sylpheed.mo
-share/locale/hr/LC_MESSAGES/sylpheed.mo
-share/locale/hu/LC_MESSAGES/sylpheed.mo
-share/locale/it/LC_MESSAGES/sylpheed.mo
-share/locale/ja/LC_MESSAGES/sylpheed.mo
-share/locale/ko/LC_MESSAGES/sylpheed.mo
-share/locale/nl/LC_MESSAGES/sylpheed.mo
-share/locale/pl/LC_MESSAGES/sylpheed.mo
-share/locale/pt_BR/LC_MESSAGES/sylpheed.mo
-share/locale/ro/LC_MESSAGES/sylpheed.mo
-share/locale/ru/LC_MESSAGES/sylpheed.mo
-share/locale/sk/LC_MESSAGES/sylpheed.mo
-share/locale/sl/LC_MESSAGES/sylpheed.mo
-share/locale/sr/LC_MESSAGES/sylpheed.mo
-share/locale/sv/LC_MESSAGES/sylpheed.mo
-share/locale/tr/LC_MESSAGES/sylpheed.mo
-share/locale/uk/LC_MESSAGES/sylpheed.mo
-share/locale/zh_CN/LC_MESSAGES/sylpheed.mo
-share/locale/zh_TW.Big5/LC_MESSAGES/sylpheed.mo
+%%PORTDOCS%%%%DOCSDIR%%/TODO.ja
%%PORTDOCS%%%%DOCSDIR%%/faq/de/sylpheed-faq-1.html
%%PORTDOCS%%%%DOCSDIR%%/faq/de/sylpheed-faq-2.html
%%PORTDOCS%%%%DOCSDIR%%/faq/de/sylpheed-faq-3.html
@@ -41,6 +61,7 @@ share/locale/zh_TW.Big5/LC_MESSAGES/sylpheed.mo
%%PORTDOCS%%%%DOCSDIR%%/faq/en/sylpheed-faq-1.html
%%PORTDOCS%%%%DOCSDIR%%/faq/en/sylpheed-faq-2.html
%%PORTDOCS%%%%DOCSDIR%%/faq/en/sylpheed-faq-3.html
+%%PORTDOCS%%%%DOCSDIR%%/faq/en/sylpheed-faq-4.html
%%PORTDOCS%%%%DOCSDIR%%/faq/en/sylpheed-faq.html
%%PORTDOCS%%%%DOCSDIR%%/faq/es/sylpheed-faq-1.html
%%PORTDOCS%%%%DOCSDIR%%/faq/es/sylpheed-faq-2.html
@@ -67,6 +88,8 @@ share/locale/zh_TW.Big5/LC_MESSAGES/sylpheed.mo
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-19.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-2.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-20.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-21.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-22.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-3.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-4.html
%%PORTDOCS%%%%DOCSDIR%%/manual/en/sylpheed-5.html
@@ -88,6 +111,12 @@ share/locale/zh_TW.Big5/LC_MESSAGES/sylpheed.mo
%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-19.html
%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-2.html
%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-20.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-21.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-22.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-23.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-24.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-25.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-26.html
%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-3.html
%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-4.html
%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-5.html
@@ -96,7 +125,38 @@ share/locale/zh_TW.Big5/LC_MESSAGES/sylpheed.mo
%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-8.html
%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed-9.html
%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed.html
-%%PORTDOCS%%%%DOCSDIR%%/manual/ja/sylpheed.sgml
+share/locale/be/LC_MESSAGES/sylpheed.mo
+share/locale/bg/LC_MESSAGES/sylpheed.mo
+share/locale/cs/LC_MESSAGES/sylpheed.mo
+share/locale/da/LC_MESSAGES/sylpheed.mo
+share/locale/de/LC_MESSAGES/sylpheed.mo
+share/locale/el/LC_MESSAGES/sylpheed.mo
+share/locale/es/LC_MESSAGES/sylpheed.mo
+share/locale/et/LC_MESSAGES/sylpheed.mo
+share/locale/fi/LC_MESSAGES/sylpheed.mo
+share/locale/fr/LC_MESSAGES/sylpheed.mo
+share/locale/gl/LC_MESSAGES/sylpheed.mo
+share/locale/hr/LC_MESSAGES/sylpheed.mo
+share/locale/hu/LC_MESSAGES/sylpheed.mo
+share/locale/it/LC_MESSAGES/sylpheed.mo
+share/locale/ja/LC_MESSAGES/sylpheed.mo
+share/locale/ko/LC_MESSAGES/sylpheed.mo
+share/locale/lt/LC_MESSAGES/sylpheed.mo
+share/locale/nl/LC_MESSAGES/sylpheed.mo
+share/locale/pl/LC_MESSAGES/sylpheed.mo
+share/locale/pt_BR/LC_MESSAGES/sylpheed.mo
+share/locale/ro/LC_MESSAGES/sylpheed.mo
+share/locale/ru/LC_MESSAGES/sylpheed.mo
+share/locale/sk/LC_MESSAGES/sylpheed.mo
+share/locale/sl/LC_MESSAGES/sylpheed.mo
+share/locale/sr/LC_MESSAGES/sylpheed.mo
+share/locale/sv/LC_MESSAGES/sylpheed.mo
+share/locale/tr/LC_MESSAGES/sylpheed.mo
+share/locale/uk/LC_MESSAGES/sylpheed.mo
+share/locale/vi/LC_MESSAGES/sylpheed.mo
+share/locale/zh_CN/LC_MESSAGES/sylpheed.mo
+share/locale/zh_TW/LC_MESSAGES/sylpheed.mo
+share/pixmaps/sylpheed.png
%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/ja
%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/en
%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual
@@ -107,3 +167,6 @@ share/locale/zh_TW.Big5/LC_MESSAGES/sylpheed.mo
%%PORTDOCS%%@dirrm %%DOCSDIR%%/faq/de
%%PORTDOCS%%@dirrm %%DOCSDIR%%/faq
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications
+@dirrm include/sylpheed/sylph
+@dirrm include/sylpheed