aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-10-24 23:11:40 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-10-24 23:11:40 +0800
commit646e34d0f731d9d664f2653567981f9a3661f058 (patch)
tree507f5b6d7d05ba03a114f9b2031886e90ed6cf4b /mail
parent657e94aff744f4f977d719d350d2d10fbb9fd42b (diff)
downloadfreebsd-ports-gnome-646e34d0f731d9d664f2653567981f9a3661f058.tar.gz
freebsd-ports-gnome-646e34d0f731d9d664f2653567981f9a3661f058.tar.zst
freebsd-ports-gnome-646e34d0f731d9d664f2653567981f9a3661f058.zip
Support staging.
Diffstat (limited to 'mail')
-rw-r--r--mail/cyrus2courier/Makefile3
-rw-r--r--mail/delatt/Makefile3
-rw-r--r--mail/spfval/Makefile3
-rw-r--r--mail/sylpheed/Makefile11
4 files changed, 8 insertions, 12 deletions
diff --git a/mail/cyrus2courier/Makefile b/mail/cyrus2courier/Makefile
index 45942ef8d863..aa41e68005f8 100644
--- a/mail/cyrus2courier/Makefile
+++ b/mail/cyrus2courier/Makefile
@@ -15,12 +15,11 @@ ALL_TARGET= build
PLIST_FILES= bin/cyrus2courier
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} '/^CFLAGS*/d; /^LDFLAGS*/d; /^CC*/d' \
${WRKSRC}/src/Makefile.FreeBSD
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/mail/delatt/Makefile b/mail/delatt/Makefile
index 6b46d8889b17..00a88a729410 100644
--- a/mail/delatt/Makefile
+++ b/mail/delatt/Makefile
@@ -21,8 +21,7 @@ NO_BUILD= yes
SHEBANG_FILES= delatt
PLIST_FILES= bin/delatt
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/mail/spfval/Makefile b/mail/spfval/Makefile
index 52a009ddd643..6d56abe84033 100644
--- a/mail/spfval/Makefile
+++ b/mail/spfval/Makefile
@@ -15,8 +15,7 @@ MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/spfval
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/spfval ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/spfval ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 1861637697d0..75f0464d81db 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -40,7 +40,6 @@ ONIGURUMA_DESC= Oniguruma support
OPTIONS_DEFAULT=SSL GTKSPELL
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
@@ -124,13 +123,13 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ChangeLog INSTALL README TODO
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/${i}.ja ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${i}.ja ${STAGEDIR}${DOCSDIR}
.endfor
.endif
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${PREFIX}/share/pixmaps/
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.desktop ${PREFIX}/share/applications/
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed.desktop ${STAGEDIR}${PREFIX}/share/applications/
.include <bsd.port.mk>