aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-06-19 01:12:47 +0800
committerleeym <leeym@FreeBSD.org>2004-06-19 01:12:47 +0800
commit941ddccd03e207e59a2e711a769b3d1737b47077 (patch)
treeb79e396f9486dc4a230fc2d42407beb3471f8582 /mail
parente841f4409c61b76282d3e56ec15410f01e4fe87c (diff)
downloadfreebsd-ports-gnome-941ddccd03e207e59a2e711a769b3d1737b47077.tar.gz
freebsd-ports-gnome-941ddccd03e207e59a2e711a769b3d1737b47077.tar.zst
freebsd-ports-gnome-941ddccd03e207e59a2e711a769b3d1737b47077.zip
- add missing dependency to devel/p5-TimeDate
- set p5-PodParser as a conditional dependency - bump PORTREVISION PR: 68070 Submitted by: Franz Klammer <klammer@webonaut.com>, leeym Reviewed by: Franz Klammer <klammer@webonaut.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/msgconvert/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/mail/msgconvert/Makefile b/mail/msgconvert/Makefile
index 2acc07db08f0..3d0907cbef44 100644
--- a/mail/msgconvert/Makefile
+++ b/mail/msgconvert/Makefile
@@ -7,6 +7,7 @@
PORTNAME= msgconvert
PORTVERSION= 20040531
+PORTREVISION= 1
CATEGORIES= mail perl5
MASTER_SITES= http://www.webonaut.com/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION}.pl
@@ -17,17 +18,23 @@ COMMENT= Convert .MSG files to multipart MIME messages (mbox)
RUN_DEPENDS= ${SITE_PERL}/OLE/Storage_Lite.pm:${PORTSDIR}/devel/p5-OLE-Storage_Lite \
${SITE_PERL}/MIME/Words.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+ ${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_BZIP2= yes
USE_PERL5= yes
-EXTRACT_AFTER_ARGS= > ${PORTNAME}.pl
+EXTRACT_AFTER_ARGS= > ${PORTNAME}.pl
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}.pl
${LN} -s ${PREFIX}/bin/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+RUN_DEPENDS+= ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
+.endif
+
+.include <bsd.port.post.mk>