aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2009-05-31 07:27:22 +0800
committergabor <gabor@FreeBSD.org>2009-05-31 07:27:22 +0800
commit949c576314ceb7d291e6ff2836428f6b8f7e297f (patch)
treee5fe95b09dd85217f4272948a700c221a54db62d /mail
parent0e015b042104c0efd2e220906e1a86bb94f4e42c (diff)
downloadfreebsd-ports-gnome-949c576314ceb7d291e6ff2836428f6b8f7e297f.tar.gz
freebsd-ports-gnome-949c576314ceb7d291e6ff2836428f6b8f7e297f.tar.zst
freebsd-ports-gnome-949c576314ceb7d291e6ff2836428f6b8f7e297f.zip
- Fixing 3 issues:
#1 There were problems with p5-Mail-DKIM 0.33, requiring >=0.34 [1] #2, running spamassassin via procmail could close without generating a error code [1] [2] #3, compiling spamc/spamd with NON base, ie PORTS openssl would fail. patch to makefile to include CFLAGS [1] [3] - Bump PORTREVISION PR: ports/135001 [1], ports/134552 [2] Submitted by: Michael Scheidell <scheidell@secnap.net> (maintainer) [1], Eric van Gyzen <eric@vangyzen.net> [2], olivier [3]
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile8
-rw-r--r--mail/p5-Mail-SpamAssassin/files/patch-spamassassin.raw12
2 files changed, 17 insertions, 3 deletions
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index ab47d58374d1..5812f2861e4f 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Mail-SpamAssassin
PORTVERSION= 3.2.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_APACHE:S/$/:apache/} ${MASTER_SITE_PERL_CPAN:S/$/:cpan/}
MASTER_SITE_SUBDIR= spamassassin/source/:apache Mail/:cpan
@@ -98,7 +98,7 @@ RUN_DEPENDS+= razor-agents>=2.84:${PORTSDIR}/mail/razor-agents
.endif
.if defined(WITH_DKIM)
-RUN_DEPENDS+= p5-Mail-DKIM>=0.33:${PORTSDIR}/mail/p5-Mail-DKIM
+RUN_DEPENDS+= p5-Mail-DKIM>=0.34:${PORTSDIR}/mail/p5-Mail-DKIM
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
RUN_DEPENDS+= p5-Crypt-OpenSSL-RSA>=0.24:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA
.endif
@@ -207,7 +207,9 @@ post-patch:
-e 's#B_CONFDIR)/v320.pre#B_CONFDIR)/v320.pre.sample#g' \
-e 's/require DBI/0/' \
${WRKSRC}/Makefile.PL
- @${REINPLACE_CMD} -e '/^CC =/d' ${WRKSRC}/spamc/Makefile.in
+ @${REINPLACE_CMD} -e '/^CC =/d; \
+ s|@SSLCFLAGS@|& $${CFLAGS}|g' ${WRKSRC}/spamc/Makefile.in
+
.if defined(WITH_RAZOR)
${REINPLACE_CMD} -e '/Razor2/s/^#loadplugin/loadplugin/' ${WRKSRC}/rules/v312.pre
diff --git a/mail/p5-Mail-SpamAssassin/files/patch-spamassassin.raw b/mail/p5-Mail-SpamAssassin/files/patch-spamassassin.raw
new file mode 100644
index 000000000000..c2300b8d4a04
--- /dev/null
+++ b/mail/p5-Mail-SpamAssassin/files/patch-spamassassin.raw
@@ -0,0 +1,12 @@
+--- spamassassin.raw.orig 2009-05-14 20:48:01.000000000 -0500
++++ spamassassin.raw 2009-05-14 20:48:19.000000000 -0500
+@@ -530,7 +530,7 @@
+ $mail->finish(); # bug 5626: remove temp files etc.
+ $mail = undef;
+ }
+- exit 0;
++ exit 15;
+ }
+
+ # ---------------------------------------------------------------------------
+