aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2012-04-09 16:13:35 +0800
committercrees <crees@FreeBSD.org>2012-04-09 16:13:35 +0800
commit94e6a9775ba62ac13a2808791dc38ce2add3c5f0 (patch)
treec3549e6fd015122c3c74f29f6573aee584f7db0f /mail
parent071b810c4f7d553595e6c65d79079c7947607377 (diff)
downloadfreebsd-ports-gnome-94e6a9775ba62ac13a2808791dc38ce2add3c5f0.tar.gz
freebsd-ports-gnome-94e6a9775ba62ac13a2808791dc38ce2add3c5f0.tar.zst
freebsd-ports-gnome-94e6a9775ba62ac13a2808791dc38ce2add3c5f0.zip
A number of tools and scripts for use with IMAP servers.
This software is a fork of Rick Sanders' imaptools which became not free now. WWW: http://code.google.com/p/imaputils/ Submitted by: Mikhail Tsatsenko (m.tsatsenko@gmail.com) Feature safe: yes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/imaputils/Makefile30
-rw-r--r--mail/imaputils/distinfo2
-rw-r--r--mail/imaputils/pkg-descr5
-rw-r--r--mail/imaputils/pkg-plist22
5 files changed, 60 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index c36ec5da47a3..41ddf9580e1c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -207,6 +207,7 @@
SUBDIR += imapfilter
SUBDIR += imapsync
SUBDIR += imaptools
+ SUBDIR += imaputils
SUBDIR += isbg
SUBDIR += isoqlog
SUBDIR += isync
diff --git a/mail/imaputils/Makefile b/mail/imaputils/Makefile
new file mode 100644
index 000000000000..20ecf0d4e659
--- /dev/null
+++ b/mail/imaputils/Makefile
@@ -0,0 +1,30 @@
+# Ports collection Makefile for: mail/imaputils
+# Date created: 2012-04-08
+# Whom: Mikhail T. (m.tsatsenko@gmail.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= imaputils
+PORTVERSION= 1.0.0
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= m.tsatsenko@gmail.com
+COMMENT= A number of tools and scripts for use with IMAP servers
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e 's|/usr/bin/perl|${PERL}|g' ${WRKSRC}/*.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/mail/imaputils/distinfo b/mail/imaputils/distinfo
new file mode 100644
index 000000000000..83d26debf8e3
--- /dev/null
+++ b/mail/imaputils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (imaputils-1.0.0.tar.gz) = 5ac3b6d30ecb501c3c8d5def83fa52409a13214c4d6c7eea176b4d31eda4270e
+SIZE (imaputils-1.0.0.tar.gz) = 106020
diff --git a/mail/imaputils/pkg-descr b/mail/imaputils/pkg-descr
new file mode 100644
index 000000000000..99d818642628
--- /dev/null
+++ b/mail/imaputils/pkg-descr
@@ -0,0 +1,5 @@
+A number of tools and scripts for use with IMAP servers.
+This software is a fork of Rick Sanders' imaptools
+which became not free now.
+
+WWW: http://code.google.com/p/imaputils/
diff --git a/mail/imaputils/pkg-plist b/mail/imaputils/pkg-plist
new file mode 100644
index 000000000000..9cf0a865ae04
--- /dev/null
+++ b/mail/imaputils/pkg-plist
@@ -0,0 +1,22 @@
+bin/IMAPtoMbox.pl
+bin/MboxtoIMAP.pl
+bin/delIMAPdups.pl
+bin/delete_imap_mailboxes.pl
+bin/dumptoIMAP.pl
+bin/imapCapability.pl
+bin/imapPing.pl
+bin/imap_to_maildir.pl
+bin/imapcopy.pl
+bin/imapdump.pl
+bin/imapfilter.pl
+bin/imapsync.pl
+bin/list_folders.pl
+bin/list_imap_folders.pl
+bin/maildir_to_imap.pl
+bin/mbxIMAPsync.pl
+bin/migrateIMAP-win.pl
+bin/migrateIMAP.pl
+bin/mozillatoIMAP.pl
+bin/pop3toimap.pl
+bin/purgeMbx.pl
+bin/trash.pl