aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2014-03-02 00:08:54 +0800
committeroliver <oliver@FreeBSD.org>2014-03-02 00:08:54 +0800
commita40aeb0b732d920bee94545abd4ed4a5dc497136 (patch)
tree4aca46f07fb3d3f7be2fe4e181ded34ccad4829c /mail
parent13e9779869d2ee100df15a26c2edd0b951834bb1 (diff)
downloadfreebsd-ports-gnome-a40aeb0b732d920bee94545abd4ed4a5dc497136.tar.gz
freebsd-ports-gnome-a40aeb0b732d920bee94545abd4ed4a5dc497136.tar.zst
freebsd-ports-gnome-a40aeb0b732d920bee94545abd4ed4a5dc497136.zip
add GNUTILS option
PR: ports/183705 Submitted by: madpilot
Diffstat (limited to 'mail')
-rw-r--r--mail/courier-imap/Makefile31
-rw-r--r--mail/courier-imap/pkg-descr2
-rw-r--r--mail/courier-imap/pkg-plist10
3 files changed, 27 insertions, 16 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 04f4b06d50d2..5e06eac6715e 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -3,6 +3,7 @@
PORTNAME= courier-imap
PORTVERSION= 4.15
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= mail ipv6
MASTER_SITES= SF/courier/imap/${PORTVERSION}
@@ -26,15 +27,15 @@ CONFIGURE_ENV= REHASH=${SCRIPTDIR}/c_rehash
MAKE_ENV:= ${CONFIGURE_ENV}
#
-NO_STAGE= yes
# options available:
#
# WITH_SYSLOG_FACILITY: The syslogfacility to use
#
-OPTIONS_DEFINE= FAM TRASHQUOTA GDBM IPV6
+OPTIONS_DEFINE= FAM TRASHQUOTA GDBM IPV6 GNUTLS
FAM_DESC= Fam support for IDLE command
TRASHQUOTA_DESC= Include deleted mails in the quota
+GNUTLS_DESC= Use GnuTLS instead of OpenSSL (Enables SNI)
FAM_USES= fam
.if exists(${.CURDIR}/../../security/courier-authlib/Makefile.opt)
@@ -57,6 +58,14 @@ CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
--with-locking-method=fcntl \
COURIERAUTHCONFIG=${PREFIX}/bin/courierauthconfig
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNUTLS}
+CONFIGURE_ARGS+=--with-gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
+USES+= pkgconfig
+.endif
+
.include <bsd.port.pre.mk>
.if exists(${.CURDIR}/../../security/courier-authlib/Makefile.dep)
@@ -70,7 +79,7 @@ CONFIGURE_ARGS+=--with-syslog=${WITH_SYSLOG_FACILITY}
.if ${PORT_OPTIONS:MAUTH_USERDB}
.if ${PORT_OPTIONS:MGDBM}
CONFIGURE_ARGS+=--with-db=gdbm --with-userdb=${USERDB}
-LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
.else
CONFIGURE_ARGS+=--with-db=db --with-userdb=${USERDB}
.endif
@@ -89,11 +98,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.endif
-MAN1= couriertcpd.1 maildiracl.1 maildirkw.1 \
- maildirmake.1
-
-MAN8= deliverquota.8 imapd.8 mkimapdcert.8 mkpop3dcert.8 mkdhparams.8
-
EXTRA_DOCS= AUTHORS INSTALL NEWS \
libs/imap/ChangeLog \
libs/imap/README \
@@ -121,16 +125,15 @@ post-patch:
post-install:
.for i in imapd pop3d
- ${INSTALL_DATA} ${WRKSRC}/libs/imap/${i}.cnf ${CONFDIR}/${i}.cnf.dist
+ ${INSTALL_DATA} ${WRKSRC}/libs/imap/${i}.cnf ${STAGEDIR}${CONFDIR}/${i}.cnf.dist
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for a in ${EXTRA_DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${a} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${a} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- cd ${WRKSRC} && ( ${GMAKE} install-configure ; cd - )
+ cd ${WRKSRC} && ( ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} \
+ install-configure ; cd - )
@${ECHO_MSG} "In case you use authpam, you should put the following lines"
@${ECHO_MSG} "in your /etc/pam.d/imap"
diff --git a/mail/courier-imap/pkg-descr b/mail/courier-imap/pkg-descr
index 0f11bac586ac..73c91db9bef2 100644
--- a/mail/courier-imap/pkg-descr
+++ b/mail/courier-imap/pkg-descr
@@ -16,4 +16,4 @@ Features:
* Virtual mailbox support.
* Pop3 daemon.
-WWW: http://www.courier-mta.org/imap/
+WWW: http://www.courier-mta.org/imap/
diff --git a/mail/courier-imap/pkg-plist b/mail/courier-imap/pkg-plist
index ebc86360a2d8..c0a69db0a985 100644
--- a/mail/courier-imap/pkg-plist
+++ b/mail/courier-imap/pkg-plist
@@ -28,6 +28,15 @@ bin/pop3d
%%LIBEXECDIR%%/makedatprog
%%LIBEXECDIR%%/pop3d-ssl.rc
%%LIBEXECDIR%%/pop3d.rc
+man/man1/couriertcpd.1.gz
+man/man1/maildiracl.1.gz
+man/man1/maildirkw.1.gz
+man/man1/maildirmake.1.gz
+man/man8/deliverquota.8.gz
+man/man8/imapd.8.gz
+man/man8/mkdhparams.8.gz
+man/man8/mkimapdcert.8.gz
+man/man8/mkpop3dcert.8.gz
sbin/imaplogin
sbin/mkdhparams
sbin/mkimapdcert
@@ -54,7 +63,6 @@ share/courier-imap/mkpop3dcert
@dirrmtry var
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/courier-imap
-@dirrmtry %%LIBEXECDIR%%/authlib
@dirrm %%LIBEXECDIR%%
@dirrm %%CONFDIR%%/shared
@dirrm %%CONFDIR%%/shared.tmp