aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2005-05-23 22:27:20 +0800
committermat <mat@FreeBSD.org>2005-05-23 22:27:20 +0800
commita4cc3a1be8059270344f4d36db6adafa9f38b7dc (patch)
tree18ebe99c54219b8bfc4f167133862d249086e518 /mail
parentbe135d6f0ff28ae56b918b54e9415203270a6484 (diff)
downloadfreebsd-ports-gnome-a4cc3a1be8059270344f4d36db6adafa9f38b7dc.tar.gz
freebsd-ports-gnome-a4cc3a1be8059270344f4d36db6adafa9f38b7dc.tar.zst
freebsd-ports-gnome-a4cc3a1be8059270344f4d36db6adafa9f38b7dc.zip
Fix sqlgrey.conf's path in sqlgrey.sh [1]
fixup a few other things while I'm there bump PORTREVISION Poked by: flz [1]
Diffstat (limited to 'mail')
-rw-r--r--mail/sqlgrey/Makefile5
-rw-r--r--mail/sqlgrey/files/sqlgrey.sh.in3
2 files changed, 5 insertions, 3 deletions
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 4258498cffa7..7cf8312c4787 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sqlgrey
PORTVERSION= 1.4.5
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -38,7 +39,7 @@ SGY_GROUPNAME?= ${SGY_USERNAME}
ETCDIR?= etc/sqlgrey
SUB_FILES= pkg-install
-MY_SUB_LIST= ETCDIR=${ETCDIR} ETCFILES="${ETCFILES}" USER=${SGY_USERNAME} GROUP=${SGY_GROUPNAME}
+MY_SUB_LIST= ETCDIR=${ETCDIR} ETCFILES="${ETCFILES}" USER=${SGY_USERNAME} GROUP=${SGY_GROUPNAME} PERL=${PERL}
SUB_LIST= ${MY_SUB_LIST}
PLIST_SUB= TOUCH=${TOUCH} ${MY_SUB_LIST}
@@ -56,7 +57,7 @@ pre-everything::
@${ECHO_MSG} " WITH_PGSQL, WITH_MYSQL, or WITH_SQLITE"
post-patch:
- @${REINPLACE_CMD} -e 's!/etc/sqlgrey!${PREFIX}/${ETCDIR}!g' ${WRKSRC}/sqlgrey
+ @${REINPLACE_CMD} -e 's-#!/usr/bin/perl-#!${PERL}-' -e 's!/etc/sqlgrey!${PREFIX}/${ETCDIR}!g' ${WRKSRC}/sqlgrey
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/sqlgrey ${PREFIX}/sbin
diff --git a/mail/sqlgrey/files/sqlgrey.sh.in b/mail/sqlgrey/files/sqlgrey.sh.in
index 02f26b4ec524..b755237cf1b2 100644
--- a/mail/sqlgrey/files/sqlgrey.sh.in
+++ b/mail/sqlgrey/files/sqlgrey.sh.in
@@ -22,6 +22,7 @@ rcvar=`set_rcvar`
command=%%PREFIX%%/sbin/sqlgrey
extra_commands=reload
+command_interpreter=%%PERL%%
stop_postcmd=stop_postcmd
@@ -35,7 +36,7 @@ stop_postcmd()
sqlgrey_enable=${sqlgrey_enable:-"NO"}
sqlgrey_pidfile=${sqlgrey_pidfile:-"/var/run/sqlgrey.pid"}
sqlgrey_listen=${sqlgrey_listen:-"2501"}
-sqlgrey_config=${sqlgrey_config:-"/usr/local/etc/sqlgrey.conf"}
+sqlgrey_config=${sqlgrey_config:-"/usr/local/%%ETCDIR%%/sqlgrey.conf"}
sqlgrey_flags=${sqlgrey_flags:-"--pidfile=${sqlgrey_pidfile} \
--inet=${sqlgrey_listen} --daemonize --user=sqlgrey --group=sqlgrey \
--configfile=${sqlgrey_config}"}