aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-04 22:42:03 +0800
committerpav <pav@FreeBSD.org>2005-05-04 22:42:03 +0800
commita57b2431d5f8fa45ebc3ddc27de1b16c9c30a118 (patch)
tree725a7b7a5a7204bf210f94b61661f4fb82e7da04 /mail
parent57a79e496b4f2a753e11a8e142cf1657b89c7281 (diff)
downloadfreebsd-ports-gnome-a57b2431d5f8fa45ebc3ddc27de1b16c9c30a118.tar.gz
freebsd-ports-gnome-a57b2431d5f8fa45ebc3ddc27de1b16c9c30a118.tar.zst
freebsd-ports-gnome-a57b2431d5f8fa45ebc3ddc27de1b16c9c30a118.zip
ProxSMTP is a flexible tool that allows you to reject, change or log
email based on arbitrary critera. It accepts SMTP connections and forwards the SMTP commands and responses to another SMTP server. You need to be able to write the filtering scripts that integrate it with your particular needs. PR: ports/80596 Submitted by: Dario Freni <saturnero@gufi.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/proxsmtp/Makefile41
-rw-r--r--mail/proxsmtp/distinfo2
-rw-r--r--mail/proxsmtp/files/patch-configure11
-rw-r--r--mail/proxsmtp/files/pkg-message.in14
-rw-r--r--mail/proxsmtp/files/proxsmtpd.sh.in30
-rw-r--r--mail/proxsmtp/pkg-descr8
-rw-r--r--mail/proxsmtp/pkg-plist4
8 files changed, 111 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 20129b05f1b0..a5c4fb5c9f88 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -371,6 +371,7 @@
SUBDIR += prom-mew
SUBDIR += prom-wl
SUBDIR += pronto
+ SUBDIR += proxsmtp
SUBDIR += py-milter
SUBDIR += py-mimelib
SUBDIR += py-spambayes
diff --git a/mail/proxsmtp/Makefile b/mail/proxsmtp/Makefile
new file mode 100644
index 000000000000..029fb002445d
--- /dev/null
+++ b/mail/proxsmtp/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: proxsmtp
+# Date created: 2005-05-03
+# Whom: Dario Freni <saturnero@gufi.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= proxsmtp
+PORTVERSION= 1.2.1
+CATEGORIES= mail security
+MASTER_SITES= http://memberwebs.com/nielsen/software/proxsmtp/
+
+MAINTAINER= saturnero@gufi.org
+COMMENT= A flexible SMTP filter which can act also as trasparent proxy
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_RC_SUBR= proxsmtpd.sh
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+MAN5= proxsmtpd.conf.5
+MAN8= proxsmtpd.8
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS}," ${WRKSRC}/configure
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/doc/proxsmtpd.conf ${PREFIX}/etc/proxsmtpd.conf-sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/proxsmtp/distinfo b/mail/proxsmtp/distinfo
new file mode 100644
index 000000000000..e3c21d0f3d5e
--- /dev/null
+++ b/mail/proxsmtp/distinfo
@@ -0,0 +1,2 @@
+MD5 (proxsmtp-1.2.1.tar.gz) = 7af2d5feafb1386934d347a5f5dc827e
+SIZE (proxsmtp-1.2.1.tar.gz) = 156525
diff --git a/mail/proxsmtp/files/patch-configure b/mail/proxsmtp/files/patch-configure
new file mode 100644
index 000000000000..5d025d1c5658
--- /dev/null
+++ b/mail/proxsmtp/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Apr 15 07:18:10 2005
++++ configure Wed Apr 20 15:45:54 2005
+@@ -3156,7 +3156,7 @@
+ # which indicates that we try without any flags at all, and "pthread-config"
+ # which is a program returning the flags for the Pth emulation library.
+
+-acx_pthread_flags="pthreads none -Kthread -kthread lthread -pthread -pthreads -mthreads pthread --thread-safe -mt pthread-config"
++acx_pthread_flags="pthreads none -Kthread -kthread %%PTHREAD_LIBS%% -pthreads lthread -mthreads pthread --thread-safe -mt pthread-config"
+
+ # The ordering *is* (sometimes) important. Some notes on the
+ # individual items follow:
diff --git a/mail/proxsmtp/files/pkg-message.in b/mail/proxsmtp/files/pkg-message.in
new file mode 100644
index 000000000000..360c370288b8
--- /dev/null
+++ b/mail/proxsmtp/files/pkg-message.in
@@ -0,0 +1,14 @@
+/* ================================================================= */
+Edit /etc/rc.conf and set
+
+proxsmtpd_enable="YES"
+
+to enable proxsmtpd.
+
+Also, there is a proxsmtpd.conf-sample in %%PREFIX%%/etc/,
+rename to proxsmtpd.conf, otherwise specify -f option to your
+config file.
+
+To work with postfix, See also
+http://memberwebs.com/nielsen/software/proxsmtp/postfix.html
+/* ================================================================= */
diff --git a/mail/proxsmtp/files/proxsmtpd.sh.in b/mail/proxsmtp/files/proxsmtpd.sh.in
new file mode 100644
index 000000000000..378453bce74e
--- /dev/null
+++ b/mail/proxsmtp/files/proxsmtpd.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: proxsmtpd
+# REQUIRE: DAEMON
+# KEYWORD: FreeBSD
+#
+# Add the fellowing line to /etc/rc.conf to enable proxsmtpd:
+#
+# proxsmtpd_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=proxsmtpd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/${name}
+sig_stop=-KILL
+
+load_rc_config ${name}
+
+proxsmtpd_enable=${proxsmtpd_enable-"NO"}
+proxsmtpd_conf=${proxsmtpd_conf-"%%PREFIX%%/etc/proxsmtpd.conf"}
+proxsmtpd_debug=${proxsmtpd_debug-"0"}
+
+command_args="-f ${proxsmtpd_conf}"
+
+run_rc_command "$1"
diff --git a/mail/proxsmtp/pkg-descr b/mail/proxsmtp/pkg-descr
new file mode 100644
index 000000000000..b129758a7d7d
--- /dev/null
+++ b/mail/proxsmtp/pkg-descr
@@ -0,0 +1,8 @@
+ProxSMTP is a flexible tool that allows you to reject, change or log
+email based on arbitrary critera. It accepts SMTP connections and
+forwards the SMTP commands and responses to another SMTP server. You
+need to be able to write the filtering scripts that integrate it with
+your particular needs.
+
+Author: Nielsen <nielsen at memberwebs.com>
+WWW: http://memberwebs.com/nielsen/software/proxsmtp/
diff --git a/mail/proxsmtp/pkg-plist b/mail/proxsmtp/pkg-plist
new file mode 100644
index 000000000000..4a0746965168
--- /dev/null
+++ b/mail/proxsmtp/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+@unexec [ ! -f /var/run/proxsmtpd.pid ] || %%PREFIX%%/etc/rc.d/proxsmtpd.sh stop || true
+etc/proxsmtpd.conf-sample
+sbin/proxsmtpd