aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-12-29 23:46:13 +0800
committercrees <crees@FreeBSD.org>2013-12-29 23:46:13 +0800
commitb426718713599e9ce79dadf5246f683f947aae5b (patch)
treebb6bf1e587f12ca3332817bdb17d2c60f9834051 /mail
parent70bd9953a7522088bd1c8a8ffca5b0d497189c8f (diff)
downloadfreebsd-ports-gnome-b426718713599e9ce79dadf5246f683f947aae5b.tar.gz
freebsd-ports-gnome-b426718713599e9ce79dadf5246f683f947aae5b.tar.zst
freebsd-ports-gnome-b426718713599e9ce79dadf5246f683f947aae5b.zip
Stage ports maintained by me in irc java mail
Cleanups in several places
Diffstat (limited to 'mail')
-rw-r--r--mail/biabam/Makefile9
-rw-r--r--mail/biabam/files/patch-biabam2
-rw-r--r--mail/sympa/Makefile19
-rw-r--r--mail/sympa/files/pkg-install.in7
-rw-r--r--mail/sympa/pkg-descr2
-rw-r--r--mail/sympa/pkg-plist4
6 files changed, 23 insertions, 20 deletions
diff --git a/mail/biabam/Makefile b/mail/biabam/Makefile
index 9cf41efef438..f637586e55df 100644
--- a/mail/biabam/Makefile
+++ b/mail/biabam/Makefile
@@ -17,13 +17,10 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
NO_BUILD= yes
PLIST_FILES= bin/biabam
-
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e '1s|\(#!\)\(/bin/bash\)|\1${LOCALBASE}\2|' \
- ${WRKSRC}/${PORTNAME}
+USES= shebangfix
+SHEBANG_FILES=${PORTNAME}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/biabam ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/biabam ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/mail/biabam/files/patch-biabam b/mail/biabam/files/patch-biabam
index aa6a16ac80a6..0bf2df023ddf 100644
--- a/mail/biabam/files/patch-biabam
+++ b/mail/biabam/files/patch-biabam
@@ -1,3 +1,5 @@
+Note: the jot parts can be removed when 8.x is no longer supported
+
--- biabam.orig Tue Dec 21 00:08:38 2004
+++ biabam Tue Dec 21 00:10:02 2004
@@ -33,15 +33,15 @@
diff --git a/mail/sympa/Makefile b/mail/sympa/Makefile
index b6c883cd1876..ecfac9ccf775 100644
--- a/mail/sympa/Makefile
+++ b/mail/sympa/Makefile
@@ -40,8 +40,10 @@ RUN_DEPENDS+= \
# Ignore alpha/beta versions
PORTSCOUT= limit:^[0-9]+(\.[0-9]+)*$$
+NEED_ROOT= yes
USERS= sympa
GROUPS= sympa
+# Shebang is corrected by configure script
USES= perl5
GNU_CONFIGURE= yes
ICONSDIR?= www/icons
@@ -62,11 +64,10 @@ CONFIGURE_ARGS+=--bindir=${PREFIX}/libexec/${PORTNAME} \
CONFIGURE_ENV+= lt_cv_sys_max_cmd_len=${CONFIGURE_MAX_CMD_LEN}
MAKE_ENV?= PERL_EXTUTILS_AUTOINSTALL=--skip
SUB_FILES= pkg-install
+SUB_LIST= DB_TYPE=${DB_TYPE:L} WITH_FASTCGI=${PORT_OPTIONS:MFASTCGI}
USE_RC_SUBR= sympa
-MAN8= alias_manager.8 archived.8 bounced.8 sympa.8
-
CONFLICTS= sympa-5*
OPTIONS_DEFINE= FASTCGI APACHE
@@ -86,7 +87,6 @@ OPTIONS_SET+= ${option}
. endfor
.endif
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -107,19 +107,20 @@ RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fa
.if ${PORT_OPTIONS:MORACLE}
RUN_DEPENDS+= p5-DBD-Oracle>=0:${PORTSDIR}/databases/p5-DBD-Oracle
+DB_TYPE= oracle
.elif ${PORT_OPTIONS:MPGSQL}
SUB_LIST+= REQ_MYSQL="" REQ_PGSQL=postgresql
RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
+DB_TYPE= pg
.elif ${PORT_OPTIONS:MSYBASE}
RUN_DEPENDS+= p5-DBD-Sybase>=0:${PORTSDIR}/databases/p5-DBD-Sybase
+DB_TYPE= sybase
.elif ${PORT_OPTIONS:MMYSQL}
SUB_LIST+= REQ_MYSQL=mysql REQ_PGSQL=""
RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
+DB_TYPE= mysql
.endif
-pre-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-patch:
@${REINPLACE_CMD} -e 's|^\( *staticdir=\).*$$|\1${DATADIR}|' \
-e 's|^\( *defaultdir=\).*$$|\1${EXAMPLESDIR}|' \
@@ -129,11 +130,7 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|\(--target.*sympa.conf\)|\1.sample|' \
${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's/\$$(DESTDIR)\$$(sampledir)/\$$(sampledir)/g' \
+ @${REINPLACE_CMD} -e 's#\$$(DESTDIR)\$$(sampledir)#${STAGEDIR}\$$(sampledir)#g' \
${WRKSRC}/doc/sample/Makefile.in
-post-install:
- @PKG_PREFIX=${PREFIX} DB_TYPE=${DB_TYPE} WITH_FASTCGI=${WITH_FASTCGI} \
- ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
.include <bsd.port.mk>
diff --git a/mail/sympa/files/pkg-install.in b/mail/sympa/files/pkg-install.in
index 0110e8a58db0..dbc28bfe62f2 100644
--- a/mail/sympa/files/pkg-install.in
+++ b/mail/sympa/files/pkg-install.in
@@ -2,10 +2,13 @@
# $FreeBSD$
#
+DB_TYPE=%%DB_TYPE%%
+WITH_FASTCGI=%%WITH_FASTCGI%%
+
case $2 in
POST-INSTALL)
echo "======================================================"
- if [ x"${DB_TYPE}" != "x" ]; then
+ if [ -n "${DB_TYPE}" ]; then
echo "If this is your first installation of sympa, please load"
echo "this file with your ${DB_TYPE} database client:"
echo " %%PREFIX%%/libexec/sympa/create_db.${DB_TYPE}"
@@ -32,7 +35,7 @@ POST-INSTALL)
echo " AddDefaultCharset UTF-8"
echo " DirectoryIndex wws"
echo " Options +Indexes"
- if [ x"${WITH_FASTCGI}" != x ]; then
+ if [ -n "${WITH_FASTCGI}" ]; then
echo " LoadModule fastcgi_module libexec/apache2/mod_fastcgi.so"
echo " <Location /wws>"
echo " SetHandler fastcgi-script"
diff --git a/mail/sympa/pkg-descr b/mail/sympa/pkg-descr
index 890461cd9c01..f47c2f9972ba 100644
--- a/mail/sympa/pkg-descr
+++ b/mail/sympa/pkg-descr
@@ -9,4 +9,4 @@ lists. For a list with 20 000 subscribers, it takes 5 minutes to send a
message to 90% of subscribers, of course considering that the network is
available.
-WWW: http://www.sympa.org/
+WWW: http://www.sympa.org/
diff --git a/mail/sympa/pkg-plist b/mail/sympa/pkg-plist
index 6598e3b89c06..62c6d96cb347 100644
--- a/mail/sympa/pkg-plist
+++ b/mail/sympa/pkg-plist
@@ -78,6 +78,10 @@ libexec/sympa/virtualwrapper
libexec/sympa/wwslib.pm
libexec/sympa/wwsympa-wrapper.fcgi
libexec/sympa/wwsympa.fcgi
+man/man8/alias_manager.8.gz
+man/man8/archived.8.gz
+man/man8/bounced.8.gz
+man/man8/sympa.8.gz
%%EXAMPLESDIR%%/auth.conf
%%EXAMPLESDIR%%/ca-bundle.crt
%%EXAMPLESDIR%%/charset.conf