aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-12-21 16:59:42 +0800
committerclement <clement@FreeBSD.org>2004-12-21 16:59:42 +0800
commitc45c4407d1d077454c523bea0bdad8efe7b5609a (patch)
tree289e9170f0eeb25de7d3aa96ca90456858817856 /mail
parentf838333dbfde0e27f6b31e7467591633192c16d5 (diff)
downloadfreebsd-ports-gnome-c45c4407d1d077454c523bea0bdad8efe7b5609a.tar.gz
freebsd-ports-gnome-c45c4407d1d077454c523bea0bdad8efe7b5609a.tar.zst
freebsd-ports-gnome-c45c4407d1d077454c523bea0bdad8efe7b5609a.zip
- Rework gpgme03 port to avoid conflict with gpgme 1.0
- Make ports depending on it use new layout - Bump PORTREVISION (except elmo*) Approved by: portmgr (marcus)
Diffstat (limited to 'mail')
-rw-r--r--mail/anubis/Makefile6
-rw-r--r--mail/anubis/files/patch-configure28
-rw-r--r--mail/claws-mail/Makefile7
-rw-r--r--mail/elmo-devel/Makefile4
-rw-r--r--mail/elmo/Makefile4
-rw-r--r--mail/sylpheed-claws/Makefile7
-rw-r--r--mail/sylpheed-gtk2/Makefile7
-rw-r--r--mail/sylpheed/Makefile7
-rw-r--r--mail/sylpheed2-devel/Makefile7
-rw-r--r--mail/sylpheed2/Makefile7
-rw-r--r--mail/sylpheed3/Makefile7
11 files changed, 64 insertions, 27 deletions
diff --git a/mail/anubis/Makefile b/mail/anubis/Makefile
index a77bd07be293..2a7f71e77d8a 100644
--- a/mail/anubis/Makefile
+++ b/mail/anubis/Makefile
@@ -31,7 +31,8 @@ USE_REINPLACE= yes
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= MAKEINFO="makeinfo --no-split" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split" LDFLAGS="${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" CPPFLAGS="${CFLAGS}"
LDFLAGS+= -L${LOCALBASE}/lib
.if defined(WITHOUT_NLS)
@@ -57,7 +58,8 @@ CONFIGURE_ARGS+= --without-gnutls
.if defined(WITHOUT_GPGME)
CONFIGURE_ARGS+= --without-gpgme
.else
-LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
+CFLAGS+= -I${LOCALBASE}/include/gpgme03
.endif
# PCRE
diff --git a/mail/anubis/files/patch-configure b/mail/anubis/files/patch-configure
new file mode 100644
index 000000000000..641761441f7b
--- /dev/null
+++ b/mail/anubis/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig Mon Dec 20 20:32:43 2004
++++ configure Mon Dec 20 20:34:13 2004
+@@ -8603,13 +8603,13 @@
+
+ else
+
+-echo "$as_me:$LINENO: checking for main in -lgpgme" >&5
+-echo $ECHO_N "checking for main in -lgpgme... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for main in -lgpgme03" >&5
++echo $ECHO_N "checking for main in -lgpgme03... $ECHO_C" >&6
+ if test "${ac_cv_lib_gpgme_main+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lgpgme $LIBS"
++LIBS="-lgpgme03 $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -8656,7 +8656,7 @@
+ #define HAVE_LIBGPGME 1
+ _ACEOF
+
+- LIBS="-lgpgme $LIBS"
++ LIBS="-lgpgme03 $LIBS"
+
+ else
+ with_gpgme=no
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 1370c4e301eb..560a7b03cc53 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 0.9.13
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -123,7 +123,7 @@ PLIST_SUB+= SA_PLUG="@comment "
.endif
.if defined(WITH_GPGME) || defined(WITH_ALL)
PLIST_SUB+= GPGME=""
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
.else
PLIST_SUB+= GPGME="@comment "
@@ -170,7 +170,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e \
- 's|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ 's|-lresolv||g; s|-lpisock\"|-liconv &|g ;\
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
@${REINPLACE_CMD} -e "s|po intl src|po src|" ${WRKSRC}/Makefile.in
diff --git a/mail/elmo-devel/Makefile b/mail/elmo-devel/Makefile
index a0ed3a9d0ad8..c77049a25d9e 100644
--- a/mail/elmo-devel/Makefile
+++ b/mail/elmo-devel/Makefile
@@ -33,8 +33,8 @@ MAN1= elmo.1 elmoconf.pl.1
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libgpgme.so) || defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme03
+.if exists(${LOCALBASE}/lib/libgpgme03.so) || defined(WITH_GPGME)
+LIB_DEPENDS+= gpgme03:${PORTSDIR}/security/gpgme03
.else
pre-everything::
@${ECHO_CMD}
diff --git a/mail/elmo/Makefile b/mail/elmo/Makefile
index 6f031105617f..27b9c0dc5660 100644
--- a/mail/elmo/Makefile
+++ b/mail/elmo/Makefile
@@ -29,8 +29,8 @@ MAN1= elmo.1 elmoconf.pl.1
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libgpgme.so) || defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme03
+.if exists(${LOCALBASE}/lib/libgpgme03.so) || defined(WITH_GPGME)
+LIB_DEPENDS+= gpgme03:${PORTSDIR}/security/gpgme03
.else
pre-everything::
@${ECHO_CMD}
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 1370c4e301eb..560a7b03cc53 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 0.9.13
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -123,7 +123,7 @@ PLIST_SUB+= SA_PLUG="@comment "
.endif
.if defined(WITH_GPGME) || defined(WITH_ALL)
PLIST_SUB+= GPGME=""
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
.else
PLIST_SUB+= GPGME="@comment "
@@ -170,7 +170,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e \
- 's|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ 's|-lresolv||g; s|-lpisock\"|-liconv &|g ;\
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
@${REINPLACE_CMD} -e "s|po intl src|po src|" ${WRKSRC}/Makefile.in
diff --git a/mail/sylpheed-gtk2/Makefile b/mail/sylpheed-gtk2/Makefile
index bc4e570d497b..db27473acfec 100644
--- a/mail/sylpheed-gtk2/Makefile
+++ b/mail/sylpheed-gtk2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-gtk2
PORTVERSION= 0.9.99.20041024
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -44,7 +44,7 @@ CONFIGURE_ARGS+= --enable-ssl
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+= --enable-gpgme
.endif
@@ -71,7 +71,8 @@ post-patch:
's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
s|^manualdir=.*|manualdir="${DOCSDIR}/manual"|g; \
- s|^faqdir=.*|faqdir="${DOCSDIR}/faq"|g' \
+ s|^faqdir=.*|faqdir="${DOCSDIR}/faq"|g ;\
+ s|gpgme-config|gpgme03-config|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|^SUBDIRS = ac po src manual faq$$|SUBDIRS = ac po src|g' \
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 5ba45e3a1663..283d945f5b35 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 1.0.0.r.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
http://sylpheed.good-day.net/sylpheed/:source \
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
@@ -106,7 +106,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
${WRKSRC}/src/procmime.c
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index 5ba45e3a1663..283d945f5b35 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 1.0.0.r.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
http://sylpheed.good-day.net/sylpheed/:source \
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
@@ -106,7 +106,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
${WRKSRC}/src/procmime.c
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index 5ba45e3a1663..283d945f5b35 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 1.0.0.r.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
http://sylpheed.good-day.net/sylpheed/:source \
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
@@ -106,7 +106,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
${WRKSRC}/src/procmime.c
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index 5ba45e3a1663..283d945f5b35 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 1.0.0.r.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
http://sylpheed.good-day.net/sylpheed/:source \
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
@@ -106,7 +106,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
+ s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
${WRKSRC}/src/procmime.c