aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2014-12-25 21:35:23 +0800
committerwen <wen@FreeBSD.org>2014-12-25 21:35:23 +0800
commitd93e3d0a541c61a662be7eba03562f8a028bd1e4 (patch)
treece653f0ac494151cb73bc3d7f7dec627c0211453 /mail
parent0c51a0b7f2a81edcedc8d4e3706a57f82d209c58 (diff)
downloadfreebsd-ports-gnome-d93e3d0a541c61a662be7eba03562f8a028bd1e4.tar.gz
freebsd-ports-gnome-d93e3d0a541c61a662be7eba03562f8a028bd1e4.tar.zst
freebsd-ports-gnome-d93e3d0a541c61a662be7eba03562f8a028bd1e4.zip
Dancer2::Plugin::Email provides an easy way of handling text or
html email messages with or without attachments. Simply define how you wish to send the email in your application's YAML configuration file, then call the email keyword passing the necessary parameters. WWW: http://search.cpan.org/dist/Dancer2-Plugin-Email/ PR: 196190 Submitted by: hvo.pm@xs4all.nl
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Dancer2-Plugin-Email/Makefile24
-rw-r--r--mail/p5-Dancer2-Plugin-Email/distinfo2
-rw-r--r--mail/p5-Dancer2-Plugin-Email/pkg-descr7
-rw-r--r--mail/p5-Dancer2-Plugin-Email/pkg-plist2
5 files changed, 36 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 87f80482ffe5..f1a14cdb0903 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -289,6 +289,7 @@
SUBDIR += p5-CGP-CLI
SUBDIR += p5-Clamd
SUBDIR += p5-Dancer-Plugin-Email
+ SUBDIR += p5-Dancer2-Plugin-Email
SUBDIR += p5-Data-Validate-Email
SUBDIR += p5-Email-Abstract
SUBDIR += p5-Email-Address
diff --git a/mail/p5-Dancer2-Plugin-Email/Makefile b/mail/p5-Dancer2-Plugin-Email/Makefile
new file mode 100644
index 000000000000..c8774c155783
--- /dev/null
+++ b/mail/p5-Dancer2-Plugin-Email/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= Dancer2-Plugin-Email
+PORTVERSION= 0.0001
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Simple email handling for Dancer2 applications
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Dancer2>=0.156001:${PORTSDIR}/www/p5-Dancer2 \
+ p5-Email-Sender>=0:${PORTSDIR}/mail/p5-Email-Sender \
+ p5-File-Type>=0:${PORTSDIR}/devel/p5-File-Type \
+ p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Dancer2-Plugin-Email/distinfo b/mail/p5-Dancer2-Plugin-Email/distinfo
new file mode 100644
index 000000000000..29fa316c6efb
--- /dev/null
+++ b/mail/p5-Dancer2-Plugin-Email/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer2-Plugin-Email-0.0001.tar.gz) = cf9c37e9ddb61ca66704a32670c93f8b6f8c1a8c9e0566ebc688f6ed1ad8ba62
+SIZE (Dancer2-Plugin-Email-0.0001.tar.gz) = 13983
diff --git a/mail/p5-Dancer2-Plugin-Email/pkg-descr b/mail/p5-Dancer2-Plugin-Email/pkg-descr
new file mode 100644
index 000000000000..f59a54e40fdb
--- /dev/null
+++ b/mail/p5-Dancer2-Plugin-Email/pkg-descr
@@ -0,0 +1,7 @@
+Dancer2::Plugin::Email provides an easy way of handling text or
+html email messages with or without attachments. Simply define
+how you wish to send the email in your application's YAML
+configuration file, then call the email keyword passing the
+necessary parameters.
+
+WWW: http://search.cpan.org/dist/Dancer2-Plugin-Email/
diff --git a/mail/p5-Dancer2-Plugin-Email/pkg-plist b/mail/p5-Dancer2-Plugin-Email/pkg-plist
new file mode 100644
index 000000000000..ba62dc8142e6
--- /dev/null
+++ b/mail/p5-Dancer2-Plugin-Email/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Dancer2/Plugin/Email.pm
+%%PERL5_MAN3%%/Dancer2::Plugin::Email.3.gz