aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-11-24 23:03:51 +0800
committeraz <az@FreeBSD.org>2013-11-24 23:03:51 +0800
commite4b3789407651ee28b1c4d26916a624734daa15d (patch)
treec856a0c5968c32250c65ab2987c1d97150c7c3e8 /mail
parent4fb869ce9197ea493d266c14c11df944745c8b49 (diff)
downloadfreebsd-ports-gnome-e4b3789407651ee28b1c4d26916a624734daa15d.tar.gz
freebsd-ports-gnome-e4b3789407651ee28b1c4d26916a624734daa15d.tar.zst
freebsd-ports-gnome-e4b3789407651ee28b1c4d26916a624734daa15d.zip
- Add patches to allow run under perl 5.16
PR: ports/183863 Submitted by: wolfgang@lyxys.ka.sub.org With hat: perl@
Diffstat (limited to 'mail')
-rw-r--r--mail/majordomo/Makefile2
-rw-r--r--mail/majordomo/files/patch-approve14
-rw-r--r--mail/majordomo/files/patch-archive2.pl29
-rw-r--r--mail/majordomo/files/patch-config-test13
-rw-r--r--mail/majordomo/files/patch-contrib__sequencer18
-rw-r--r--mail/majordomo/files/patch-majordomo11
-rw-r--r--mail/majordomo/files/patch-md-sub__md-sub.cgi20
-rw-r--r--mail/majordomo/files/patch-resend23
8 files changed, 129 insertions, 1 deletions
diff --git a/mail/majordomo/Makefile b/mail/majordomo/Makefile
index 024a58bfe704..8bbcf7f18230 100644
--- a/mail/majordomo/Makefile
+++ b/mail/majordomo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= majordomo
PORTVERSION= 1.94.5
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= mail
MASTER_SITES= ftp://ftp.nuug.no/pub/anders/distfiles/ \
ftp://ftp.sgi.com/other/majordomo/1.94.5/ \
diff --git a/mail/majordomo/files/patch-approve b/mail/majordomo/files/patch-approve
new file mode 100644
index 000000000000..bbaab3dec755
--- /dev/null
+++ b/mail/majordomo/files/patch-approve
@@ -0,0 +1,14 @@
+--- ./approve.orig 2013-11-24 18:53:39.307114948 +0400
++++ ./approve 2013-11-24 18:45:58.000000000 +0400
+@@ -70,9 +70,9 @@
+ if !$MAILER;
+
+
+-require "getopts.pl";
++use Getopt::Std;
+
+-&Getopts("df:") ||
++getopts("df:") ||
+ die("USAGE: approve [-f <config-file>] [-d] [<file> ...]\nStopped");
+
+ if (!defined($opt_f)) {
diff --git a/mail/majordomo/files/patch-archive2.pl b/mail/majordomo/files/patch-archive2.pl
new file mode 100644
index 000000000000..4932066dbecb
--- /dev/null
+++ b/mail/majordomo/files/patch-archive2.pl
@@ -0,0 +1,29 @@
+--- ./archive2.pl.orig 2013-11-24 18:52:35.932149986 +0400
++++ ./archive2.pl 2013-11-24 18:49:56.000000000 +0400
+@@ -74,7 +74,7 @@
+
+ # All these should be in the standard PERL library
+ unshift(@INC, $homedir);
+-require "ctime.pl"; # To get MoY definitions for month abbrevs
++use POSIX qw(ctime);
+ require "majordomo_version.pl"; # What version of Majordomo is this?
+ require "majordomo.pl"; # all sorts of general-purpose Majordomo subs
+ require "shlock.pl"; # NNTP-style file locking
+@@ -85,7 +85,7 @@
+
+ # Here's where the fun begins...
+
+-require "getopts.pl";
++use Getopt::Std;
+
+ $m = 1;
+ foreach (@ctime'MoY) {
+@@ -94,7 +94,7 @@
+
+ $usage = "Usage: $0 -f <file> {-u|-a} [-d|-D|-m|-M|-y|-Y] [file ...]";
+
+-&Getopts("f:uadDmMyY") || die("$usage\nStopped");
++getopts("f:uadDmMyY") || die("$usage\nStopped");
+
+ if (!defined($opt_f)) {
+ print STDERR "'-f <list>' required\n$usage\n";
diff --git a/mail/majordomo/files/patch-config-test b/mail/majordomo/files/patch-config-test
new file mode 100644
index 000000000000..0f1d6c805865
--- /dev/null
+++ b/mail/majordomo/files/patch-config-test
@@ -0,0 +1,13 @@
+--- ./config-test.orig 2013-11-24 18:52:22.394976553 +0400
++++ ./config-test 2013-11-24 18:49:26.000000000 +0400
+@@ -7,8 +7,8 @@
+ # execute this by cd to your majordomo dir, then 'wrapper config-test'
+ #
+
+-@requires = ( "ctime.pl",
+- "majordomo_version.pl",
++use POSIX qw(ctime);
++@requires = ( "majordomo_version.pl",
+ "majordomo.pl",
+ "shlock.pl",
+ "config_parse.pl",
diff --git a/mail/majordomo/files/patch-contrib__sequencer b/mail/majordomo/files/patch-contrib__sequencer
new file mode 100644
index 000000000000..2ab3bb8a4a2c
--- /dev/null
+++ b/mail/majordomo/files/patch-contrib__sequencer
@@ -0,0 +1,18 @@
+--- ./contrib/sequencer.orig 2013-11-24 18:53:58.067356022 +0400
++++ ./contrib/sequencer 2013-11-24 18:48:32.000000000 +0400
+@@ -59,13 +59,13 @@
+
+ chdir($homedir) || die("Can't chdir(\"$homedir\"): $!");
+ unshift(@INC, $homedir);
++use Getopt::Std;
+ require "majordomo.pl";
+ require "majordomo_version.pl";
+-require "getopts.pl";
+ require "config_parse.pl";
+ require "shlock.pl";
+
+-&Getopts("Aa:df:h:I:l:m:M:nNp:Rr:s") || die("sequencer: Getopts() failed: $!");
++getopts("Aa:df:h:I:l:m:M:nNp:Rr:s") || die("sequencer: Getopts() failed: $!");
+
+ if (! defined($opt_l) || ! defined($opt_h)) {
+ die("sequencer: must specify both '-l list' and '-h host' arguments");
diff --git a/mail/majordomo/files/patch-majordomo b/mail/majordomo/files/patch-majordomo
new file mode 100644
index 000000000000..b5cab6bf966b
--- /dev/null
+++ b/mail/majordomo/files/patch-majordomo
@@ -0,0 +1,11 @@
+--- ./majordomo.orig 2013-11-24 18:52:53.333372091 +0400
++++ ./majordomo 2013-11-24 18:50:33.000000000 +0400
+@@ -71,7 +71,7 @@
+
+ # All these should be in the standard PERL library
+ unshift(@INC, $homedir);
+-require "ctime.pl"; # To get MoY definitions for month abbrevs
++use POSIX qw(ctime); # To get MoY definitions for month abbrevs
+ require "majordomo_version.pl"; # What version of Majordomo is this?
+ require "majordomo.pl"; # all sorts of general-purpose Majordomo subs
+ require "shlock.pl"; # NNTP-style file locking
diff --git a/mail/majordomo/files/patch-md-sub__md-sub.cgi b/mail/majordomo/files/patch-md-sub__md-sub.cgi
new file mode 100644
index 000000000000..def15deb0ecb
--- /dev/null
+++ b/mail/majordomo/files/patch-md-sub__md-sub.cgi
@@ -0,0 +1,20 @@
+--- ./md-sub/md-sub.cgi.orig 2013-11-24 18:54:07.634476295 +0400
++++ ./md-sub/md-sub.cgi 2013-11-24 18:47:15.000000000 +0400
+@@ -78,7 +78,7 @@
+ #
+ # Required file
+ require 'cgi-lib.pl';
+-require 'getopts.pl';
++use Getopt::Std;
+
+ #
+ # Version number
+@@ -90,7 +90,7 @@
+
+ #
+ # Call Getopts
+-&Getopts( 'C:v');
++getopts( 'C:v');
+
+ #
+ # Check to see if we are creating a DB
diff --git a/mail/majordomo/files/patch-resend b/mail/majordomo/files/patch-resend
new file mode 100644
index 000000000000..1bf709eed553
--- /dev/null
+++ b/mail/majordomo/files/patch-resend
@@ -0,0 +1,23 @@
+--- ./resend.orig 2013-11-24 18:53:15.076805222 +0400
++++ ./resend 2013-11-24 18:50:15.000000000 +0400
+@@ -71,8 +71,9 @@
+ # getopts.pl was place where it's supposed to be. This changes previous
+ # behavior which allowed getopts.pl to be in the same place as
+ # majordomo.cf.
+-require "getopts.pl";
+-&Getopts("C:c:Aa:df:h:I:l:M:p:Rr:s") || die("resend: Getopts() failed: $!");
++use Getopt::Std;
++
++getopts("C:c:Aa:df:h:I:l:M:p:Rr:s") || die("resend: Getopts() failed: $!");
+
+ if (! defined($opt_l)) {
+ die("resend: must specify '-l list'");
+@@ -105,7 +106,7 @@
+ chdir($homedir) || die("Can't chdir(\"$homedir\"): $!");
+
+ unshift(@INC, $homedir);
+-require "ctime.pl"; # For logging purposes
++use POSIX qw(ctime); # For logging purposes
+ require "majordomo.pl";
+ require "majordomo_version.pl";
+ require "config_parse.pl";