aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2013-12-16 13:30:28 +0800
committerashish <ashish@FreeBSD.org>2013-12-16 13:30:28 +0800
commitec0af1bb3f66cf6f23a2d06f8fff5238b0972365 (patch)
tree90b8a2f20f7a606ce00c6aa6862eb20d0747be5d /mail
parent0f170c532c86823ea75372ab01868e4cfcc9c0e3 (diff)
downloadfreebsd-ports-gnome-ec0af1bb3f66cf6f23a2d06f8fff5238b0972365.tar.gz
freebsd-ports-gnome-ec0af1bb3f66cf6f23a2d06f8fff5238b0972365.tar.zst
freebsd-ports-gnome-ec0af1bb3f66cf6f23a2d06f8fff5238b0972365.zip
- Update to latest snapshot 201312142054
- Add STAGE support - Use OptionsNG helpers - Add OPTION for installing CA bundle
Diffstat (limited to 'mail')
-rw-r--r--mail/opensmtpd-devel/Makefile67
-rw-r--r--mail/opensmtpd-devel/distinfo4
-rw-r--r--mail/opensmtpd-devel/files/pkg-deinstall.in2
-rw-r--r--mail/opensmtpd-devel/files/pkg-install.in2
-rw-r--r--mail/opensmtpd-devel/pkg-descr2
-rw-r--r--mail/opensmtpd-devel/pkg-plist20
6 files changed, 44 insertions, 53 deletions
diff --git a/mail/opensmtpd-devel/Makefile b/mail/opensmtpd-devel/Makefile
index 0fa9bc614138..cac4f7a7a0dc 100644
--- a/mail/opensmtpd-devel/Makefile
+++ b/mail/opensmtpd-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= opensmtpd
-PORTVERSION= 201308201232
+PORTVERSION= 201312142054
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
@@ -20,9 +20,11 @@ LIB_DEPENDS= event-1:${PORTSDIR}/devel/libevent
OPENSMTPD_SNAPSHOT_VER= p1
-OPTIONS_DEFINE= PAM SQLITE MYSQL PGSQL LDAP
+OPTIONS_DEFINE= CA_BUNDLE PAM SQLITE MYSQL PGSQL LDAP
-OPTIONS_DEFAULT= PAM
+OPTIONS_DEFAULT= CA_BUNDLE PAM
+
+CA_BUNDLE_DESC= Install CA bundle for OpenSSL
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libevent-dir=${LOCALBASE} --sysconfdir=${PREFIX}/etc/mail/ \
@@ -39,58 +41,37 @@ MAN5= smtpd.conf.5 aliases.5 forward.5
USERS= _smtpd _smtpq
GROUPS= _smtpd
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_SUB= MYSQL SQLITE PGSQL LDAP
-USE_OPENSSL= yes
+CA_BUNDLE_CONFIGURE_ON= --with-ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-CFLAGS+= -I${LOCALBASE}/include/mysql
-LDFLAGS+= -L${LOCALBASE}/lib/mysql
-CONFIGURE_ARGS+= --with-experimental-mysql
-PLIST_SUB+= MYSQL=""
-.else
-PLIST_SUB+= MYSQL="@comment "
-.endif
+MYSQL_USE= MYSQL=yes
+MYSQL_CFLAGS= -I${LOCALBASE}/include/mysql
+MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
+MYSQL_CONFIGURE_ON= --with-experimental-mysql
-.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= 3
-CONFIGURE_ARGS+= --with-experimental-sqlite
-PLIST_SUB+= SQLITE=""
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.else
-PLIST_SUB+= SQLITE="@comment "
-.endif
+SQLITE_USE= SQLITE=3
+SQLITE_CFLAGS= -I${LOCALBASE}/include
+SQLITE_LDFLAGS= -L${LOCALBASE}/lib
+SQLITE_CONFIGURE_ON= --with-experimental-sqlite
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-CONFIGURE_ARGS+= --with-experimental-postgres
-PLIST_SUB+= PGSQL=""
-.else
-PLIST_SUB+= PGSQL="@comment "
-.endif
+PGSQL_USE= PGSQL=yes
+PGSQL_CONFIGURE_ON= --with-experimental-postgres
-.if ${PORT_OPTIONS:MLDAP}
-CONFIGURE_ARGS+= --with-experimental-ldap
-PLIST_SUB+= LDAP=""
-.else
-PLIST_SUB+= LDAP="@comment "
-.endif
+LDAP_CONFIGURE_ON= --with-experimental-ldap
-.if ${PORT_OPTIONS:MPAM}
-CONFIGURE_ARGS+= --with-pam
-.endif
+PAM_CONFIGURE_ON= --with-pam
+
+.include <bsd.port.options.mk>
+
+USE_OPENSSL= yes
# FreeBSD 7.3 and earlier need to use OpenSSL from ports
.if ${OSVERSION} < 704000
WITH_OPENSSL_PORT= yes
.endif
-post-install:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
post-deinstall:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-DEINSTALL
diff --git a/mail/opensmtpd-devel/distinfo b/mail/opensmtpd-devel/distinfo
index 23e9bdab7bef..c0e770ceae2d 100644
--- a/mail/opensmtpd-devel/distinfo
+++ b/mail/opensmtpd-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (opensmtpd-201308201232p1.tar.gz) = 419fb0f2109ce4c155919cac163b8ac3b50578d19b723caf946a76199b636dea
-SIZE (opensmtpd-201308201232p1.tar.gz) = 780516
+SHA256 (opensmtpd-201312142054p1.tar.gz) = 1ba9763825373a7fc5eb405117bfb0329cf360ea7839006632f30f144abf4e1c
+SIZE (opensmtpd-201312142054p1.tar.gz) = 870900
diff --git a/mail/opensmtpd-devel/files/pkg-deinstall.in b/mail/opensmtpd-devel/files/pkg-deinstall.in
index 3c939c99eee1..3ef0e1146da0 100644
--- a/mail/opensmtpd-devel/files/pkg-deinstall.in
+++ b/mail/opensmtpd-devel/files/pkg-deinstall.in
@@ -8,7 +8,7 @@ PREFIX=$(echo %%PREFIX%% |sed -e 's,/,\\/,g')
if [ "$TARGET" = POST-DEINSTALL ]; then
sed -e '/[[:space:]]'$PREFIX'\/sbin\/smtpctl/d' \
-e '/[[:space:]]'$PREFIX'\/libexec\/opensmtpd\/makemap/d' \
- -e 's/^### smtpd: //g' -i '' /etc/mail/mailer.conf
+ -e 's/^### opensmtpd: //g' -i '' /etc/mail/mailer.conf
fi
exit 0
diff --git a/mail/opensmtpd-devel/files/pkg-install.in b/mail/opensmtpd-devel/files/pkg-install.in
index 899ad234742e..86eb79f70eb7 100644
--- a/mail/opensmtpd-devel/files/pkg-install.in
+++ b/mail/opensmtpd-devel/files/pkg-install.in
@@ -4,7 +4,7 @@ PKGNAME=$1
TARGET=$2
if [ "$TARGET" = POST-INSTALL ]; then
- sed -e '/^[^#]/s/^/### smtpd: /g' -i '' /etc/mail/mailer.conf
+ sed -e '/^[^#]/s/^/### opensmtpd: /g' -i '' /etc/mail/mailer.conf
cat >>/etc/mail/mailer.conf <<EOF
sendmail %%PREFIX%%/sbin/smtpctl
send-mail %%PREFIX%%/sbin/smtpctl
diff --git a/mail/opensmtpd-devel/pkg-descr b/mail/opensmtpd-devel/pkg-descr
index 0c38e93edb98..cd06b8200d1d 100644
--- a/mail/opensmtpd-devel/pkg-descr
+++ b/mail/opensmtpd-devel/pkg-descr
@@ -5,4 +5,4 @@ speaking the SMTP protocol.
This port packages the development snapshots released by OpenSMTPD team.
-WWW: http://www.OpenSMTPD.org/
+WWW: http://www.OpenSMTPD.org/
diff --git a/mail/opensmtpd-devel/pkg-plist b/mail/opensmtpd-devel/pkg-plist
index ef8ded9d2bdf..bdc483fc49fc 100644
--- a/mail/opensmtpd-devel/pkg-plist
+++ b/mail/opensmtpd-devel/pkg-plist
@@ -1,22 +1,32 @@
etc/mail/smtpd.conf.sample
libexec/opensmtpd/mail.local
libexec/opensmtpd/makemap
-libexec/opensmtpd/backend-queue-null
-libexec/opensmtpd/backend-queue-ram
-libexec/opensmtpd/backend-queue-stub
+libexec/opensmtpd/queue-null
+libexec/opensmtpd/queue-ram
+libexec/opensmtpd/queue-stub
libexec/opensmtpd/table-stub
libexec/opensmtpd/table-passwd
%%MYSQL%%libexec/opensmtpd/table-mysql
%%SQLITE%%libexec/opensmtpd/table-sqlite
%%LDAP%%libexec/opensmtpd/table-ldap
%%PGSQL%%libexec/opensmtpd/table-postgres
-libexec/opensmtpd/backend-scheduler-ram
-libexec/opensmtpd/backend-scheduler-stub
+libexec/opensmtpd/scheduler-ram
+libexec/opensmtpd/scheduler-stub
libexec/opensmtpd/filter-dnsbl
libexec/opensmtpd/filter-monkey
libexec/opensmtpd/filter-stub
libexec/opensmtpd/filter-trace
+libexec/opensmtpd/encrypt
sbin/smtpctl
sbin/smtpd
+man/man8/newaliases.8.gz
+man/man8/sendmail.8.gz
+man/man8/smtpd.8.gz
+man/man8/makemap.8.gz
+man/man8/smtpctl.8.gz
+man/man5/table.5.gz
+man/man5/smtpd.conf.5.gz
+man/man5/forward.5.gz
+man/man5/aliases.5.gz
@dirrm libexec/opensmtpd
@dirrmtry etc/mail