aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>2001-02-10 04:35:19 +0800
committerjim <jim@FreeBSD.org>2001-02-10 04:35:19 +0800
commitecef81f5bc9a090ce503ff69854463283eacb6a1 (patch)
tree1f4c308e69ea1972e4927e9611d29d74cfac7ffe /mail
parentd1a7b63dc9a154c7e33dccd1daaa4abb5bd18ec5 (diff)
downloadfreebsd-ports-gnome-ecef81f5bc9a090ce503ff69854463283eacb6a1.tar.gz
freebsd-ports-gnome-ecef81f5bc9a090ce503ff69854463283eacb6a1.tar.zst
freebsd-ports-gnome-ecef81f5bc9a090ce503ff69854463283eacb6a1.zip
Add a WITH_DRAC knob to enable DRAC support.
Submitted by: Anders Nordby <anders@fix.no>
Diffstat (limited to 'mail')
-rw-r--r--mail/teapop-devel/Makefile9
-rw-r--r--mail/teapop/Makefile9
2 files changed, 18 insertions, 0 deletions
diff --git a/mail/teapop-devel/Makefile b/mail/teapop-devel/Makefile
index ba1d553ed93d..07032a4a4b57 100644
--- a/mail/teapop-devel/Makefile
+++ b/mail/teapop-devel/Makefile
@@ -21,6 +21,10 @@ LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.endif
+.if defined(WITH_DRAC)
+BUILD_DEPENDS= ${PREFIX}/lib/libdrac.a:${PORTSDIR}/mail/drac
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-flock
@@ -40,6 +44,11 @@ CONFIGURE_ARGS+= --with-pgsql=${PREFIX}/pgsql
CONFIGURE_ARGS+= --with-mysql=${PREFIX}
.endif
+.if defined(WITH_DRAC)
+CONFIGURE_ARGS+= --with-drac=${PREFIX}/lib \
+ --with-dracinc=${PREFIX}/include
+.endif
+
MAN8= teapop.8
.include <bsd.port.mk>
diff --git a/mail/teapop/Makefile b/mail/teapop/Makefile
index ba1d553ed93d..07032a4a4b57 100644
--- a/mail/teapop/Makefile
+++ b/mail/teapop/Makefile
@@ -21,6 +21,10 @@ LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.endif
+.if defined(WITH_DRAC)
+BUILD_DEPENDS= ${PREFIX}/lib/libdrac.a:${PORTSDIR}/mail/drac
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-flock
@@ -40,6 +44,11 @@ CONFIGURE_ARGS+= --with-pgsql=${PREFIX}/pgsql
CONFIGURE_ARGS+= --with-mysql=${PREFIX}
.endif
+.if defined(WITH_DRAC)
+CONFIGURE_ARGS+= --with-drac=${PREFIX}/lib \
+ --with-dracinc=${PREFIX}/include
+.endif
+
MAN8= teapop.8
.include <bsd.port.mk>