aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-02-14 01:24:36 +0800
committermiwi <miwi@FreeBSD.org>2008-02-14 01:24:36 +0800
commitef1119cb334dba06a52ffc93abd5744a6572fd59 (patch)
treed118f5418c18b518071d723c4f897f00e49b4de6 /mail
parent4eedf1c8075fe163ddf76ae4fb09c16d22d1eeb2 (diff)
downloadfreebsd-ports-gnome-ef1119cb334dba06a52ffc93abd5744a6572fd59.tar.gz
freebsd-ports-gnome-ef1119cb334dba06a52ffc93abd5744a6572fd59.tar.zst
freebsd-ports-gnome-ef1119cb334dba06a52ffc93abd5744a6572fd59.zip
- Unbreak
- Update to 2.99.57 - Pass maintainership to submitter PR: 120536 Submitted by: Pietro Cerutti <gahr@gahr.ch>
Diffstat (limited to 'mail')
-rw-r--r--mail/zmailer/Makefile24
-rw-r--r--mail/zmailer/distinfo6
-rw-r--r--mail/zmailer/files/patch-EAI_NODATA37
-rw-r--r--mail/zmailer/files/patch-Makefile.in10
-rw-r--r--mail/zmailer/files/patch-aa8
-rw-r--r--mail/zmailer/files/patch-ab10
-rw-r--r--mail/zmailer/files/patch-proto::post-install.sh.in11
-rw-r--r--mail/zmailer/files/patch-sfio-src-lib-sfio_sfsetbuf.c24
-rw-r--r--mail/zmailer/files/patch-smtpserver-smtpetrn.c11
-rw-r--r--mail/zmailer/files/patch-transports-smtp-smtp.c13
-rw-r--r--mail/zmailer/files/patch-transports-smtp-smtp.h12
-rw-r--r--mail/zmailer/files/patch-transports-smtp-smtptls.c26
-rw-r--r--mail/zmailer/pkg-plist11
13 files changed, 81 insertions, 122 deletions
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index 4581759899de..6a39be1c15db 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -6,29 +6,28 @@
#
PORTNAME= zmailer
-PORTVERSION= 2.99.56
+PORTVERSION= 2.99.57
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.funet.fi/pub/unix/mail/zmailer/src/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@gahr.ch
COMMENT= A fully functional fast, robust SMTP server and transport agent
CONFLICTS= courier-0.* postfix-1.* postfix-2.* sendmail-8.* sendmail-*-8.* smail-3.*
+
+OPTIONS= SSL "Enable SSL support" ON
+
GNU_CONFIGURE= yes
USE_PERL5= yes
-.if defined(WITH_SSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS= --with-openssl
-.else
-CONFIGURE_ARGS= --without-openssl
-.endif
-
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS= --without-openssl
+.else
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+CONFIGURE_ARGS= --with-openssl
.endif
CONFIGURE_ARGS+=--prefix=${PREFIX}/ \
@@ -67,6 +66,9 @@ DOMAIN!= /bin/hostname | ${SED} -e "s:^"`/bin/hostname -s`"\.*::g"
DOMAIN= "mydomain.com"
.endif
+pre-install:
+ cd ${WRKSRC}/man && make install
+
post-install:
@${SETENV} PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
# set up the initial mail.conf with reasonable settings.
diff --git a/mail/zmailer/distinfo b/mail/zmailer/distinfo
index b6d752753f03..0c13b3819b05 100644
--- a/mail/zmailer/distinfo
+++ b/mail/zmailer/distinfo
@@ -1,3 +1,3 @@
-MD5 (zmailer-2.99.56.tar.gz) = c94cc0c2e2427a210a046a02ac4c2d50
-SHA256 (zmailer-2.99.56.tar.gz) = 7a5e6c051fc9c9bdf9774fe9ce11871105d20f569e61bdc8da222a1ff587678d
-SIZE (zmailer-2.99.56.tar.gz) = 5926859
+MD5 (zmailer-2.99.57.tar.gz) = abe451575234ac5ce79d9b950b150986
+SHA256 (zmailer-2.99.57.tar.gz) = 74b878138d82c765174c44250a7789b15c70a1d0fc39bddd096cd4147ed5a115
+SIZE (zmailer-2.99.57.tar.gz) = 5521100
diff --git a/mail/zmailer/files/patch-EAI_NODATA b/mail/zmailer/files/patch-EAI_NODATA
deleted file mode 100644
index b42624c6e7fd..000000000000
--- a/mail/zmailer/files/patch-EAI_NODATA
+++ /dev/null
@@ -1,37 +0,0 @@
---- smtpserver/mxverify.c.orig Fri Apr 16 15:45:46 2004
-+++ smtpserver/mxverify.c Fri Apr 16 15:46:38 2004
-@@ -607,7 +607,6 @@
- if (retmode == '+') {
- if (rc == -EX_NOHOST ||
- rc == -EX_UNAVAILABLE ||
-- rc == EAI_NODATA ||
- rc == EAI_NONAME)
- return -2; /* Definitely hard errors */
- if (rc == 2)
---- transports/smtp/smtp.c.orig Fri Apr 16 15:48:44 2004
-+++ transports/smtp/smtp.c Fri Apr 16 15:54:18 2004
-@@ -2912,6 +2912,7 @@
- return EX_DEFERALL;
- }
-
-+#if 0 /* FreeBSD 5.x doesn't have it */
- if ( r == EAI_NODATA ) {
- sprintf(SS->remotemsg,"smtp; 500 (getaddrinfo<%.200s>: No data)",host);
- time(&endtime);
-@@ -2925,6 +2926,7 @@
- return EX_DEFERALL;
- return EX_UNAVAILABLE;
- }
-+#endif
-
- r = EX_UNAVAILABLE; /* This gives instant rejection */
- if (rc == EX_TEMPFAIL) r = rc;
-@@ -2944,7 +2946,7 @@
- if (r != EX_TEMPFAIL)
- r = EX_NOHOST;
- #endif
-- } else if (gai_err == EAI_NONAME || gai_err == EAI_NODATA) {
-+ } else if (gai_err == EAI_NONAME) {
- sprintf(SS->remotemsg,
- "smtp; 500 (nameserver data inconsistency. No MX, no address: '%.200s' (%s))",
- host, gai_err == EAI_NONAME ? "NONAME" : "NODATA");
diff --git a/mail/zmailer/files/patch-Makefile.in b/mail/zmailer/files/patch-Makefile.in
deleted file mode 100644
index f702dd1f9a26..000000000000
--- a/mail/zmailer/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.in.orig Wed Apr 14 17:22:31 2004
-+++ Makefile.in Wed Apr 14 17:23:04 2004
-@@ -130,6 +130,7 @@
- @cd transports ; $(MAKE) $(MFLAGS) install
- @cd libc ; $(MAKE) $(MFLAGS) install
- @cd utils ; $(MAKE) $(MFLAGS) install
-+ @cd man ; $(MAKE) $(MFLAGS) install
- $(MAKE) $(MFLAGS) post-install-note
-
- post-install-note:
diff --git a/mail/zmailer/files/patch-aa b/mail/zmailer/files/patch-aa
index 7a83abb03cf9..24ccd22c3d9c 100644
--- a/mail/zmailer/files/patch-aa
+++ b/mail/zmailer/files/patch-aa
@@ -1,13 +1,5 @@
--- configure.orig Fri Dec 26 10:29:15 2003
+++ configure Fri Dec 26 10:33:26 2003
-@@ -280,6 +280,7 @@
- # Factoring default headers for most tests.
- ac_includes_default="\
- #include <stdio.h>
-+#include <sys/param.h>
- #if HAVE_SYS_TYPES_H
- # include <sys/types.h>
- #endif
@@ -20317,7 +20318,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
diff --git a/mail/zmailer/files/patch-ab b/mail/zmailer/files/patch-ab
deleted file mode 100644
index f167d88b90db..000000000000
--- a/mail/zmailer/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- transports/smtp/getmxrr.c.orig Mon Jun 23 12:04:35 2003
-+++ transports/smtp/getmxrr.c Fri Dec 26 11:30:58 2003
-@@ -416,7 +416,6 @@
- break;
- case EAI_NONAME:
- case EAI_FAIL:
-- case EAI_NODATA:
- case EAI_SERVICE:
- default:
- break;
diff --git a/mail/zmailer/files/patch-proto::post-install.sh.in b/mail/zmailer/files/patch-proto::post-install.sh.in
deleted file mode 100644
index c352a1a9bbbd..000000000000
--- a/mail/zmailer/files/patch-proto::post-install.sh.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- proto/post-install.sh.in.orig Fri Apr 16 12:45:45 2004
-+++ proto/post-install.sh.in Fri Apr 16 12:46:00 2004
-@@ -373,7 +373,7 @@
- ", $POSTOFFICE);
-
- if (! -d "$POSTOFFICE/.") {
-- mymysystem("$MKDIR -p $POSTOFFICE");
-+ mysystem("$MKDIR -p $POSTOFFICE");
-
- }
- mysystem("chmod 2755 $POSTOFFICE/.");
diff --git a/mail/zmailer/files/patch-sfio-src-lib-sfio_sfsetbuf.c b/mail/zmailer/files/patch-sfio-src-lib-sfio_sfsetbuf.c
new file mode 100644
index 000000000000..e2f348a98632
--- /dev/null
+++ b/mail/zmailer/files/patch-sfio-src-lib-sfio_sfsetbuf.c
@@ -0,0 +1,24 @@
+--- sfio/src/lib/sfio/sfsetbuf.c.orig 2008-02-11 09:54:38.000000000 +0100
++++ sfio/src/lib/sfio/sfsetbuf.c 2008-02-11 09:55:58.000000000 +0100
+@@ -6,10 +6,6 @@
+
+ #include "sfhdr.h"
+
+-#if _lib_memalign
+-extern void *memalign _ARG_((size_t boundary, size_t size));
+-#endif
+-
+ #if defined(__STDPP__directive) && defined(__STDPP__hide)
+ __STDPP__directive pragma pp:nohide getpagesize
+ #else
+@@ -265,10 +261,6 @@
+ }
+ if(!buf)
+ { /* do allocation */
+-#if _lib_memalign
+- if(!(f->flags&SF_STRING) && _Sfpage && (size % _Sfpage) == 0)
+- buf = (Void_t*)memalign(_Sfpage,size);
+-#endif
+ while(!buf && size > 0)
+ { if((buf = (Void_t*)malloc(size)) )
+ break;
diff --git a/mail/zmailer/files/patch-smtpserver-smtpetrn.c b/mail/zmailer/files/patch-smtpserver-smtpetrn.c
deleted file mode 100644
index e81d603f331f..000000000000
--- a/mail/zmailer/files/patch-smtpserver-smtpetrn.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- smtpserver/smtpetrn.c.orig Sun Sep 24 14:05:20 2006
-+++ smtpserver/smtpetrn.c Sun Sep 24 14:06:45 2006
-@@ -21,6 +21,8 @@
-
- #ifndef HAVE_OPENSSL
- #include "md5.h"
-+#else
-+#include <openssl/md5.h>
- #endif /* --HAVE_OPENSSL */
-
- static int local_etrn(SS, name, cp, silence)
diff --git a/mail/zmailer/files/patch-transports-smtp-smtp.c b/mail/zmailer/files/patch-transports-smtp-smtp.c
new file mode 100644
index 000000000000..19e5d9cc31dc
--- /dev/null
+++ b/mail/zmailer/files/patch-transports-smtp-smtp.c
@@ -0,0 +1,13 @@
+--- transports/smtp/smtp.c.orig 2008-02-13 12:43:13.000000000 +0100
++++ transports/smtp/smtp.c 2008-02-13 12:43:32.000000000 +0100
+@@ -4214,8 +4214,10 @@
+
+
+ #ifdef HAVE_OPENSSL
++#ifdef EPROTO
+ if (SS->TLS.sslmode && err == EPROTO)
+ break;
++#endif
+
+ if (SS->TLS.sslmode && SS->TLS.wantreadwrite > 0) waitwr = 1;
+ #endif /* - HAVE_OPENSSL */
diff --git a/mail/zmailer/files/patch-transports-smtp-smtp.h b/mail/zmailer/files/patch-transports-smtp-smtp.h
deleted file mode 100644
index 53b9a640e87d..000000000000
--- a/mail/zmailer/files/patch-transports-smtp-smtp.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- transports/smtp/smtp.h.orig Sun Sep 24 14:10:22 2006
-+++ transports/smtp/smtp.h Sun Sep 24 14:10:56 2006
-@@ -69,6 +69,9 @@
- #include <netinet/tcp.h>
- #endif
-
-+#include <sys/types.h>
-+#include <openssl/md5.h>
-+
- #ifndef NFDBITS
- /*
- * This stuff taken from the 4.3bsd /usr/include/sys/types.h, but on the
diff --git a/mail/zmailer/files/patch-transports-smtp-smtptls.c b/mail/zmailer/files/patch-transports-smtp-smtptls.c
new file mode 100644
index 000000000000..c92e624d79dc
--- /dev/null
+++ b/mail/zmailer/files/patch-transports-smtp-smtptls.c
@@ -0,0 +1,26 @@
+--- transports/smtp/smtptls.c.orig 2008-02-13 12:44:21.000000000 +0100
++++ transports/smtp/smtptls.c 2008-02-13 12:45:10.000000000 +0100
+@@ -1878,7 +1878,11 @@
+ e = EAGAIN;
+ break;
+ case SSL_ERROR_SSL:
++#ifdef EPROTO
+ e = EPROTO;
++#else
++ e = 1;
++#endif
+ default:
+ SS->TLS.wantreadwrite = 0;
+ break;
+@@ -2056,7 +2060,11 @@
+ e = EAGAIN;
+ break;
+ case SSL_ERROR_SSL:
++#ifdef EPROTO
+ e = EPROTO;
++#else
++ e = 1;
++#endif
+ default:
+ SS->TLS.wantreadwrite = 0;
+ break;
diff --git a/mail/zmailer/pkg-plist b/mail/zmailer/pkg-plist
index ccc2d688bcc5..32105d1e1bc2 100644
--- a/mail/zmailer/pkg-plist
+++ b/mail/zmailer/pkg-plist
@@ -53,7 +53,6 @@ etc/zmailer/forms/proto/loopexceeded.md5
etc/zmailer/forms/proto/nonewsgroup.md5
etc/zmailer/forms/proto/norealname.md5
etc/zmailer/forms/proto/norecipients.md5
-etc/zmailer/forms/proto/nosuchuser.md5
etc/zmailer/forms/proto/unresolvable.md5
etc/zmailer/forms/proto/vms-in-pros.md5
etc/zmailer/forms/proto/wrongname.md5
@@ -71,7 +70,6 @@ etc/zmailer/forms/loopexceeded
etc/zmailer/forms/nonewsgroup
etc/zmailer/forms/norealname
etc/zmailer/forms/norecipients
-etc/zmailer/forms/nosuchuser
etc/zmailer/forms/unresolvable
etc/zmailer/forms/vms-in-pros
etc/zmailer/forms/wrongname
@@ -91,7 +89,6 @@ etc/zmailer/cf/proto/p-uucp.cf.md5
etc/zmailer/cf/proto/p-usenet.cf.md5
etc/zmailer/cf/proto/p-smtp.cf.md5
etc/zmailer/cf/proto/p-routes.cf.md5
-etc/zmailer/cf/proto/p-ldap.cf.md5
etc/zmailer/cf/proto/p-iproutes.cf.md5
etc/zmailer/cf/proto/p-ean.cf.md5
etc/zmailer/cf/proto/p-bitnet.cf.md5
@@ -116,7 +113,6 @@ etc/zmailer/cf/proto/UTGPU.cf.md5
etc/zmailer/cf/proto/UTAI.cf.md5
etc/zmailer/cf/proto/TELE-FI.cf.md5
etc/zmailer/cf/proto/SMTP.cf.md5
-etc/zmailer/cf/proto/tryme.cf.md5
etc/zmailer/cf/SMTP+UUCP.cf
etc/zmailer/cf/trusted.cf
etc/zmailer/cf/standard.cf
@@ -127,7 +123,6 @@ etc/zmailer/cf/p-uucp.cf
etc/zmailer/cf/p-usenet.cf
etc/zmailer/cf/p-smtp.cf
etc/zmailer/cf/p-routes.cf
-etc/zmailer/cf/p-ldap.cf
etc/zmailer/cf/p-iproutes.cf
etc/zmailer/cf/p-ean.cf
etc/zmailer/cf/p-bitnet.cf
@@ -152,7 +147,6 @@ etc/zmailer/cf/UTGPU.cf
etc/zmailer/cf/UTAI.cf
etc/zmailer/cf/TELE-FI.cf
etc/zmailer/cf/SMTP.cf
-etc/zmailer/cf/tryme.cf
etc/zmailer/scheduler.conf
etc/zmailer/sm.conf
etc/zmailer/smtpserver.conf
@@ -184,7 +178,6 @@ etc/zmailer/forms/proto/loopexceeded
etc/zmailer/forms/proto/nonewsgroup
etc/zmailer/forms/proto/norealname
etc/zmailer/forms/proto/norecipients
-etc/zmailer/forms/proto/nosuchuser
etc/zmailer/forms/proto/unresolvable
etc/zmailer/forms/proto/vms-in-pros
etc/zmailer/forms/proto/wrongname
@@ -200,6 +193,7 @@ etc/zmailer/guides/smtpauth-login-pam-support
etc/zmailer/guides/smtp-policy
etc/zmailer/guides/smtp-msa-mode
etc/zmailer/guides/smtp-etrn
+etc/zmailer/guides/smtpserver-spf
etc/zmailer/guides/scheduler-ta-protocol
etc/zmailer/guides/relations
etc/zmailer/guides/procmail
@@ -229,7 +223,6 @@ etc/zmailer/cf/proto/p-uucp.cf
etc/zmailer/cf/proto/p-usenet.cf
etc/zmailer/cf/proto/p-smtp.cf
etc/zmailer/cf/proto/p-routes.cf
-etc/zmailer/cf/proto/p-ldap.cf
etc/zmailer/cf/proto/p-iproutes.cf
etc/zmailer/cf/proto/p-ean.cf
etc/zmailer/cf/proto/p-bitnet.cf
@@ -254,7 +247,6 @@ etc/zmailer/cf/proto/UTGPU.cf
etc/zmailer/cf/proto/UTAI.cf
etc/zmailer/cf/proto/TELE-FI.cf
etc/zmailer/cf/proto/SMTP.cf
-etc/zmailer/cf/proto/tryme.cf
etc/zmailer/vacation.msg
etc/zmailer/mail.conf.sample
@exec mkdir -p %D/etc/zmailer/lists
@@ -303,6 +295,7 @@ sbin/scheduler
sbin/sendmail
sbin/smtpserver
sbin/smtpserver-log-parser.pl
+sbin/zrfilter
@unexec /bin/rm -f %D/sbin/vacation
sbin/vacation.exe
sbin/vacation.sh