aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-15 06:43:05 +0800
committermiwi <miwi@FreeBSD.org>2009-03-15 06:43:05 +0800
commitf27f251cf3e3c63ed1cc5221732f426af3efdc7a (patch)
tree81c24ae131f38ce0f53d83285f230b72b19bd291 /mail
parent415e83bac573061fd5f1aecdbf28c2828cc12f51 (diff)
downloadfreebsd-ports-gnome-f27f251cf3e3c63ed1cc5221732f426af3efdc7a.tar.gz
freebsd-ports-gnome-f27f251cf3e3c63ed1cc5221732f426af3efdc7a.tar.zst
freebsd-ports-gnome-f27f251cf3e3c63ed1cc5221732f426af3efdc7a.zip
- Fix build after strndup MFC
PR: 132009 Submitted by: Florian Smeets <flo@kasimir.com> Approved by: maintainer timeout
Diffstat (limited to 'mail')
-rw-r--r--mail/smfsav/Makefile8
-rw-r--r--mail/smfsav/files/patch-irpmarshall.c16
2 files changed, 17 insertions, 7 deletions
diff --git a/mail/smfsav/Makefile b/mail/smfsav/Makefile
index 53b7411ff619..2104dc4bb085 100644
--- a/mail/smfsav/Makefile
+++ b/mail/smfsav/Makefile
@@ -56,10 +56,4 @@ post-install:
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800058 || (${OSVERSION} >= 701101 && ${OSVERSION} < 800000)
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/smfsav/files/patch-irpmarshall.c b/mail/smfsav/files/patch-irpmarshall.c
new file mode 100644
index 000000000000..a8563914cfdf
--- /dev/null
+++ b/mail/smfsav/files/patch-irpmarshall.c
@@ -0,0 +1,16 @@
+--- ../src/lib/irs/irpmarshall.c.orig 2009-02-22 15:17:43.000000000 +0000
++++ ../src/lib/irs/irpmarshall.c 2009-02-22 15:25:53.000000000 +0000
+@@ -89,6 +89,12 @@
+
+ #include "port_after.h"
+
++#if defined(__FreeBSD__)
++#include <osreldate.h>
++#if __FreeBSD_version >= 800058 || __FreeBSD_version >= 701101 && __FreeBSD_version < 800000
++#define HAVE_STRNDUP 1
++#endif
++#endif
+
+ #ifndef HAVE_STRNDUP
+ static char *strndup(const char *str, size_t len);
+