aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2017-10-14 15:21:17 +0800
committerpi <pi@FreeBSD.org>2017-10-14 15:21:17 +0800
commitcc2f416ddaf8f7bec84f1593b9e96013044ef905 (patch)
treed7ebc70530737bb07163f38cdc6204d9045ef652 /mail
parenta1e12a292f802fa1160530c410c241082f52f06e (diff)
downloadfreebsd-ports-gnome-cc2f416ddaf8f7bec84f1593b9e96013044ef905.tar.gz
freebsd-ports-gnome-cc2f416ddaf8f7bec84f1593b9e96013044ef905.tar.zst
freebsd-ports-gnome-cc2f416ddaf8f7bec84f1593b9e96013044ef905.zip
New port: mail/py-premailer: Convert CSS to style attributes
Python module to support CSS and HTML-based email formatting. WWW: https://github.com/peterbe/premailer PR: 221154 Submitted by: Ryder Dain <ryder.dain@gmail.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-premailer/Makefile29
-rw-r--r--mail/py-premailer/distinfo3
-rw-r--r--mail/py-premailer/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 9bc97ea3396b..5388a8aa2a06 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -539,6 +539,7 @@
SUBDIR += py-milter
SUBDIR += py-notmuch
SUBDIR += py-ppolicy
+ SUBDIR += py-premailer
SUBDIR += py-pymailq
SUBDIR += py-pyspf
SUBDIR += py-spambayes
diff --git a/mail/py-premailer/Makefile b/mail/py-premailer/Makefile
new file mode 100644
index 000000000000..d203fcca71e6
--- /dev/null
+++ b/mail/py-premailer/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= premailer
+PORTVERSION= 3.1.1
+CATEGORIES= mail python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rtd24@columbia.edu
+COMMENT= Turns CSS blocks into style attributes
+
+LICENSE= PSFL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cssselect>=0:www/py-cssselect \
+ ${PYTHON_PKGNAMEPREFIX}cssutils>=0:www/py-cssutils \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils concurrent
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/mail/py-premailer/distinfo b/mail/py-premailer/distinfo
new file mode 100644
index 000000000000..a1bc4af44528
--- /dev/null
+++ b/mail/py-premailer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501591383
+SHA256 (premailer-3.1.1.tar.gz) = fd07dadc47345f7d44a0587bd65a37c45886f19c44b3ec94904761e4b2d39124
+SIZE (premailer-3.1.1.tar.gz) = 17306
diff --git a/mail/py-premailer/pkg-descr b/mail/py-premailer/pkg-descr
new file mode 100644
index 000000000000..8f965f903eab
--- /dev/null
+++ b/mail/py-premailer/pkg-descr
@@ -0,0 +1,3 @@
+Python module to support CSS and HTML-based email formatting.
+
+WWW: https://github.com/peterbe/premailer