aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-08-22 10:49:22 +0800
committerswills <swills@FreeBSD.org>2017-08-22 10:49:22 +0800
commitd37995ee9b69d8b8d7ab334f4783e761f520e9ca (patch)
tree2dc7c645edcc13a71dc35343e3e51361cd87e3f2 /mail
parentc76aa70db8e47c3ae4e058d27c9f709be1f5843a (diff)
downloadfreebsd-ports-gnome-d37995ee9b69d8b8d7ab334f4783e761f520e9ca.tar.gz
freebsd-ports-gnome-d37995ee9b69d8b8d7ab334f4783e761f520e9ca.tar.zst
freebsd-ports-gnome-d37995ee9b69d8b8d7ab334f4783e761f520e9ca.zip
mail/milter-greylist: Bring in DKIM option from milter-greylist-devel
While here, make DKIM, SPF, GEOIP and CURL default like -devel PR: 220256 Submitted by: m.tsatsenko@gmail.com (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/milter-greylist/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/mail/milter-greylist/Makefile b/mail/milter-greylist/Makefile
index 5e5999eba2f1..5b58ef53cea6 100644
--- a/mail/milter-greylist/Makefile
+++ b/mail/milter-greylist/Makefile
@@ -3,6 +3,7 @@
PORTNAME= milter-greylist
PORTVERSION= 4.6.2
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.espci.fr/pub/milter-greylist/ \
http://fossies.org/unix/privat/
@@ -30,12 +31,15 @@ USES= tar:tgz
# installed port preference over it.
##
-OPTIONS_DEFINE= SPF GEOIP CURL LDAP P0F POSTFIX DOCS EXAMPLES
+OPTIONS_DEFINE= DKIM SPF GEOIP CURL LDAP P0F POSTFIX DOCS EXAMPLES
+OPTIONS_DEFAULT= DKIM SPF GEOIP CURL
+DKIM_DESC= DKIM support
SPF_DESC= SPF support
CURL_DESC= curl support
P0F_DESC= P0F support
POSTFIX_DESC= Use Postfix instead of Sendmail
+DKIM_LIB_DEPENDS= libopendkim.so:mail/opendkim
P0F_RUN_DEPENDS= p0f:net-mgmt/p0f
SPF_LIB_DEPENDS= libspf2.so:mail/libspf2
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
@@ -47,6 +51,8 @@ POSTFIX_LIBS_OFF= ${SENDMAIL_LDADD}
P0F_CONFIGURE_ENABLE= p0f306
+DKIM_CONFIGURE_ON= --with-libopendkim=${LOCALBASE}
+DKIM_USES= ssl
SPF_CONFIGURE_ON= --with-libspf2=${LOCALBASE}
GEOIP_CONFIGURE_ON= --with-libGeoIP=${LOCALBASE}
CURL_CONFIGURE_ON= --with-libcurl=${LOCALBASE}