aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2018-10-22 15:07:54 +0800
committerehaupt <ehaupt@FreeBSD.org>2018-10-22 15:07:54 +0800
commit0204ee0be06a37e04ae74c54270e14f0b5893847 (patch)
treea0d314702300598dba1830cd5d5a16dc7c661be2 /mail
parente41cc161d8ee84918cbb459db223c432a7118df2 (diff)
downloadfreebsd-ports-gnome-0204ee0be06a37e04ae74c54270e14f0b5893847.tar.gz
freebsd-ports-gnome-0204ee0be06a37e04ae74c54270e14f0b5893847.tar.zst
freebsd-ports-gnome-0204ee0be06a37e04ae74c54270e14f0b5893847.zip
pragrma directive is not supported by base GCC. Remove it to fix build with
mips, mips64, powerpc64. PR: 232514 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Diffstat (limited to 'mail')
-rw-r--r--mail/isync/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/mail/isync/Makefile b/mail/isync/Makefile
index d8fafc30077c..4f9dc0f0a0cf 100644
--- a/mail/isync/Makefile
+++ b/mail/isync/Makefile
@@ -12,10 +12,6 @@ COMMENT= Maintain local copies of remote IMAP folders w/synchronized flags
LICENSE= GPLv2
-BROKEN_mips= fails to compile: util.c:523: \#pragma GCC diagnostic not allowed inside functions
-BROKEN_mips64= fails to compile: util.c:523: \#pragma GCC diagnostic not allowed inside functions
-BROKEN_powerpc64= fails to compile: util.c:523: \#pragma GCC diagnostic not allowed inside functions
-
LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
USES= alias bdb cpe perl5 ssl
@@ -32,10 +28,15 @@ MAKE_ARGS+= SSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
CPPFLAGS+= -I${BDB_INCLUDE_DIR}
LDFLAGS+= -L${BDB_LIB_DIR}
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|: install-docDATA|:|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|\$$(docdir)/examples|\$$(sysconfdir)|g' \
${WRKSRC}/src/Makefile.in ${WRKSRC}/src/compat/Makefile.in
@${REINPLACE_CMD} -e 's|-ansi||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
+ @${REINPLACE_CMD} -e '/pragma/d' ${WRKSRC}/src/util.c
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>