aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2018-04-26 08:53:01 +0800
committerfluffy <fluffy@FreeBSD.org>2018-04-26 08:53:01 +0800
commit072c4546486b13cd95db318d13acdb299c55938a (patch)
treeda7adbd94efa986284ea6439ed407d8164661588 /mail
parent531cc99cf9871d470f9668c4778cdbef4fc64b2e (diff)
downloadfreebsd-ports-gnome-072c4546486b13cd95db318d13acdb299c55938a.tar.gz
freebsd-ports-gnome-072c4546486b13cd95db318d13acdb299c55938a.tar.zst
freebsd-ports-gnome-072c4546486b13cd95db318d13acdb299c55938a.zip
- Pet MDA part, add brackets around Return-Path as per RFC5322 ยง3.6.6.
Missing brackets lead to a panic when a malformed address line is fed to dovecot-lda Submitted by: gahr Reported by: brnrd via dovecot ML Obtained from: https://github.com/OpenSMTPD/OpenSMTPD/pull/847/commits/725ba4fa2ddf23bbcd1ff9ec92e86bbfaa6825c8
Diffstat (limited to 'mail')
-rw-r--r--mail/opensmtpd-devel/Makefile2
-rw-r--r--mail/opensmtpd-devel/files/patch-src_mda.c11
-rw-r--r--mail/opensmtpd/Makefile2
-rw-r--r--mail/opensmtpd/files/patch-src_mda.c11
4 files changed, 24 insertions, 2 deletions
diff --git a/mail/opensmtpd-devel/Makefile b/mail/opensmtpd-devel/Makefile
index 7ff292530b63..40548d0e465e 100644
--- a/mail/opensmtpd-devel/Makefile
+++ b/mail/opensmtpd-devel/Makefile
@@ -4,7 +4,7 @@
PORTNAME= opensmtpd
PORTVERSION= 201606220754
DISTVERSIONSUFFIX= p1
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
diff --git a/mail/opensmtpd-devel/files/patch-src_mda.c b/mail/opensmtpd-devel/files/patch-src_mda.c
new file mode 100644
index 000000000000..3f4e0b1bf9ef
--- /dev/null
+++ b/mail/opensmtpd-devel/files/patch-src_mda.c
@@ -0,0 +1,11 @@
+--- smtpd/mda.c.orig 2016-05-13 02:56:04.000000000 +1000
++++ smtpd/mda.c 2018-04-26 10:28:45.373358000 +1000
+@@ -274,7 +274,7 @@
+ * if any
+ */
+ n = iobuf_fqueue(&s->iobuf,
+- "Return-Path: %s\n"
++ "Return-Path: <%s>\n"
+ "Delivered-To: %s\n",
+ e->sender,
+ e->rcpt ? e->rcpt : e->dest);
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index ee452b76d3d1..d426d05cb70e 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -4,7 +4,7 @@
PORTNAME= opensmtpd
PORTVERSION= 5.9.2p1
PORTEPOCH= 1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
http://distfiles.pirateparty.in/ashish/
diff --git a/mail/opensmtpd/files/patch-src_mda.c b/mail/opensmtpd/files/patch-src_mda.c
new file mode 100644
index 000000000000..3f4e0b1bf9ef
--- /dev/null
+++ b/mail/opensmtpd/files/patch-src_mda.c
@@ -0,0 +1,11 @@
+--- smtpd/mda.c.orig 2016-05-13 02:56:04.000000000 +1000
++++ smtpd/mda.c 2018-04-26 10:28:45.373358000 +1000
+@@ -274,7 +274,7 @@
+ * if any
+ */
+ n = iobuf_fqueue(&s->iobuf,
+- "Return-Path: %s\n"
++ "Return-Path: <%s>\n"
+ "Delivered-To: %s\n",
+ e->sender,
+ e->rcpt ? e->rcpt : e->dest);