aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-18 20:25:41 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-18 20:25:41 +0800
commit07883c192dbb30cf0a875f51cadd7bb2e22e1007 (patch)
treef45bdfb6f43eb830cf6e92a172fc6da85cb96b62 /mail
parentfb4883390907d50b0a65f09307febe0b89b9e6de (diff)
downloadfreebsd-ports-gnome-07883c192dbb30cf0a875f51cadd7bb2e22e1007.tar.gz
freebsd-ports-gnome-07883c192dbb30cf0a875f51cadd7bb2e22e1007.tar.zst
freebsd-ports-gnome-07883c192dbb30cf0a875f51cadd7bb2e22e1007.zip
Support staging
Diffstat (limited to 'mail')
-rw-r--r--mail/libdomainkeys/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/mail/libdomainkeys/Makefile b/mail/libdomainkeys/Makefile
index 7a81ec9349be..945939100cf6 100644
--- a/mail/libdomainkeys/Makefile
+++ b/mail/libdomainkeys/Makefile
@@ -1,4 +1,4 @@
-# Created by: Sergey Skvortsov <skv@protey.ru>
+ Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
PORTNAME= libdomainkeys
@@ -9,21 +9,20 @@ MASTER_SITES= SF/domainkeys/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= DomainKeys library
-USE_LDCONFIG= YES
+USE_LDCONFIG= yes
SHLIB_MAJOR= 3
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
-USE_OPENSSL= YES
+USE_OPENSSL= yes
-NO_STAGE= yes
post-patch:
${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.prev
@${SED} -e "s=%%SHLIB_MAJOR%%=${SHLIB_MAJOR}=g" \
${FILESDIR}/Makefile > ${WRKSRC}/Makefile
post-install:
- @${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/dknewkey ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/test ${DATADIR}/dktest
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/dknewkey ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/test ${STAGEDIR}${DATADIR}/dktest
.include <bsd.port.mk>