aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2018-11-07 04:46:33 +0800
committerzeising <zeising@FreeBSD.org>2018-11-07 04:46:33 +0800
commit28a7dfb1b293a6588d1f9012b88ccf7efe6c13af (patch)
treeabc2a2f19e7edb5aa9d5add326f5eed6e079395e /mail
parent980d0f3cbc6705225bcb4da40c12b50f35966d98 (diff)
downloadfreebsd-ports-gnome-28a7dfb1b293a6588d1f9012b88ccf7efe6c13af.tar.gz
freebsd-ports-gnome-28a7dfb1b293a6588d1f9012b88ccf7efe6c13af.tar.zst
freebsd-ports-gnome-28a7dfb1b293a6588d1f9012b88ccf7efe6c13af.zip
mail/spamassassin: switch gpg version, silence gpg
Switch to use gpg2 instead of the old and mostly deprecated gpg as the default gpg version. Add a gpg.conf file to silence the warning about using insecure memory with gpg2 [1]. Bump portrevision Submitted by: Larry Rosenman (ler) [1]
Diffstat (limited to 'mail')
-rw-r--r--mail/spamassassin/Makefile13
-rw-r--r--mail/spamassassin/pkg-plist1
2 files changed, 10 insertions, 4 deletions
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index eb77f1a462a9..daac11e128ba 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spamassassin
PORTVERSION= 3.4.2
-PORTREVISION?= 0 # also bump japanese/spamassassin
+PORTREVISION?= 1 # also bump japanese/spamassassin
CATEGORIES?= mail perl5
MASTER_SITES= APACHE/spamassassin/source CPAN/Mail
DISTNAME= Mail-SpamAssassin-${PORTVERSION}
@@ -24,6 +24,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
p5-URI>=0:net/p5-URI \
re2c>=.12.0:devel/re2c
+USES= cpe perl5
+
.for dep in DCC DKIM MYSQL PGSQL PYZOR RAZOR RELAY_COUNTRY RLIMIT SPF_QUERY SSL
TEST_DEPENDS+= ${${dep}_RUN_DEPENDS}
.endfor
@@ -32,7 +34,6 @@ CONFLICTS?= ja-spamassassin-[0-9]*
CPE_VENDOR= apache
-USES= cpe perl5
USE_PERL5= configure
USE_LDCONFIG= yes
@@ -55,7 +56,7 @@ OPTIONS_GROUP_DATABASE= MYSQL PGSQL
OPTIONS_GROUP_PLUGINS= DCC DKIM PYZOR RAZOR RELAY_COUNTRY RLIMIT SPF_QUERY
OPTIONS_SINGLE= GPG
OPTIONS_SINGLE_GPG= GNUPG_NONE GNUPG GNUPG2
-OPTIONS_DEFAULT= AS_ROOT DKIM GNUPG SSL SPF_QUERY
+OPTIONS_DEFAULT= AS_ROOT DKIM GNUPG2 SSL SPF_QUERY
AS_ROOT_DESC= Run spamd as root (recommended)
@@ -168,11 +169,15 @@ pre-su-install:
.endif
${INSTALL_DATA} ${WRKSRC}/spamc/libspamc.h ${STAGEDIR}${PREFIX}/include
-post-install::
+post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/spamc
@${MKDIR} ${STAGEDIR}/var/lib/spamassassin ${STAGEDIR}${DBDIR}/spamassassin ${STAGEDIR}/var/run/spamd
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "sql ldap" ${STAGEDIR}${DOCSDIR})
+post-install-GNUPG2-on:
+ ${MKDIR} ${STAGEDIR}/${ETCDIR}/sa-update-keys
+ ${ECHO} "no-secmem-warning" >${STAGEDIR}/${ETCDIR}/sa-update-keys/gpg.conf
+
.include <bsd.port.post.mk>
diff --git a/mail/spamassassin/pkg-plist b/mail/spamassassin/pkg-plist
index bc7494e9dc2d..2c5bf812adc2 100644
--- a/mail/spamassassin/pkg-plist
+++ b/mail/spamassassin/pkg-plist
@@ -16,6 +16,7 @@ bin/spamd
@sample %%ETCDIR%%/v340.pre.sample
@sample %%ETCDIR%%/v341.pre.sample
@sample %%ETCDIR%%/v342.pre.sample
+%%GNUPG2%%%%ETCDIR%%/sa-update-keys/gpg.conf
include/libspamc.h
lib/libspamc.so
lib/libspamc.so.0