aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2009-05-03 00:49:41 +0800
committerleeym <leeym@FreeBSD.org>2009-05-03 00:49:41 +0800
commit2cea0c671ffee96859338e2c8a8083315d3f37bd (patch)
tree1cb64f39310cf65413f9612d84873adb33cc0223 /mail
parent38bcc06b3394b74d9e6aa4b35daca79dda6c0c9b (diff)
downloadfreebsd-ports-gnome-2cea0c671ffee96859338e2c8a8083315d3f37bd.tar.gz
freebsd-ports-gnome-2cea0c671ffee96859338e2c8a8083315d3f37bd.tar.zst
freebsd-ports-gnome-2cea0c671ffee96859338e2c8a8083315d3f37bd.zip
- simplify dependency
- update WWW in pkg-descr - bump PORTREVISION
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-MIME-Tools/Makefile28
-rw-r--r--mail/p5-MIME-Tools/pkg-descr2
2 files changed, 20 insertions, 10 deletions
diff --git a/mail/p5-MIME-Tools/Makefile b/mail/p5-MIME-Tools/Makefile
index 45318acbdaf0..4871d8d40ec3 100644
--- a/mail/p5-MIME-Tools/Makefile
+++ b/mail/p5-MIME-Tools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= MIME-Tools
PORTVERSION= 5.427
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= mail perl5
MASTER_SITES= CPAN
@@ -16,12 +17,10 @@ DISTNAME= MIME-tools-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= A set of perl5 modules for MIME
-BUILD_DEPENDS= ${SITE_PERL}/Mail/Header.pm:${PORTSDIR}/mail/p5-Mail-Tools \
- ${SITE_PERL}/IO/Wrap.pm:${PORTSDIR}/devel/p5-IO-stringy \
- ${SITE_PERL}/Convert/BinHex.pm:${PORTSDIR}/converters/p5-Convert-BinHex \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Convert-BinHex>=0:${PORTSDIR}/converters/p5-Convert-BinHex \
+ p5-IO-stringy>=2.11:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-Mail-Tools>=1.0203:${PORTSDIR}/mail/p5-Mail-Tools
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= YES
@@ -57,7 +56,18 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-post-patch:
- @${FIND} ${WRKSRC} -name "*.orig" | ${XARGS} ${RM} -f
+.include <bsd.port.pre.mk>
-.include <bsd.port.mk>
+.if ${PERL_LEVEL} < 500801
+RUN_DEPENDS+= p5-MIME-Base64>=2.2:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.if ${PERL_LEVEL} < 500703
+BUILD_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.if ${PERL_LEVEL} < 500905
+RUN_DEPENDS+= p5-File-Temp>=0.18:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-MIME-Tools/pkg-descr b/mail/p5-MIME-Tools/pkg-descr
index d7c6bddb348d..c5a03b3b8498 100644
--- a/mail/p5-MIME-Tools/pkg-descr
+++ b/mail/p5-MIME-Tools/pkg-descr
@@ -11,4 +11,4 @@ MIME::ParserBase MIME::ToolUtils MIME::Tools MIME::Words
Warning: This module is _very_ slow for (at least some) large mails,
is derived from Mail-Tools, and has at least some mail-specific parts.
-WWW: http://www.zeegee.com/code/perl/MIME-tools/
+WWW: http://search.cpan.org/dist/MIME-tools/