aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-12-01 00:47:24 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-12-01 00:47:24 +0800
commit35bc56b58c28a223235bc30b05011227c343c99b (patch)
tree04dfa172015f727a4be403ae40edd8d4f705c6ad /mail
parentf374d4b80d01b029ea92d104a44279998343f07c (diff)
downloadfreebsd-ports-gnome-35bc56b58c28a223235bc30b05011227c343c99b.tar.gz
freebsd-ports-gnome-35bc56b58c28a223235bc30b05011227c343c99b.tar.zst
freebsd-ports-gnome-35bc56b58c28a223235bc30b05011227c343c99b.zip
- Switch to options helpers
- Minor cleanup
Diffstat (limited to 'mail')
-rw-r--r--mail/nmzmail/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/mail/nmzmail/Makefile b/mail/nmzmail/Makefile
index 8ea4549972b2..a7f3f96dade7 100644
--- a/mail/nmzmail/Makefile
+++ b/mail/nmzmail/Makefile
@@ -22,17 +22,17 @@ OPTIONS_DEFINE= DOCS
pre-extract:
.if !defined(MAX_MAIL_DIRS)
- @ ${ECHO_MSG} "You can define MAX_MAIL_DIRS=n."
- @ ${ECHO_MSG} "nmzmail will only process this many mailboxes, the default is 32."
+ @${ECHO_MSG} "You can define MAX_MAIL_DIRS=n."
+ @${ECHO_MSG} "nmzmail will only process this many mailboxes, the default is 32."
.endif
post-extract:
.if defined(MAX_MAIL_DIRS)
- @ ${SED} -i.bak -e 's/MAX_MAIL_DIRS 32/MAX_MAIL_DIRS ${MAX_MAIL_DIRS}/' \
- ${WRKSRC}/src/nmzmail.c
+ @${REINPLACE_CMD} -e 's/MAX_MAIL_DIRS 32/MAX_MAIL_DIRS ${MAX_MAIL_DIRS}/' \
+ ${WRKSRC}/src/nmzmail.c
.endif
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}