aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2007-01-29 23:49:01 +0800
committernork <nork@FreeBSD.org>2007-01-29 23:49:01 +0800
commit393667f0f4e9788317930f6e9a78768cd945fc87 (patch)
tree7612756b13f509b5f0c9fbd46934df989f0c575c /mail
parentbcf396eaadd837d6442fc04959e4422ce775ce46 (diff)
downloadfreebsd-ports-gnome-393667f0f4e9788317930f6e9a78768cd945fc87.tar.gz
freebsd-ports-gnome-393667f0f4e9788317930f6e9a78768cd945fc87.tar.zst
freebsd-ports-gnome-393667f0f4e9788317930f6e9a78768cd945fc87.zip
o Update to 2.4.0 beta1.
o Reduce diffs from mail/sylpheed2.
Diffstat (limited to 'mail')
-rw-r--r--mail/sylpheed2-devel/Makefile26
-rw-r--r--mail/sylpheed2-devel/distinfo6
-rw-r--r--mail/sylpheed2-devel/files/patch-libsylph-ssl.c10
3 files changed, 16 insertions, 26 deletions
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index 2cedc234987b..55b8e003bd1b 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -6,13 +6,11 @@
#
PORTNAME= sylpheed
-PORTVERSION= 2.3.0.rc
+PORTVERSION= 2.4.0.b1
PORTREVISION= 0
CATEGORIES= mail ipv6
-MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v2.3beta/ \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= sylpheed-claws/
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.rc/rc/}
+MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v2.4beta/
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.b/beta/}
MAINTAINER= nork@FreeBSD.org
COMMENT= A lightweight, featureful, and fast GTK+ based e-mail client
@@ -22,17 +20,19 @@ RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support \
#IGNORE= "is out-of-dated, use mail/sylpheed2 instead of this, until the next development starts."
-LATEST_LINK= ${PORTNAME}23
+LATEST_LINK= ${PORTNAME}24
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_ICONV= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib -L${X11BASE}/lib"
+# Sylpheed needs pthread if GnomeVFS is installed (GtkFileChooser uses it)
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-ipv6 \
--prefix=${PREFIX} \
--with-libintl-prefix=${LOCALBASE} \
@@ -128,10 +128,6 @@ post-patch:
.endif
post-install:
- @${MKDIR} ${PREFIX}/share/pixmaps
- @${MKDIR} ${PREFIX}/share/applications
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${PREFIX}/share/pixmaps/
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.desktop ${PREFIX}/share/applications/
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ChangeLog INSTALL README TODO
@@ -139,5 +135,9 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${i}.ja ${DOCSDIR}
.endfor
.endif
+ @${MKDIR} ${PREFIX}/share/pixmaps
+ @${MKDIR} ${PREFIX}/share/applications
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${PREFIX}/share/pixmaps/
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed.desktop ${PREFIX}/share/applications/
.include <bsd.port.post.mk>
diff --git a/mail/sylpheed2-devel/distinfo b/mail/sylpheed2-devel/distinfo
index 3a59d253f959..a79c38624b8f 100644
--- a/mail/sylpheed2-devel/distinfo
+++ b/mail/sylpheed2-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (sylpheed-2.3.0rc.tar.bz2) = 4e29600db22061fc3c7ce69fa7c6f220
-SHA256 (sylpheed-2.3.0rc.tar.bz2) = 38aea98ed463bbcc4136584ec2e769825677378a057c5e9f3893310a5b07170c
-SIZE (sylpheed-2.3.0rc.tar.bz2) = 2628875
+MD5 (sylpheed-2.4.0beta1.tar.bz2) = 81cf5dcec6ba332786c0a3592c688dfb
+SHA256 (sylpheed-2.4.0beta1.tar.bz2) = 046f4b2b9b7d081b2d7aa13f819348b9b31d84a3b8ba85c593cb9964fe3f8940
+SIZE (sylpheed-2.4.0beta1.tar.bz2) = 2628893
diff --git a/mail/sylpheed2-devel/files/patch-libsylph-ssl.c b/mail/sylpheed2-devel/files/patch-libsylph-ssl.c
deleted file mode 100644
index f5ee34547995..000000000000
--- a/mail/sylpheed2-devel/files/patch-libsylph-ssl.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libsylph/ssl.c.orig Mon Dec 18 15:16:01 2006
-+++ libsylph/ssl.c Sat Dec 23 14:41:18 2006
-@@ -55,6 +55,7 @@
- if (certs_dir) {
- LOOK_FOR("ca-certificates.crt");
- LOOK_FOR("ca-bundle.crt");
-+ LOOK_FOR("ca-root.crt");
- LOOK_FOR("certs.crt");
- }
-