aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2006-02-09 19:29:11 +0800
committerflz <flz@FreeBSD.org>2006-02-09 19:29:11 +0800
commit3d88bef0e09b86a057f40ff31ceb6b21691266b4 (patch)
tree9dc888f7292d5ab3ad8846fc45f54f2dd490ffb0 /mail
parentf3b6a88de85ecfae817f4d012eeef62d390cb572 (diff)
downloadfreebsd-ports-gnome-3d88bef0e09b86a057f40ff31ceb6b21691266b4.tar.gz
freebsd-ports-gnome-3d88bef0e09b86a057f40ff31ceb6b21691266b4.tar.zst
freebsd-ports-gnome-3d88bef0e09b86a057f40ff31ceb6b21691266b4.zip
- Add missing pkg-install.in script.
- Fix whitespace. Reported by: pointyhat via kris Pointy hat to: self
Diffstat (limited to 'mail')
-rw-r--r--mail/roundcube/Makefile2
-rw-r--r--mail/roundcube/files/pkg-install.in (renamed from mail/roundcube/pkg-install)7
2 files changed, 8 insertions, 1 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index be231dd664fe..f630557b2958 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -50,7 +50,7 @@ OPTIONS= MYSQL "Use MySQL backend" on \
PGSQL "Use PostgreSQL backend" off
.if defined(PHP_VER) && ${PHP_VER} == 5
-OPTIONS+= SQLITE "Use SQLite backend" off
+OPTIONS+= SQLITE "Use SQLite backend" off
.endif
.include <bsd.port.pre.mk>
diff --git a/mail/roundcube/pkg-install b/mail/roundcube/files/pkg-install.in
index ca19fb80a3aa..a750c4ec6b02 100644
--- a/mail/roundcube/pkg-install
+++ b/mail/roundcube/files/pkg-install.in
@@ -1,5 +1,7 @@
#! /bin/sh
+RCUBEROOT=%%RCUBEROOT%%
+
case $2 in
POST-INSTALL)
@@ -10,6 +12,11 @@ POST-INSTALL)
[ -f ${i} ] || cp ${i}.dist ${i}
done
;;
+DEINSTALL)
+ for i in ${RCUBEROOT}/config/db.inc.php ${RCUBEROOT}/config/main.inc.php; do
+ if cmp -s ${i} ${i}.dist; then rm ${i}; fi
+ done
+ ;;
*)
exit 1
;;