aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-05-25 15:46:10 +0800
committerbsam <bsam@FreeBSD.org>2013-05-25 15:46:10 +0800
commit3fd6a528b20c494d3bb03086aba98e560e21aaaf (patch)
tree3c3b4075cffe3ac75ba6f6d63d5ca09608737762 /mail
parent968927c8e121879b052b02108a9db6e494bc12bb (diff)
downloadfreebsd-ports-gnome-3fd6a528b20c494d3bb03086aba98e560e21aaaf.tar.gz
freebsd-ports-gnome-3fd6a528b20c494d3bb03086aba98e560e21aaaf.tar.zst
freebsd-ports-gnome-3fd6a528b20c494d3bb03086aba98e560e21aaaf.zip
Use shebangfix and let Makefile be more declarative.
Convinced by: jgh, danfe
Diffstat (limited to 'mail')
-rw-r--r--mail/imaptools/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/mail/imaptools/Makefile b/mail/imaptools/Makefile
index 7dc3e16ed2ad..b1e1d96b446c 100644
--- a/mail/imaptools/Makefile
+++ b/mail/imaptools/Makefile
@@ -15,12 +15,12 @@ LICENSE= ISCL
CONFLICTS= imaputils-[0-9]*
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USES= shebangfix
+SHEBANG_FILES= *.pl
USE_PERL5_RUN= yes
-do-build:
- ${REINPLACE_CMD} \
- -e 's|/usr/bin/perl|${PERL}|g' ${WRKDIR}/*.pl
-
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/*.pl ${PREFIX}/bin