aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-12-27 17:46:01 +0800
committertobez <tobez@FreeBSD.org>2005-12-27 17:46:01 +0800
commit531826cc84d877694aa10a6654a98d2a7f39d5e4 (patch)
treef02f419c6f354ed917add1b8d5c04bafc6c1f9af /mail
parentfb145cec347cac48fa3ed938b0dd2b4c2a2f74a2 (diff)
downloadfreebsd-ports-gnome-531826cc84d877694aa10a6654a98d2a7f39d5e4.tar.gz
freebsd-ports-gnome-531826cc84d877694aa10a6654a98d2a7f39d5e4.tar.zst
freebsd-ports-gnome-531826cc84d877694aa10a6654a98d2a7f39d5e4.zip
Add mail/p5-Email-Send 2.00, a Perl module for sending email, simply.
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Email-Send/Makefile42
-rw-r--r--mail/p5-Email-Send/distinfo3
-rw-r--r--mail/p5-Email-Send/pkg-descr5
-rw-r--r--mail/p5-Email-Send/pkg-plist11
5 files changed, 62 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 6c0677618bd7..30a52f9121b2 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -272,6 +272,7 @@
SUBDIR += p5-Email-MIME-Encodings
SUBDIR += p5-Email-MIME-Modifier
SUBDIR += p5-Email-MessageID
+ SUBDIR += p5-Email-Send
SUBDIR += p5-Email-Simple
SUBDIR += p5-Email-Simple-Creator
SUBDIR += p5-Email-Valid
diff --git a/mail/p5-Email-Send/Makefile b/mail/p5-Email-Send/Makefile
new file mode 100644
index 000000000000..628fafd6c316
--- /dev/null
+++ b/mail/p5-Email-Send/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: mail/p5-Email-Send
+# Date created: 27 December 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-Send
+PORTVERSION= 2.00
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Email::Send - Simply Sending Email
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
+ ${SITE_PERL}/Return/Value.pm:${PORTSDIR}/devel/p5-Return-Value \
+ ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Email/Address.pm:${PORTSDIR}/mail/p5-Email-Address \
+ p5-Net>0:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::Send.3 \
+ Email::Send::IO.3 \
+ Email::Send::NNTP.3 \
+ Email::Send::Qmail.3 \
+ Email::Send::SMTP.3 \
+ Email::Send::Sendmail.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Email-Send/distinfo b/mail/p5-Email-Send/distinfo
new file mode 100644
index 000000000000..a2b8b13dcfbf
--- /dev/null
+++ b/mail/p5-Email-Send/distinfo
@@ -0,0 +1,3 @@
+MD5 (Email-Send-2.00.tar.gz) = d950eee17da5f815e92c6b7d7aefb299
+SHA256 (Email-Send-2.00.tar.gz) = c7918b403a3f08a46e4a45cf564394cb3ffca11b029971f180cb241cfa4228bd
+SIZE (Email-Send-2.00.tar.gz) = 9396
diff --git a/mail/p5-Email-Send/pkg-descr b/mail/p5-Email-Send/pkg-descr
new file mode 100644
index 000000000000..d76b1b4365bd
--- /dev/null
+++ b/mail/p5-Email-Send/pkg-descr
@@ -0,0 +1,5 @@
+This module provides a very simple, very clean, very specific interface
+to multiple Email mailers. The goal of this software is to be small
+and simple, easy to use, and easy to extend.
+
+WWW: http://search.cpan.org/dist/Email-Send/
diff --git a/mail/p5-Email-Send/pkg-plist b/mail/p5-Email-Send/pkg-plist
new file mode 100644
index 000000000000..affd3d397f52
--- /dev/null
+++ b/mail/p5-Email-Send/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Email/Send.pm
+%%SITE_PERL%%/Email/Send/IO.pm
+%%SITE_PERL%%/Email/Send/NNTP.pm
+%%SITE_PERL%%/Email/Send/Qmail.pm
+%%SITE_PERL%%/Email/Send/SMTP.pm
+%%SITE_PERL%%/Email/Send/Sendmail.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Send/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Send 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Email/Send 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Email 2>/dev/null || true