aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2009-02-18 15:00:44 +0800
committeritetcu <itetcu@FreeBSD.org>2009-02-18 15:00:44 +0800
commit57717768770680a640858b1689d9472192e0f605 (patch)
tree4ac1596371b24bd5ebe4d8365aefb4fe431ec8ae /mail
parent88e36a4684ebc4b00f39f316ce56adb55bdcbcb3 (diff)
downloadfreebsd-ports-gnome-57717768770680a640858b1689d9472192e0f605.tar.gz
freebsd-ports-gnome-57717768770680a640858b1689d9472192e0f605.tar.zst
freebsd-ports-gnome-57717768770680a640858b1689d9472192e0f605.zip
Add MAILDROP_LOG_COLUMNS which controlls the lenght of the 'File:' line in the
logs. Default it to 72 (like in the sources), which plus the message size gives 80 (= standard # of columns in a terminal). If you watch the logs under X something like 140 will probably use your screen width more usfully. Approved by: maintainer
Diffstat (limited to 'mail')
-rw-r--r--mail/maildrop/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index af4f78b0d380..f36d358f1c88 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -15,6 +15,7 @@
# MAILDROP_TRUSTED_USERS=<user> Specify users allowed to use the -d option
# NO_MAILWRAPPER=yes If defined, let configure guess which sendmail binary
# to use
+# MAILDROP_LOG_COLUMNS lenght of 'File:' line in log - 8; default: 72
PORTNAME= maildrop
PORTVERSION= 2.0.4
@@ -38,6 +39,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+MAILDROP_LOG_COLUMNS?= 72 # lenght of 'File:' line in log
+
.if defined(WITH_AUTHLIB)
.if exists(${.CURDIR}/../../security/courier-authlib/Makefile.opt)
.include "${.CURDIR}/../../security/courier-authlib/Makefile.opt"
@@ -73,18 +76,19 @@ USE_FAM= yes
CONFIGURE_ARGS+= --enable-trusted-users="${MAILDROP_TRUSTED_USERS}"
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s/l= 72 - szbuf.Length();/l= ${MAILDROP_LOG_COLUMNS} - szbuf.Length();/" \
+ ${WRKSRC}/maildrop/log.C
.if defined(WITH_AUTHLIB)
.if exists(${.CURDIR}/../../security/courier-authlib/Makefile.dep)
.include "${.CURDIR}/../../security/courier-authlib/Makefile.dep"
.endif
-BUILD_DEPENDS+= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
-RUN_DEPENDS+= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
-CONFIGURE_ARGS+= --enable-authlib
-
-post-patch:
@${REINPLACE_CMD} -e 's|@LIBS@|@LIBS@ \
-rpath=:${LOCALBASE}/lib/courier-authlib|' \
${WRKSRC}/maildrop/Makefile.in
+BUILD_DEPENDS+= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+RUN_DEPENDS+= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+CONFIGURE_ARGS+= --enable-authlib
.else
CONFIGURE_ARGS+= --disable-authlib
.endif