aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2013-12-07 00:59:37 +0800
committerfeld <feld@FreeBSD.org>2013-12-07 00:59:37 +0800
commit6bdc70f6389a7a8a3b921c96f952238f1b8816fc (patch)
tree378bd05b5f0b0a82bce3a6ab155ee9c98af0932e /mail
parent2641dff9e47c5a2505c023b922e3a61ed42ec844 (diff)
downloadfreebsd-ports-gnome-6bdc70f6389a7a8a3b921c96f952238f1b8816fc.tar.gz
freebsd-ports-gnome-6bdc70f6389a7a8a3b921c96f952238f1b8816fc.tar.zst
freebsd-ports-gnome-6bdc70f6389a7a8a3b921c96f952238f1b8816fc.zip
Import patch to fix IPv6 greylisting
This patch is floating in the bug system on SourceForge. Upstream develoment is slow/nonexistent. If you have IPv6 mail servers and run sqlgrey you may notice emails from places like GMail sometimes get lost or take forever to get be received. This is because GMail does not retry from the same server, and they have a large pool of IPv6 capable MTAs. For IPv4 sqlgrey handles this by whitelisting the entire /24, but similar logic for whitelisting a /64 in sqlgrey doesn't work consistently. This fixes it. PR: ports/182440 Approved by: crees (mentor), maintainer timeout
Diffstat (limited to 'mail')
-rw-r--r--mail/sqlgrey/Makefile1
-rw-r--r--mail/sqlgrey/files/patch-ipv611
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 2174cb650469..36c0a640caef 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sqlgrey
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-1.8%20%28stable%29
diff --git a/mail/sqlgrey/files/patch-ipv6 b/mail/sqlgrey/files/patch-ipv6
new file mode 100644
index 000000000000..8be3f957e0a2
--- /dev/null
+++ b/mail/sqlgrey/files/patch-ipv6
@@ -0,0 +1,11 @@
+--- sqlgrey.orig 2013-09-27 06:51:40.913265753 -0500
++++ sqlgrey 2013-09-27 06:51:25.000000000 -0500
+@@ -1037,7 +1037,7 @@
+ return join(":", (split(/:/, $addr))[0..3]);
+ } else {
+ ## For Non-EUI64 or Non-Global-Unicast return the address
+- return $addr;
++ return join(":", (split(/:/, $addr))[0..3]);
+ }
+ }
+