aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-01-30 08:54:15 +0800
committerjbeich <jbeich@FreeBSD.org>2018-01-30 08:54:15 +0800
commit772a19d89d57e1b17331c7a6a2dc63835c81d56a (patch)
tree7f3a37de356eead36207e7a7ae83df74679ca0e5 /mail
parentb50aa700bc756283f236d71af0a2ded7a153b8fe (diff)
downloadfreebsd-ports-gnome-772a19d89d57e1b17331c7a6a2dc63835c81d56a.tar.gz
freebsd-ports-gnome-772a19d89d57e1b17331c7a6a2dc63835c81d56a.tar.zst
freebsd-ports-gnome-772a19d89d57e1b17331c7a6a2dc63835c81d56a.zip
www/firefox-esr: work around race on sqlite3 init
PR: 225364 Obtained from: upstream (Firefox 56) MFH: 2018Q1 (r459458 follow up)
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/files/patch-bug138070636
2 files changed, 37 insertions, 1 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 691ca98cc09e..6be8bb7f0ad0 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 52.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1380706 b/mail/thunderbird/files/patch-bug1380706
new file mode 100644
index 000000000000..0fe688458ae6
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1380706
@@ -0,0 +1,36 @@
+commit 10b55207992c
+Author: Kai Engert <kaie@kuix.de>
+Date: Fri Jul 14 15:31:30 2017 +0200
+
+ Bug 1380706, PSM should depend on mozStorage, as a workaround for a sqlite3_config race, r=keeler
+---
+ security/manager/ssl/nsNSSComponent.cpp | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git security/manager/ssl/nsNSSComponent.cpp security/manager/ssl/nsNSSComponent.cpp
+index f51f8af47d51..a82c1ed61fba 100644
+--- mozilla/security/manager/ssl/nsNSSComponent.cpp
++++ mozilla/security/manager/ssl/nsNSSComponent.cpp
+@@ -13,6 +13,7 @@
+ #include "SharedSSLState.h"
+ #include "cert.h"
+ #include "certdb.h"
++#include "mozStorageCID.h"
+ #include "mozilla/ArrayUtils.h"
+ #include "mozilla/Assertions.h"
+ #include "mozilla/Casting.h"
+@@ -2032,6 +2033,14 @@ nsNSSComponent::Init()
+ return NS_ERROR_NOT_AVAILABLE;
+ }
+
++ // To avoid a sqlite3_config race in NSS init, as a workaround for
++ // bug 730495, we require the storage service to get initialized first.
++ nsCOMPtr<nsISupports> storageService =
++ do_GetService(MOZ_STORAGE_SERVICE_CONTRACTID);
++ if (!storageService) {
++ return NS_ERROR_NOT_AVAILABLE;
++ }
++
+ MOZ_LOG(gPIPNSSLog, LogLevel::Debug, ("Beginning NSS initialization\n"));
+
+ nsresult rv = InitializePIPNSSBundle();