aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2014-05-07 02:14:01 +0800
committerfeld <feld@FreeBSD.org>2014-05-07 02:14:01 +0800
commit7bfa544c17ce2e5db1f04d92afef4d0b520caf83 (patch)
treef0ef414ab275d6094d57d5dc8c60c9baf4c816dd /mail
parent3158311af530facd34e7e11028da8cfa8e064976 (diff)
downloadfreebsd-ports-gnome-7bfa544c17ce2e5db1f04d92afef4d0b520caf83.tar.gz
freebsd-ports-gnome-7bfa544c17ce2e5db1f04d92afef4d0b520caf83.tar.zst
freebsd-ports-gnome-7bfa544c17ce2e5db1f04d92afef4d0b520caf83.zip
Fix support for Postgres 9.2
Diffstat (limited to 'mail')
-rw-r--r--mail/archiveopteryx/Makefile2
-rw-r--r--mail/archiveopteryx/files/patch-db__postgres.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index 0e65b5ecaf5d..543484e66fe3 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= archiveopteryx
PORTVERSION= 3.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://archiveopteryx.org/download/
diff --git a/mail/archiveopteryx/files/patch-db__postgres.cpp b/mail/archiveopteryx/files/patch-db__postgres.cpp
new file mode 100644
index 000000000000..cb0eaeefc3b2
--- /dev/null
+++ b/mail/archiveopteryx/files/patch-db__postgres.cpp
@@ -0,0 +1,11 @@
+--- ./db/postgres.cpp.orig 2014-05-06 13:03:48.795894217 -0500
++++ ./db/postgres.cpp 2014-05-06 13:04:03.207891218 -0500
+@@ -85,7 +85,7 @@
+ "from pg_locks h join pg_locks w using (locktype) "
+ "join pg_stat_activity a on (h.pid="
+ );
+- if (Postgres::version() < 90300)
++ if (Postgres::version() < 90200)
+ s.append( "a.procpid" );
+ else
+ s.append( "a.pid" );