aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2005-11-18 06:54:30 +0800
committerroam <roam@FreeBSD.org>2005-11-18 06:54:30 +0800
commit8408b1d055ae77925163f09c3280e10c42bc82c0 (patch)
treecc6db9c2ec43eb52054e0eeca1c611775a6a450f /mail
parentf604e3d2675e5a931d4926ef272fea35cc54d51d (diff)
downloadfreebsd-ports-gnome-8408b1d055ae77925163f09c3280e10c42bc82c0.tar.gz
freebsd-ports-gnome-8408b1d055ae77925163f09c3280e10c42bc82c0.tar.zst
freebsd-ports-gnome-8408b1d055ae77925163f09c3280e10c42bc82c0.zip
Unless WITHOUT_FPIC is defined, add -fPIC to the C compiler flags.
This fixes the build of ports that use libvpopmail, at least on amd64, and does not hurt on other platforms. PR: 88402 Submitted by: Matteo Baldi <egon@egonflower.com> among others
Diffstat (limited to 'mail')
-rw-r--r--mail/vpopmail/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index 9737458b4ce5..b75208285bff 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vpopmail
PORTVERSION= 5.4.10
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -64,6 +64,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
# WITH_SPAMASSASSIN - enable SpamAssassin checks before Maildir delivery
# WITH_SUID_VCHKPW - set the setuid bit on the vchkpw program
# WITH_SMTP_AUTH_PATCH - apply an SMTP authentcation fix
+# WITHOUT_FPIC - do not add -fPIC to the C compiler flags
#
# Set these to the values you'd prefer
#
@@ -132,6 +133,10 @@ RELAYCLEAR?= 30
SPAM_THRESHOLD?=15
LOGLEVEL?= y
+.if !defined(WITHOUT_FPIC)
+CFLAGS+= -fPIC
+.endif
+
.if defined(WITH_LDAP)
USE_OPENLDAP= yes
.if defined(WITH_LDAP_SASL)