aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-05-12 16:48:02 +0800
committerpav <pav@FreeBSD.org>2009-05-12 16:48:02 +0800
commit8fde4ddb039431e4b59eb144e8600c013cc9d2fb (patch)
tree7994999a3f37723f0017378766a30d541b9fb16c /mail
parent5358153cc7a30cee2ed9e22c78818dd59c92c8e3 (diff)
downloadfreebsd-ports-gnome-8fde4ddb039431e4b59eb144e8600c013cc9d2fb.tar.gz
freebsd-ports-gnome-8fde4ddb039431e4b59eb144e8600c013cc9d2fb.tar.zst
freebsd-ports-gnome-8fde4ddb039431e4b59eb144e8600c013cc9d2fb.zip
- Add MAX_MAIL_DIRS option to define a number of mailboxes to process
PR: ports/132815 Submitted by: Fernan Aguero <fernan.aguero@gmail.com> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/nmzmail/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/mail/nmzmail/Makefile b/mail/nmzmail/Makefile
index f9a43d7f3c43..47a33093070c 100644
--- a/mail/nmzmail/Makefile
+++ b/mail/nmzmail/Makefile
@@ -23,6 +23,18 @@ USE_GMAKE= yes
PLIST_FILES= bin/nmzmail
PORTDOCS= README NEWS
+pre-extract:
+.if !defined(MAX_MAIL_DIRS)
+ @ ${ECHO_MSG} "You can define MAX_MAIL_DIRS=n."
+ @ ${ECHO_MSG} "nmzmail will only process this many mailboxes, the default is 32."
+.endif
+
+post-extract:
+.if defined(MAX_MAIL_DIRS)
+ @ ${SED} -i.bak -e 's/MAX_MAIL_DIRS 32/MAX_MAIL_DIRS ${MAX_MAIL_DIRS}/' \
+ ${WRKSRC}/src/nmzmail.c
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${INSTALL} -d ${DOCSDIR}/