aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2007-04-18 14:08:10 +0800
committerlwhsu <lwhsu@FreeBSD.org>2007-04-18 14:08:10 +0800
commit9daa96243c3960b7888d5d1b31bea82674258ade (patch)
treea5356d9f2b67e3e878767ec76dfb50908748a1ca /mail
parent5aa0df56b96c48f6ae67e43936a26eeb272a7baa (diff)
downloadfreebsd-ports-gnome-9daa96243c3960b7888d5d1b31bea82674258ade.tar.gz
freebsd-ports-gnome-9daa96243c3960b7888d5d1b31bea82674258ade.tar.zst
freebsd-ports-gnome-9daa96243c3960b7888d5d1b31bea82674258ade.zip
- Add /etc/passwd authentication method support
- Bump PORTREVISION PR: 111806 Submitted by: Alexander Logvinov <ports AT logvinov.com> Approved by: Boris Kovalenko <boris AT tagnet.ru> (maintainer), clsung (mentor)
Diffstat (limited to 'mail')
-rw-r--r--mail/tpop3d/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index 79f2ae344cbb..1104a65c68f1 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tpop3d
PORTVERSION= 1.5.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= http://www.ex-parrot.com/~chris/tpop3d/
@@ -26,7 +26,8 @@ OPTIONS= MYSQL "Use MySQL authentication" off \
PGSQL "Use PgSQL authentication" off \
LDAP "Use LDAP authentication" off \
PERLAUTH "Use Perl authentication" off \
- FLATAUTH "Enable /etc/passwd-style authentication" off \
+ PASSWDAUTH "Use /etc/passwd authentication" off \
+ FLATAUTH "Use /etc/passwd-style flat file authentication" off \
MAILDIR "Compile Maildir support" on \
DRAC "Enable DRAC RFC for POP-before-SMTP relaying" off \
FIX_PERLAUTH "Only try it if perl-auth coredumps" off
@@ -67,6 +68,10 @@ CONFIGURE_ARGS+= --enable-auth-perl
CONFIGURE_ARGS+= --enable-auth-flatfile
.endif
+.if defined(WITH_PASSWDAUTH)
+CONFIGURE_ARGS+= --enable-auth-passwd
+.endif
+
.if !defined(WITHOUT_MAILDIR)
CONFIGURE_ARGS+= --enable-mbox-maildir
.endif