aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2017-10-30 18:40:01 +0800
committergahr <gahr@FreeBSD.org>2017-10-30 18:40:01 +0800
commitab8ae9ecbee25bf9660a069b0a19a5fd6cc7c0a8 (patch)
tree31984860e454e57d62390152dda1146b611c0894 /mail
parentfc436af529df79aa81b90ca75c93d40a4be13c2b (diff)
downloadfreebsd-ports-gnome-ab8ae9ecbee25bf9660a069b0a19a5fd6cc7c0a8.tar.gz
freebsd-ports-gnome-ab8ae9ecbee25bf9660a069b0a19a5fd6cc7c0a8.tar.zst
freebsd-ports-gnome-ab8ae9ecbee25bf9660a069b0a19a5fd6cc7c0a8.zip
mail/roundcube-carddav: fix adding new calendars with Roundcube 1.3
See https://github.com/blind-coder/rcmcarddav/issues/186 for the issue and https://github.com/blind-coder/rcmcarddav/commit/c14c32a for the commit.
Diffstat (limited to 'mail')
-rw-r--r--mail/roundcube-carddav/Makefile9
-rw-r--r--mail/roundcube-carddav/distinfo6
-rw-r--r--mail/roundcube-carddav/files/patch-rcube-input-post65
3 files changed, 74 insertions, 6 deletions
diff --git a/mail/roundcube-carddav/Makefile b/mail/roundcube-carddav/Makefile
index 0b3a9ebd0e17..4751f9e26787 100644
--- a/mail/roundcube-carddav/Makefile
+++ b/mail/roundcube-carddav/Makefile
@@ -3,8 +3,9 @@
PORTNAME= carddav
PORTVERSION= 2.0.4
+DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= mail
-MASTER_SITES= https://github.com/blind-coder/rcmcarddav/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= roundcube-
MAINTAINER= gahr@FreeBSD.org
@@ -15,11 +16,13 @@ LICENSE= GPLv2
BUILD_DEPENDS= roundcube>=1.0:mail/roundcube
RUN_DEPENDS= roundcube>=1.0:mail/roundcube
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
NO_BUILD= yes
NO_ARCH= yes
+USE_GITHUB= yes
+GH_ACCOUNT= blind-coder
+GH_PROJECT= rcmcarddav
+
USES= php tar:bz2
USE_PHP= simplexml sockets curl
diff --git a/mail/roundcube-carddav/distinfo b/mail/roundcube-carddav/distinfo
index 31e6536888ee..e87022f4c1b4 100644
--- a/mail/roundcube-carddav/distinfo
+++ b/mail/roundcube-carddav/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1497267572
-SHA256 (carddav-2.0.4.tar.bz2) = d24da18a9c8f1058be3468e74daf8ead14a1ed755c4cdf42b40d4fbbeeadf0ba
-SIZE (carddav-2.0.4.tar.bz2) = 298144
+TIMESTAMP = 1509359873
+SHA256 (blind-coder-rcmcarddav-v2.0.4_GH0.tar.gz) = 87a6f564bdda268a8569f855697fb00940f67508c6827cf86139dcc89b607c4a
+SIZE (blind-coder-rcmcarddav-v2.0.4_GH0.tar.gz) = 50542
diff --git a/mail/roundcube-carddav/files/patch-rcube-input-post b/mail/roundcube-carddav/files/patch-rcube-input-post
new file mode 100644
index 000000000000..40d2de8fa640
--- /dev/null
+++ b/mail/roundcube-carddav/files/patch-rcube-input-post
@@ -0,0 +1,65 @@
+From c14c32af9fd1ff363e9be0c237ffa1a0ccc1514d Mon Sep 17 00:00:00 2001
+From: Benjamin 'blindCoder' Schieder <benjamin@anderdonau.de>
+Date: Thu, 27 Apr 2017 09:19:04 +0200
+Subject: [PATCH] use correct namespace for RCUBE_INPUT_POST, fixes #186
+
+---
+ carddav.php | 24 ++++++++++++------------
+ 1 file changed, 12 insertions(+), 12 deletions(-)
+
+diff --git a/carddav.php b/carddav.php
+index 998272e..7034ab5 100644
+--- carddav.php.orig
++++ carddav.php
+@@ -499,16 +499,16 @@ function cd_save($args)
+
+ } else {
+ $newset = array (
+- 'name' => rcube_utils::get_input_value($abookid."_cd_name", RCUBE_INPUT_POST),
+- 'username' => rcube_utils::get_input_value($abookid."_cd_username", RCUBE_INPUT_POST, true),
+- 'url' => rcube_utils::get_input_value($abookid."_cd_url", RCUBE_INPUT_POST),
++ 'name' => rcube_utils::get_input_value($abookid."_cd_name", rcube_utils::INPUT_POST),
++ 'username' => rcube_utils::get_input_value($abookid."_cd_username", rcube_utils::INPUT_POST, true),
++ 'url' => rcube_utils::get_input_value($abookid."_cd_url", rcube_utils::INPUT_POST),
+ 'active' => isset($_POST[$abookid.'_cd_active']) ? 1 : 0,
+ 'use_categories' => isset($_POST[$abookid.'_cd_use_categories']) ? 1 : 0,
+- 'refresh_time' => rcube_utils::get_input_value($abookid."_cd_refresh_time", RCUBE_INPUT_POST),
++ 'refresh_time' => rcube_utils::get_input_value($abookid."_cd_refresh_time", rcube_utils::INPUT_POST),
+ );
+
+ // only set the password if the user entered a new one
+- $password = rcube_utils::get_input_value($abookid."_cd_password", RCUBE_INPUT_POST, true);
++ $password = rcube_utils::get_input_value($abookid."_cd_password", rcube_utils::INPUT_POST, true);
+ if(strlen($password) > 0) {
+ $newset['password'] = $password;
+ }
+@@ -525,14 +525,14 @@ function cd_save($args)
+ }
+
+ // add a new address book?
+- $new = rcube_utils::get_input_value('new_cd_name', RCUBE_INPUT_POST);
++ $new = rcube_utils::get_input_value('new_cd_name', rcube_utils::INPUT_POST);
+ if ( (!array_key_exists('_GLOBAL', $prefs) || !$prefs['_GLOBAL']['fixed']) && strlen($new) > 0) {
+- $srv = rcube_utils::get_input_value('new_cd_url', RCUBE_INPUT_POST);
+- $usr = rcube_utils::get_input_value('new_cd_username', RCUBE_INPUT_POST, true);
+- $pass = rcube_utils::get_input_value('new_cd_password', RCUBE_INPUT_POST, true);
++ $srv = rcube_utils::get_input_value('new_cd_url', rcube_utils::INPUT_POST);
++ $usr = rcube_utils::get_input_value('new_cd_username', rcube_utils::INPUT_POST, true);
++ $pass = rcube_utils::get_input_value('new_cd_password', rcube_utils::INPUT_POST, true);
+ $pass = self::$helper->encrypt_password($pass);
+- $abname = rcube_utils::get_input_value('new_cd_name', RCUBE_INPUT_POST);
+- $use_categories = intval(rcube_utils::get_input_value('new_cd_use_categories', RCUBE_INPUT_POST, true), 0);
++ $abname = rcube_utils::get_input_value('new_cd_name', rcube_utils::INPUT_POST);
++ $use_categories = intval(rcube_utils::get_input_value('new_cd_use_categories', rcube_utils::INPUT_POST, true), 0);
+
+ $discovery = new carddav_discovery();
+ $srvs = $discovery->find_addressbooks($srv, $usr, $pass);
+@@ -550,7 +550,7 @@ function cd_save($args)
+ 'password' => $pass,
+ 'use_categories' => $use_categories,
+ 'url' => $srv['href'],
+- 'refresh_time' => rcube_utils::get_input_value('new_cd_refresh_time', RCUBE_INPUT_POST)
++ 'refresh_time' => rcube_utils::get_input_value('new_cd_refresh_time', rcube_utils::INPUT_POST)
+ ));
+ }
+ } else {