aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-06-03 11:26:09 +0800
committerwill <will@FreeBSD.org>2003-06-03 11:26:09 +0800
commitb2b2a3b3b11d9c0f98889194dbefca181ebc8af1 (patch)
tree755f7f85aecdca30d2d7488582fdc56b998f0e3a /mail
parentacba06cb2892a608cf7d14d1b7953f9362756be7 (diff)
downloadfreebsd-ports-gnome-b2b2a3b3b11d9c0f98889194dbefca181ebc8af1.tar.gz
freebsd-ports-gnome-b2b2a3b3b11d9c0f98889194dbefca181ebc8af1.tar.zst
freebsd-ports-gnome-b2b2a3b3b11d9c0f98889194dbefca181ebc8af1.zip
Add p5-Mail-RFC822-Address 0.3, a perl5 module to validate RFC822
conformance of email adresses. PR: 52403 Submitted by: Simon Barner <barner@in.tum.de>
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Mail-RFC822-Address/Makefile25
-rw-r--r--mail/p5-Mail-RFC822-Address/distinfo1
-rw-r--r--mail/p5-Mail-RFC822-Address/pkg-descr2
-rw-r--r--mail/p5-Mail-RFC822-Address/pkg-plist5
5 files changed, 34 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index cabd66d29f2d..44d25a565236 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -191,6 +191,7 @@
SUBDIR += p5-Mail-Procmailrc
SUBDIR += p5-Mail-QuoteWrap
SUBDIR += p5-Mail-RBL
+ SUBDIR += p5-Mail-RFC822-Address
SUBDIR += p5-Mail-Sender
SUBDIR += p5-Mail-Sendmail
SUBDIR += p5-Mail-SpamAssassin
diff --git a/mail/p5-Mail-RFC822-Address/Makefile b/mail/p5-Mail-RFC822-Address/Makefile
new file mode 100644
index 000000000000..3dd434f9433f
--- /dev/null
+++ b/mail/p5-Mail-RFC822-Address/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Mail-RFC822-Address
+# Date created: 18 May 2003
+# Whom: Simon Barner <barner@in.tum.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-RFC822-Address
+PORTVERSION= 0.3
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mharo@FreeBSD.org
+COMMENT= Perl5 module to validate RFC822 conformance of email adresses
+
+PERL_CONFIGURE= yes
+
+INSTALL_TARGET= pure_site_install
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Mail::RFC822::Address.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-RFC822-Address/distinfo b/mail/p5-Mail-RFC822-Address/distinfo
new file mode 100644
index 000000000000..528484cb99dc
--- /dev/null
+++ b/mail/p5-Mail-RFC822-Address/distinfo
@@ -0,0 +1 @@
+MD5 (Mail-RFC822-Address-0.3.tar.gz) = 0bd88b2ffedd95a4a920053fd6d0b709
diff --git a/mail/p5-Mail-RFC822-Address/pkg-descr b/mail/p5-Mail-RFC822-Address/pkg-descr
new file mode 100644
index 000000000000..6f763756a00d
--- /dev/null
+++ b/mail/p5-Mail-RFC822-Address/pkg-descr
@@ -0,0 +1,2 @@
+This perl module validates email addresses against the grammar described in
+RFC 822 using regular expressions.
diff --git a/mail/p5-Mail-RFC822-Address/pkg-plist b/mail/p5-Mail-RFC822-Address/pkg-plist
new file mode 100644
index 000000000000..2f3138b4efd6
--- /dev/null
+++ b/mail/p5-Mail-RFC822-Address/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Mail/RFC822/Address.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/RFC822/Address/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Mail/RFC822
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/RFC822/Address
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/RFC822