aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-26 17:10:36 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-26 17:10:36 +0800
commitbe8798af2e631cd55d7da7fa2ecdacae6634b301 (patch)
tree1993956ccf542e0d355b7d78c7d62db715ee945c /mail
parentfbf2a2c15e787507b521bb258763439cf6a8a681 (diff)
downloadfreebsd-ports-gnome-be8798af2e631cd55d7da7fa2ecdacae6634b301.tar.gz
freebsd-ports-gnome-be8798af2e631cd55d7da7fa2ecdacae6634b301.tar.zst
freebsd-ports-gnome-be8798af2e631cd55d7da7fa2ecdacae6634b301.zip
Support staging
Diffstat (limited to 'mail')
-rw-r--r--mail/epstools/Makefile29
1 files changed, 12 insertions, 17 deletions
diff --git a/mail/epstools/Makefile b/mail/epstools/Makefile
index e2ae0d555063..d6e1051731af 100644
--- a/mail/epstools/Makefile
+++ b/mail/epstools/Makefile
@@ -18,31 +18,26 @@ MAKE_ENV+= DEFS="-I${LOCALBASE}/include/eps ${CFLAGS}"
SUB_FILES= pkg-message
EXAMPLE_FILES= addr.1 addr.2 addr.3 addr.4 email.1 email.2 virus.email
-INSTALL_FILES= address b64decode b64encode body fold full headers qpdecode rewrite
+INSTALL_FILES= address b64decode b64encode body fold full headers qpdecode \
+ rewrite
+
+OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|^CC =|CC \?=|' \
- -e 's|^DEFS =|DEFS \?=|' \
- -e 's|^LIBS = -leps|LIBS = ${LOCALBASE}/lib/libeps.a|' \
- ${WRKSRC}/Makefile
+ -e 's|^DEFS =|DEFS \?=|' \
+ -e 's|^LIBS = -leps|LIBS = ${LOCALBASE}/lib/libeps.a|' \
+ ${WRKSRC}/Makefile
do-install:
.for f in ${INSTALL_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/bin/eps-${f}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin/eps-${f}
.endfor
-
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ${EXAMPLE_FILES}
- ${INSTALL_DATA} ${WRKSRC}/content/${f} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/content/${f} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>