aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2015-10-17 15:33:11 +0800
committerume <ume@FreeBSD.org>2015-10-17 15:33:11 +0800
commitdfb644d209c3ff7845d94909b7a736c318b73091 (patch)
tree411890d4a3ff177643fa1a65e0c9dc4aeae88b6a /mail
parente3306224a3f02fde49337f404eacbce6143219c8 (diff)
downloadfreebsd-ports-gnome-dfb644d209c3ff7845d94909b7a736c318b73091.tar.gz
freebsd-ports-gnome-dfb644d209c3ff7845d94909b7a736c318b73091.tar.zst
freebsd-ports-gnome-dfb644d209c3ff7845d94909b7a736c318b73091.zip
re-enable autosieve option.
PR: 162185 Submitted by: enzi.sergio
Diffstat (limited to 'mail')
-rw-r--r--mail/cyrus-imapd24/Makefile4
-rw-r--r--mail/cyrus-imapd24/files/extra-patch-imap__lmtp_sieve.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index 1c19fc4a96c8..22b908cc8b6a 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cyrus-imapd
PORTVERSION= 2.4.18
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-imapd/ \
http://cyrusimap.org/releases/
@@ -111,7 +111,7 @@ AUTOCREATE_PATCHFILES= ${PORTNAME}-2.4.4-autocreate-${AUTOCREATE_VERSION}.patch:
AUTOSIEVE_VERSION= 0.6.0
AUTOSIEVE_PATCH_SITES= LOCAL/mm:autosieve
AUTOSIEVE_PATCHFILES= ${PORTNAME}-2.4.12-autosieve-${AUTOSIEVE_VERSION}.patch:-p1:autosieve
-AUTOSIEVE_BROKEN= Not buildable with autosieve patch
+AUTOSIEVE_EXTRA_PATCHES=${FILESDIR}/extra-patch-imap__lmtp_sieve.c
DRAC_EXTRA_PATCHES= ${FILESDIR}/extra-patch-cmulocal::sasl2.m4
DRAC_USE= AUTOTOOLS=autoconf,autoheader
diff --git a/mail/cyrus-imapd24/files/extra-patch-imap__lmtp_sieve.c b/mail/cyrus-imapd24/files/extra-patch-imap__lmtp_sieve.c
new file mode 100644
index 000000000000..828283b0f0b0
--- /dev/null
+++ b/mail/cyrus-imapd24/files/extra-patch-imap__lmtp_sieve.c
@@ -0,0 +1,11 @@
+--- imap/lmtp_sieve.c.orig 2015-10-17 06:54:40 UTC
++++ imap/lmtp_sieve.c
+@@ -511,7 +511,7 @@ static int sieve_fileinto(void *ac,
+ /* Try to deliver the mail again. */
+ if (!ret)
+ ret = deliver_mailbox(md->f, mdata->content, mdata->stage, md->size,
+- fc->imapflags->flag, fc->imapflags->nflags,
++ fc->imapflags,
+ (char *) sd->username, sd->authstate, md->id,
+ sd->username, mdata->notifyheader,
+ namebuf, md->date, quotaoverride, 0);