aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormisha <misha@FreeBSD.org>2017-01-06 08:36:05 +0800
committermisha <misha@FreeBSD.org>2017-01-06 08:36:05 +0800
commitdfe47a7a2d88eec5b540f8e8dda868c1f1ed950a (patch)
tree83db2a4b094a426bb879a089db44987b381fe83f /mail
parent4305af68824e84b355e6290fe50c37af3c5c6b4e (diff)
downloadfreebsd-ports-gnome-dfe47a7a2d88eec5b540f8e8dda868c1f1ed950a.tar.gz
freebsd-ports-gnome-dfe47a7a2d88eec5b540f8e8dda868c1f1ed950a.tar.zst
freebsd-ports-gnome-dfe47a7a2d88eec5b540f8e8dda868c1f1ed950a.zip
- update from 2.6.20 to 2.6.22
- remove DOCS option - cryptography support - remove unneeded patches Approved by: jpaetzel (mentor), maintainer timeout (bofh@, 2 weeks)
Diffstat (limited to 'mail')
-rw-r--r--mail/gmime26/Makefile27
-rw-r--r--mail/gmime26/distinfo5
-rw-r--r--mail/gmime26/files/patch-gmime.pc.in6
-rw-r--r--mail/gmime26/files/patch-tests__test-mbox.c10
-rw-r--r--mail/gmime26/files/patch-tests__test-mime.c10
-rw-r--r--mail/gmime26/files/patch-tests__test-parser.c10
-rw-r--r--mail/gmime26/pkg-plist2
7 files changed, 16 insertions, 54 deletions
diff --git a/mail/gmime26/Makefile b/mail/gmime26/Makefile
index 40d2bb459a71..e98a69096e88 100644
--- a/mail/gmime26/Makefile
+++ b/mail/gmime26/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gmime
-PORTVERSION= 2.6.20
-PORTREVISION?= 1
+PORTVERSION= 2.6.22
CATEGORIES?= mail
MASTER_SITES= GNOME
PKGNAMESUFFIX?= 26
@@ -13,35 +12,27 @@ COMMENT?= Library (written in C) for parsing and creating messages using MIME
LICENSE= LGPL21
+LIB_DEPENDS= libgpgme.so:security/gpgme \
+ libassuan.so:security/libassuan \
+ libgpg-error.so:security/libgpg-error
+
SLAVEDIRS= mail/gmime26-sharp
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}26
-USES= gmake iconv libtool pathfix pkgconfig tar:xz
+USES= gettext-runtime gmake iconv libtool localbase pathfix pkgconfig tar:xz
USE_GNOME+= glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
# www.freebsd.org/cgi/query-pr.cgi?pr=118092
# Rename uudecode and uuencode to gmime-* to not conflict with userland
# fix kept in case issue returns
-CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc \
- --enable-mono=no \
+CONFIGURE_ARGS?=--enable-mono=no \
--program-transform-name="s/uuencode/gmime-uuencode/;s/uudecode/gmime-uudecode/;"
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-PORTDOCS= *
-
-OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/tests//' \
${WRKSRC}/Makefile.in
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for i in docs/reference/html/*
- ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
-.endfor
-
.include <bsd.port.mk>
diff --git a/mail/gmime26/distinfo b/mail/gmime26/distinfo
index 7f875c3e223f..cfffb04b0430 100644
--- a/mail/gmime26/distinfo
+++ b/mail/gmime26/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gmime-2.6.20.tar.xz) = e0a170fb264c2ae4cecd852f4e7aaddb8d58e8f3f0b569ce2d2a4704f55bdf65
-SIZE (gmime-2.6.20.tar.xz) = 740696
+TIMESTAMP = 1482272349
+SHA256 (gmime-2.6.22.tar.xz) = c25f9097d5842a4808f1d62faf5eace24af2c51d6113da58d559a3bfe1d5553a
+SIZE (gmime-2.6.22.tar.xz) = 5216068
diff --git a/mail/gmime26/files/patch-gmime.pc.in b/mail/gmime26/files/patch-gmime.pc.in
index bd70c1315105..8e8d0047bfe2 100644
--- a/mail/gmime26/files/patch-gmime.pc.in
+++ b/mail/gmime26/files/patch-gmime.pc.in
@@ -1,6 +1,6 @@
---- gmime.pc.in.orig 2013-05-22 08:39:38.000000000 +0000
-+++ gmime.pc.in 2013-05-22 08:39:54.000000000 +0000
-@@ -7,7 +7,7 @@
+--- gmime.pc.in.orig 2016-12-09 15:08:58 UTC
++++ gmime.pc.in
+@@ -7,7 +7,7 @@ includedir=@includedir@
Name: GMime
Version: @VERSION@
Description: MIME parser and utility library
diff --git a/mail/gmime26/files/patch-tests__test-mbox.c b/mail/gmime26/files/patch-tests__test-mbox.c
deleted file mode 100644
index bba86048372d..000000000000
--- a/mail/gmime26/files/patch-tests__test-mbox.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- tests/test-mbox.c.orig Mon Feb 12 15:48:22 2007
-+++ tests/test-mbox.c Mon Feb 12 15:48:54 2007
-@@ -26,6 +26,7 @@
- #include <fcntl.h>
- #include <time.h>
-
-+#include <config.h>
- #include <gmime/gmime.h>
-
- #ifndef G_OS_WIN32
diff --git a/mail/gmime26/files/patch-tests__test-mime.c b/mail/gmime26/files/patch-tests__test-mime.c
deleted file mode 100644
index 35067da0afa6..000000000000
--- a/mail/gmime26/files/patch-tests__test-mime.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- tests/test-mime.c.orig Mon Feb 12 15:48:32 2007
-+++ tests/test-mime.c Mon Feb 12 15:49:04 2007
-@@ -21,6 +21,7 @@
- #include <stdio.h>
- #include <string.h>
-
-+#include <config.h>
- #include <gmime/gmime.h>
-
- #ifndef G_OS_WIN32
diff --git a/mail/gmime26/files/patch-tests__test-parser.c b/mail/gmime26/files/patch-tests__test-parser.c
deleted file mode 100644
index a408ff684cfe..000000000000
--- a/mail/gmime26/files/patch-tests__test-parser.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- tests/test-parser.c.orig Mon Feb 12 15:48:38 2007
-+++ tests/test-parser.c Mon Feb 12 15:49:14 2007
-@@ -26,6 +26,7 @@
- #include <fcntl.h>
- #include <time.h>
-
-+#include <config.h>
- #include <gmime/gmime.h>
-
- #ifndef G_OS_WIN32
diff --git a/mail/gmime26/pkg-plist b/mail/gmime26/pkg-plist
index 6f2153290f08..59a83360422d 100644
--- a/mail/gmime26/pkg-plist
+++ b/mail/gmime26/pkg-plist
@@ -54,5 +54,5 @@ include/gmime-2.6/gmime/internet-address.h
lib/libgmime-2.6.a
lib/libgmime-2.6.so
lib/libgmime-2.6.so.0
-lib/libgmime-2.6.so.0.620.0
+lib/libgmime-2.6.so.0.622.0
libdata/pkgconfig/gmime-2.6.pc