aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-06-26 11:24:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-06-26 11:24:38 +0800
commitec231f6c40084f768fbf1447e6e6a938d34d3494 (patch)
treefa021cb6d32e240de5fbf0ca0f0a72b94e9140d0 /mail
parent07d8d7f22c18bd643dac30101e1fd081182738cb (diff)
downloadfreebsd-ports-gnome-ec231f6c40084f768fbf1447e6e6a938d34d3494.tar.gz
freebsd-ports-gnome-ec231f6c40084f768fbf1447e6e6a938d34d3494.tar.zst
freebsd-ports-gnome-ec231f6c40084f768fbf1447e6e6a938d34d3494.zip
Remove Perl core modules
- Add LICENSE_FILE - Add NO_ARCH - Convert to options target helper - Remove blank line in PLIST - Bump PORTREVISION for dependency change
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix-postfwd/Makefile20
-rw-r--r--mail/postfix-postfwd/pkg-plist1
2 files changed, 10 insertions, 11 deletions
diff --git a/mail/postfix-postfwd/Makefile b/mail/postfix-postfwd/Makefile
index 06df96251f16..0ca091975d1c 100644
--- a/mail/postfix-postfwd/Makefile
+++ b/mail/postfix-postfwd/Makefile
@@ -12,12 +12,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Postfix firewall policy daemon
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/doc/LICENSE
RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS \
- p5-Net-Server>=0:net/p5-Net-Server \
- p5-Storable>=0:devel/p5-Storable \
- p5-Time-HiRes>=0:devel/p5-Time-HiRes
+ p5-Net-Server>=0:net/p5-Net-Server
+NO_ARCH= yes
SUB_FILES= pkg-message
USE_RC_SUBR= ${PORTNAME}
@@ -29,23 +29,23 @@ NO_BUILD= yes
OPTIONS_DEFINE= EXAMPLES DOCS POSTFWD2
POSTFWD2_DESC= Install postfwd v2 rather than v1
-.include <bsd.port.options.mk>
-
do-install:
-.if ${PORT_OPTIONS:MPOSTFWD2}
- @${INSTALL_SCRIPT} ${WRKSRC}/sbin/${PORTNAME}2 ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.else
- @${INSTALL_SCRIPT} ${WRKSRC}/sbin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-.endif
@${INSTALL_DATA} ${WRKSRC}/etc/${PORTNAME}.cf.sample ${STAGEDIR}${ETCDIR}
@${INSTALL_MAN} ${WRKSRC}/man/man8/* ${STAGEDIR}${MANPREFIX}/man/man8
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/tools/request.sample ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/plugins/postfwd.plugins.sample ${STAGEDIR}${EXAMPLESDIR}
+do-install-POSTFWD2-on:
+ @${INSTALL_SCRIPT} ${WRKSRC}/sbin/${PORTNAME}2 ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+do-install-POSTFWD2-off:
+ @${INSTALL_SCRIPT} ${WRKSRC}/sbin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
.include <bsd.port.mk>
diff --git a/mail/postfix-postfwd/pkg-plist b/mail/postfix-postfwd/pkg-plist
index 1fc56a64777e..00e93948868b 100644
--- a/mail/postfix-postfwd/pkg-plist
+++ b/mail/postfix-postfwd/pkg-plist
@@ -19,4 +19,3 @@ man/man8/postfwd2.8.gz
%%PORTDOCS%%%%DOCSDIR%%/versions.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/postfwd.plugins.sample
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/request.sample
-