aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-06-01 08:52:49 +0800
committermarcus <marcus@FreeBSD.org>2003-06-01 08:52:49 +0800
commitf27065f9c894a1bd1dc8348634bd939ad19981b1 (patch)
tree36e328c501689eeff430b0bd92f4a110a72f0f23 /mail
parentd1d7426e718edc8ef2f16e2b153638bb71fc0d4e (diff)
downloadfreebsd-ports-gnome-f27065f9c894a1bd1dc8348634bd939ad19981b1.tar.gz
freebsd-ports-gnome-f27065f9c894a1bd1dc8348634bd939ad19981b1.tar.zst
freebsd-ports-gnome-f27065f9c894a1bd1dc8348634bd939ad19981b1.zip
Fix the dreaded thread problem on -CURRENT.
Diffstat (limited to 'mail')
-rw-r--r--mail/balsa2/Makefile4
-rw-r--r--mail/balsa2/files/patch-ltmain.sh51
2 files changed, 53 insertions, 2 deletions
diff --git a/mail/balsa2/Makefile b/mail/balsa2/Makefile
index 1fd8694e6574..c2c23a4dd485 100644
--- a/mail/balsa2/Makefile
+++ b/mail/balsa2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= balsa2
PORTVERSION= 2.0.11
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/ \
ftp://ftp.newton.cx/pub/balsa/
@@ -25,12 +26,11 @@ RUN_DEPENDS= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_LIBTOOL= yes
USE_PERL5= yes
USE_REINPLACE= yes
USE_OPENSSL= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml
-LIBTOOLFILES= libmutt/configure
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-threads \
--enable-gtkhtml \
--enable-ldap \
diff --git a/mail/balsa2/files/patch-ltmain.sh b/mail/balsa2/files/patch-ltmain.sh
new file mode 100644
index 000000000000..8afc42e3986c
--- /dev/null
+++ b/mail/balsa2/files/patch-ltmain.sh
@@ -0,0 +1,51 @@
+--- ltmain.sh.orig Fri Apr 25 15:18:44 2003
++++ ltmain.sh Sun May 11 02:27:13 2003
+@@ -1061,7 +1061,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1071,8 +1071,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2471,6 +2479,9 @@
+ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4280,10 +4291,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"