aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-09 21:16:49 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-09 21:16:49 +0800
commitf3daf2261fb178366adda1ccfd67d90513f16f2a (patch)
tree263754af5ddd95f1ad55b06c101378a0cf71009b /mail
parentcc1bd708b05005e884e1cb06113168318d3dbe5a (diff)
downloadfreebsd-ports-gnome-f3daf2261fb178366adda1ccfd67d90513f16f2a.tar.gz
freebsd-ports-gnome-f3daf2261fb178366adda1ccfd67d90513f16f2a.tar.zst
freebsd-ports-gnome-f3daf2261fb178366adda1ccfd67d90513f16f2a.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Diffstat (limited to 'mail')
-rw-r--r--mail/alpine/Makefile4
-rw-r--r--mail/dma/Makefile3
-rw-r--r--mail/dovecot2/Makefile11
-rw-r--r--mail/exim/Makefile6
4 files changed, 1 insertions, 23 deletions
diff --git a/mail/alpine/Makefile b/mail/alpine/Makefile
index 0a4069a03600..63d32c038ce4 100644
--- a/mail/alpine/Makefile
+++ b/mail/alpine/Makefile
@@ -61,10 +61,6 @@ MAKE_ARGS+= CC="${CC}" CXX="${CXX}" GCCCFLAGS="${CFLAGS}"
.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
-.if ${OSVERSION} < 1000000
-# OpenSSL is pre v1.0 in FBSD9.x so the ports version needs to be used
-WITH_OPENSSL_PORT= yes
-.endif
CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLDIR} \
--with-ssl-include-dir=${OPENSSLINC} \
diff --git a/mail/dma/Makefile b/mail/dma/Makefile
index e3c0aae6f124..6a893eb0119d 100644
--- a/mail/dma/Makefile
+++ b/mail/dma/Makefile
@@ -53,9 +53,6 @@ post-patch:
${WRKSRC}/dma.conf
@${REINPLACE_CMD} -e '/^MK_MAN/d' -e 's/^NOMAN/NO_MAN/' \
${WRKSRC}/bsd/dma-mbox-create/Makefile
-.if ${OSVERSION} < 1000013
- @${REINPLACE_CMD} -e 's,^YFLAGS.*,,' ${WRKSRC}/bsd/dma/Makefile
-.endif
post-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index c8de14bdca52..43d99b6d3a77 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -132,18 +132,9 @@ LDAP_VARS= _REQUIRE+=slapd
MYSQL_VARS= _REQUIRE+=mysql
PGSQL_VARS= _REQUIRE+=postgresql
-.include <bsd.port.options.mk>
-
SUB_LIST+= REQUIRE="${_REQUIRE}"
SUB_FILES+= pkg-message
-.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 1000011
-USES+= compiler:c11
-WITH_OPENSSL_PORT= yes
-.endif
-
-.include <bsd.port.pre.mk>
-
CPPFLAGS+= -I${LOCALBASE}/include -I${OPENSSLINC}
LDFLAGS+= -L${LOCALBASE}/lib -L${OPENSSLLIB}
@@ -169,4 +160,4 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 346bcd096e4e..a55ba33322ed 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -83,12 +83,6 @@ IGNORE= you cannot enable DMARC without SPF and DKIM support
.if ! ${PORT_OPTIONS:MDNSSEC} || ! ${PORT_OPTIONS:MTLS}
IGNORE= you cannot enable DANE without DNSSEC support or without TLS support
.endif
-# Use Openssl from the ports
-.if ${OSVERSION} < 1000000
-. if ! ${PORT_OPTIONS:MGNUTLS}
-WITH_OPENSSL_PORT= yes
-. endif
-.endif
.endif
.if ${PORT_OPTIONS:MSA_EXIM} || defined(FETCH_ALL)