aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-08-11 03:40:01 +0800
committeralane <alane@FreeBSD.org>2002-08-11 03:40:01 +0800
commit03f68a7c8e04fec117cc972b5fd135852ae4a92d (patch)
tree2b967ee8e81533d5f3009b7b0bacb10b18b6676b /mail
parent7f67c8392b67f55e9f51abbce7df6ab09c053c8b (diff)
downloadfreebsd-ports-gnome-03f68a7c8e04fec117cc972b5fd135852ae4a92d.tar.gz
freebsd-ports-gnome-03f68a7c8e04fec117cc972b5fd135852ae4a92d.tar.zst
freebsd-ports-gnome-03f68a7c8e04fec117cc972b5fd135852ae4a92d.zip
The port of PodParser doesn't work with 5.8. The internal 5.8 code is newer.
So, don't use it or install it (it will break installing all subsequent ports) if we're using perl 5.8. This is not the best test, but it'll do until I (or someone) figures out a way to do a < comparison instead of a != comparison.
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index eafcdd186ea6..3daaf2a5e8cc 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -19,9 +19,12 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDI
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
RUN_DEPENDS= ${BUILD_DEPENDS} \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Razor/Client.pm:${PORTSDIR}/mail/razor-agents
+.if ${PERL_VERSION} != "5.8.0"
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
+.endif
+
PERL_CONFIGURE= yes
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Mail::SpamAssassin.3 Mail::SpamAssassin::PerMsgStatus.3 \