aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2001-05-27 20:56:05 +0800
committerjeh <jeh@FreeBSD.org>2001-05-27 20:56:05 +0800
commit07a81fade4482a5cd8fa46d65e0aa85b3dd3da77 (patch)
treeaa535eece7359509434e6476f802df263b9eb0d9 /mail
parentfc0350164ef34810d32c3f444944b15ac17f3471 (diff)
downloadfreebsd-ports-gnome-07a81fade4482a5cd8fa46d65e0aa85b3dd3da77.tar.gz
freebsd-ports-gnome-07a81fade4482a5cd8fa46d65e0aa85b3dd3da77.tar.zst
freebsd-ports-gnome-07a81fade4482a5cd8fa46d65e0aa85b3dd3da77.zip
new release of elm 2.4 ME+ pl 92.
PR: 27310 Submitted by: Cyrille Lefevre <clefevre@poboxes.com> MAINTAINER
Diffstat (limited to 'mail')
-rw-r--r--mail/elm+ME/Makefile120
-rw-r--r--mail/elm+ME/distinfo2
-rw-r--r--mail/elm+ME/files/00elm.sh18
-rw-r--r--mail/elm+ME/files/elm.mimetypes4
-rw-r--r--mail/elm+ME/files/patch-ac23
-rw-r--r--mail/elm+ME/files/patch-newmbox.c36
-rw-r--r--mail/elm+ME/pkg-plist43
-rw-r--r--mail/elm+ME/scripts/pre-configure37
8 files changed, 225 insertions, 58 deletions
diff --git a/mail/elm+ME/Makefile b/mail/elm+ME/Makefile
index a837da3990a3..393a2eb55d53 100644
--- a/mail/elm+ME/Makefile
+++ b/mail/elm+ME/Makefile
@@ -1,14 +1,12 @@
-# New ports collection makefile for: elm ME+ (unofficial Elm)
-# Date created: 26 June 1995
-# Whom: ache
+# New ports collection makefile for: elm ME+ (unofficial Elm)
+# Date created: 26 June 1995
+# Whom: ache
#
# $FreeBSD$
#
PORTNAME= elm+ME
-PORTVERSION= 2.4.88
-PORTREVISION= 1
-PORTEPOCH= 1
+PORTVERSION= 2.4.92
CATEGORIES= mail
DISTNAME= ${PORTNAME:S/+ME//}-${PORTVERSION:R}ME+${PORTVERSION:E}
@@ -17,7 +15,8 @@ MASTER_SITES= ftp://ftp.ozone.fmi.fi/KEH/ \
http://www.ozone.fmi.fi/KEH/
# the following repositories conform to the main repository.
-MASTER_SITES+= ftp://ftp.tu-darmstadt.de/pub/networking/mail/elm+ME/ \
+MASTER_SITES+= ftp://ftp.lip6.fr/pub/unix/mail/elm-me/ \
+ ftp://ftp.tu-darmstadt.de/pub/networking/mail/elm+ME/ \
ftp://ftp.cs.tu-berlin.de/pub/net/mail/elm-me-plus/ \
ftp://ftp.ntua.gr/pub/net/mail/elm-me/ \
ftp://ftp.eos.hokudai.ac.jp/pub/network/mail/elm-2.4ME+/ \
@@ -28,10 +27,6 @@ MASTER_SITES+= ftp://ftp.unina.it/pub/Unix/pkgs/network/mail/elm-me+/ \
ftp://ftp.rge.com/pub/mail/elm/elm-2.4ME+/ \
ftp://ftp.uni-trier.de/pub/unix/network/mail/elm-me+/
-# fetch doesn't work w/ ftp.lip6.fr and ftp doesn't work w/ the http protocol.
-# MASTER_SITES+= ftp://ftp.lip6.fr/pub/unix/mail/elm-me/
-# FETCH_CMD= /usr/bin/ftp
-
MAINTAINER= clefevre@poboxes.com
# not needed since config.sh is generated by scripts/pre-configure.
@@ -40,75 +35,111 @@ MAINTAINER= clefevre@poboxes.com
# BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
# BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
-WRKSRC= ${WRKDIR}/${DISTNAME:S/-//:S/ME+/.ME+./}
-
#
# Global variables
#
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-//:S/ME+/.ME+./}
+
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
-SCRIPTS_ENV= CFLAGS="${CFLAGS}" PREFIX="${PREFIX}"
-CONFIGURE_ARGS= -S -d -P${PREFIX}
+SCRIPTS_ENV= CFLAGS="${CFLAGS}" ${PLIST_SUB} \
+ PREFIX="${PREFIX}" MAN1PREFIX="${MAN1PREFIX}"
+CONFIGURE_ARGS= -S -P ${PREFIX}
+
+MAKE_ARGS= MJ="FORMATTER=groff FORMATTER_OPTS=-Tlatin1"
+ALL_TARGET= all documentation
+
+PLIST_SUB= SO_REV="${SO_REV}" DOC_SUBDIR="${DOC_SUBDIR}" \
+ LIB_SUBDIR="${LIB_SUBDIR}" SHLIB_SUBDIR="${SHLIB_SUBDIR}"
MAN1= answer.1 checkalias.1 elm.1 elmalias.1 elmcharset.1 \
- elmterminal.1 fastmail.1 frm.1 listalias.1 messages.1 \
- newalias.1 newmail.1 printmail.1 readmsg.1
+ elmterminal.1 elmunidata.1 fastmail.1 frm.1 listalias.1 \
+ messages.1 newalias.1 newmail.1 printmail.1 readmsg.1
MLINKS= frm.1 nfrm.1 newmail.1 wnewmail.1
#
# Local variables
#
-DESTLIBDIR= ${PREFIX}/lib/${PORTNAME:S/+ME//}
-MIMETYPES= elm.mimetypes
+SO_REV= `${AWK} '/SHAREDTAG:/{print $$2}' ${WRKSRC}/hdrs/patchlevel.h`
+MSECS= 1
+
+RCD_SUBDIR= etc/rc.d
+LIB_SUBDIR= lib/elm
+SHLIB_SUBDIR= libexec/elm
+DOC_SUBDIR= share/doc/elm
+
+RCD_FILE= 00elm.sh
+MIME_TYPES= elm.mimetypes
+DOC_FILES= README.ME+ shared_libs/tls/README.TLS \
+ doc/Alias.fmtd doc/Config.fmtd doc/Cover.fmtd \
+ doc/Form.fmtd doc/Ref.fmtd doc/Users.fmtd
+
+AWK?= awk
#
# Post-patch
#
+post-patch: patch-install-script patch-setgid patch-nls-files
+
+patch-install-script:
+ @${SED} -e 's,%%SHLIB_SUBDIR%%,${SHLIB_SUBDIR},' \
+ ${FILESDIR}/${RCD_FILE} > ${WRKSRC}/${RCD_FILE}
+
# d_savegrpmboxid is currently broken using setgid(2) instead of setegid(2).
-# will probably be fixed in the next release, for instance, fake a patch.
+# will probably be fixed in a next release, for instance, fake a patch.
# the alternative would be to disable this option in pre-configure script.
-post-patch:
+patch-setgid:
@${PERL} -pi.fbsd -e 's,setgid,setegid,' \
${WRKSRC}/lib/localmbx.c \
${WRKSRC}/src/init.c ${WRKSRC}/src/lock.c
-#
-# Post-configure
-#
-
-post-configure:
+patch-nls-files:
@${PERL} -pi.fbsd -e 's,/usr/local,${PREFIX},' ${WRKSRC}/nls/LANGS
#
# Post-install
#
-post-install: install-nls install-mime-types \
+post-install: install-startup-files install-nls-files \
+ install-doc-files install-mime-types \
remove-catman-files remove-catman-links
-install-nls:
+install-startup-files:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${RCD_FILE} ${PREFIX}/${RCD_SUBDIR}
+
+install-nls-files:
@cd ${WRKSRC}/nls; ${MAKE} install
+install-doc-files:
+.if !defined(NOPORTSDOC)
+ @${MKDIR} ${PREFIX}/${DOC_SUBDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/${DOC_SUBDIR}
+ @${GZIP_CMD} ${PREFIX}/${DOC_SUBDIR}/${file:T}
+.endfor
+.endif
+
install-mime-types:
- @${INSTALL_DATA} \
- ${FILESDIR}/${MIMETYPES} ${DESTLIBDIR}/${MIMETYPES}-dist
- @if [ ! -f ${DESTLIBDIR}/${MIMETYPES} ]; then \
- ${INSTALL_DATA} ${FILESDIR}/${MIMETYPES} ${DESTLIBDIR}; \
+ @${INSTALL_DATA} ${FILESDIR}/${MIME_TYPES} \
+ ${PREFIX}/${LIB_SUBDIR}/${MIME_TYPES}-dist
+ @if [ ! -f ${PREFIX}/${LIB_SUBDIR}/${MIME_TYPES} ]; then \
+ ${INSTALL_DATA} ${FILESDIR}/${MIME_TYPES} \
+ ${PREFIX}/${LIB_SUBDIR}; \
fi
remove-catman-files:
-.for sect in 1
+.for sect in ${MSECS}
.for page in ${MAN${sect}}
@${RM} -f ${MAN${sect}PREFIX}/man/cat${sect}/${page}
.endfor
.endfor
remove-catman-links:
-.for sect in 1
+.for sect in ${MSECS}
.for page in ${MLINKS}
.if ${MAN${sect}:M${page}} == ""
@${RM} -f ${MAN${sect}PREFIX}/man/cat${sect}/${page}
@@ -116,4 +147,23 @@ remove-catman-links:
.endfor
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# some sketchy hackery
+FETCH_CMD_INTERIOR= ${FETCH_CMD:M*fetch*}
+
+# only enable the hack if FETCH_CMD is fetch
+.if !empty(FETCH_CMD_INTERIOR)
+
+# lip6 dislike $USER@localhost...
+FETCH_ENV= FTP_PASSWORD=${FTP_PASSWORD}
+
+AWK?= awk
+IFCONFIG?= ifconfig
+
+# well, this is a hack to make fetch happy on lip6, ugh!
+HOSTIPADDR= ${IFCONFIG} | ${AWK} '/inet /{print $$2; exit}'
+FTP_PASSWORD?= ${USER}@`${HOSTIPADDR}`
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/elm+ME/distinfo b/mail/elm+ME/distinfo
index b1973a99afd6..1ca7471bcfc0 100644
--- a/mail/elm+ME/distinfo
+++ b/mail/elm+ME/distinfo
@@ -1 +1 @@
-MD5 (elm-2.4ME+88.tar.gz) = 96704eae50aace159a752caafb9bcd44
+MD5 (elm-2.4ME+92.tar.gz) = fd3ebe8318a6f33cc3f42aeda39808d7
diff --git a/mail/elm+ME/files/00elm.sh b/mail/elm+ME/files/00elm.sh
new file mode 100644
index 000000000000..337653829286
--- /dev/null
+++ b/mail/elm+ME/files/00elm.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ /sbin/ldconfig -m ${PREFIX}/%%SHLIB_SUBDIR%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" 2>&1
+ exit 64
+ ;;
+esac
diff --git a/mail/elm+ME/files/elm.mimetypes b/mail/elm+ME/files/elm.mimetypes
index 2cace40e1cc0..93491edd31cb 100644
--- a/mail/elm+ME/files/elm.mimetypes
+++ b/mail/elm+ME/files/elm.mimetypes
@@ -1,5 +1,9 @@
+# $FreeBSD$
+#
# mime.types for Elm 2.4PL24 ME8 (or greater)
#
+# Written by Cyrille Lefevre <clefevre@poboxes.com>
+#
# Format of this file:
# <suffix> <content-type>
#
diff --git a/mail/elm+ME/files/patch-ac b/mail/elm+ME/files/patch-ac
index 76684c18becd..5b376468189b 100644
--- a/mail/elm+ME/files/patch-ac
+++ b/mail/elm+ME/files/patch-ac
@@ -1,5 +1,5 @@
---- Configure.orig Fri Dec 29 20:57:04 2000
-+++ Configure Sat Jan 6 23:19:54 2001
+--- Configure.orig Fri May 11 19:35:20 2001
++++ Configure Sun May 13 01:26:06 2001
@@ -16,10 +16,10 @@
PATH=".:$PATH:/bin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/ucb:/usr/local:/usr/lbin:/etc:/usr/new:/usr/new/bin:/usr/nbin"
export PATH || (echo "OOPS, this isn't sh. Desperation time. I will feed myself to sh."; sh $0; kill $$)
@@ -15,7 +15,16 @@
(alias) >/dev/null 2>&1 && \
echo "(I see you are using the Korn shell. Some ksh's blow up on Configure," && \
-@@ -1926,7 +1926,10 @@
+@@ -1971,7 +1971,7 @@
+ echo "Found shlib directory"
+ fi
+
+- $echo "Trying create chared library"
++ $echo "Trying create shared library"
+
+ LibLoc=`cd ..; pwd`/shlib
+
+@@ -2263,7 +2263,10 @@
: see if crypt exists
echo " "
@@ -27,3 +36,11 @@
echo 'crypt() found.'
d_crypt="$define"
cryptlib=''
+@@ -2767,6 +2770,7 @@
+
+ $echo $n "Testing if inet_aton can be used ... $c"
+ $cat > try.c <<'EOF'
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/mail/elm+ME/files/patch-newmbox.c b/mail/elm+ME/files/patch-newmbox.c
new file mode 100644
index 000000000000..37a67784d66c
--- /dev/null
+++ b/mail/elm+ME/files/patch-newmbox.c
@@ -0,0 +1,36 @@
+--- src/newmbox.c.orig Tue Feb 6 19:48:32 2001
++++ src/newmbox.c Sat May 12 21:28:05 2001
+@@ -568,6 +568,33 @@
+ }
+ }
+
++ else if (NULL != (tmphdr = locate_header_by_name(parsed_headers,
++ "Newsgroups"))) {
++ struct addr_item * addrs =
++ break_down_address(tmphdr->body,
++ !(current_header -> status &
++ NOHDRENCODING) &&
++ is_rfc1522(tmphdr->body),
++ current_header->header_charset);
++
++ if (addrs) {
++ if (current_header->to)
++ free_addr_items(current_header->to);
++ current_header->to = addrs;
++ if (debug > 15 && debugfile) {
++ struct addr_item * p;
++ for (p = current_header->to; p->addr; p++) {
++ elm_fprintf(debugfile,
++ FRM("-- to[%d] addr='%s' comment='%S' fullname='%S'\n"),
++ p - current_header->to,
++ p->addr,
++ p->comment,
++ p->fullname);
++ }
++ }
++ }
++ }
++
+ if (NULL != (tmphdr = locate_header_by_name(parsed_headers,
+ "Cc"))) {
+ struct addr_item * addrs =
diff --git a/mail/elm+ME/pkg-plist b/mail/elm+ME/pkg-plist
index ab4af39a22c0..98fd03a9dc27 100644
--- a/mail/elm+ME/pkg-plist
+++ b/mail/elm+ME/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
bin/answer
bin/checkalias
bin/elm
@@ -14,17 +15,33 @@ bin/newmail
@unexec rm -f %B/wnewmail
bin/printmail
bin/readmsg
-share/nls/C/elm2.4me+.cat
-lib/elm/elm-help.0
-lib/elm/elm-help.1
-lib/elm/elm-help.2
-lib/elm/elm-help.3
-lib/elm/elm.mimecharsets
-@unexec if cmp -s %D/lib/elm/elm.mimetypes %D/lib/elm/elm.mimetypes-dist; then rm -f %D/lib/elm/elm.mimetypes; fi
-lib/elm/elm.mimetypes-dist
+etc/rc.d/00elm.sh
+%%LIB_SUBDIR%%/elm-help.0
+%%LIB_SUBDIR%%/elm-help.1
+%%LIB_SUBDIR%%/elm-help.2
+%%LIB_SUBDIR%%/elm-help.3
+%%LIB_SUBDIR%%/elm.map.bin/unidata.bin
+%%LIB_SUBDIR%%/elm.mimecharsets
+@unexec if cmp -s %D/%%LIB_SUBDIR%%/elm.mimetypes %D/%%LIB_SUBDIR%%/elm.mimetypes-dist; then rm -f %D/%%LIB_SUBDIR%%/elm.mimetypes; fi
+%%LIB_SUBDIR%%/elm.mimetypes-dist
@exec [ ! -f %B/elm.mimetypes ] && cp %B/%f %B/elm.mimetypes
-lib/elm/elmcharset
-lib/elm/elmrc-info
-lib/elm/elmterminal
-lib/elm/prlong
-@dirrm lib/elm
+%%LIB_SUBDIR%%/elmcharset
+%%LIB_SUBDIR%%/elmrc-info
+%%LIB_SUBDIR%%/elmterminal
+%%LIB_SUBDIR%%/elmunidata
+%%LIB_SUBDIR%%/prlong
+%%SHLIB_SUBDIR%%/libelmme-base.so%%SO_REV%%
+%%SHLIB_SUBDIR%%/libelmme-tls.so%%SO_REV%%
+%%PORTDOCS%%%%DOC_SUBDIR%%/README.ME+.gz
+%%PORTDOCS%%%%DOC_SUBDIR%%/README.TLS.gz
+%%PORTDOCS%%%%DOC_SUBDIR%%/Alias.fmtd.gz
+%%PORTDOCS%%%%DOC_SUBDIR%%/Config.fmtd.gz
+%%PORTDOCS%%%%DOC_SUBDIR%%/Cover.fmtd.gz
+%%PORTDOCS%%%%DOC_SUBDIR%%/Form.fmtd.gz
+%%PORTDOCS%%%%DOC_SUBDIR%%/Ref.fmtd.gz
+%%PORTDOCS%%%%DOC_SUBDIR%%/Users.fmtd.gz
+share/nls/C/elm2.4me+.cat
+@dirrm %%LIB_SUBDIR%%/elm.map.bin
+@dirrm %%LIB_SUBDIR%%
+@dirrm %%SHLIB_SUBDIR%%
+%%PORTDOCS%%@dirrm %%DOC_SUBDIR%%
diff --git a/mail/elm+ME/scripts/pre-configure b/mail/elm+ME/scripts/pre-configure
index e75d5d1781c8..e7a7e28b7d24 100644
--- a/mail/elm+ME/scripts/pre-configure
+++ b/mail/elm+ME/scripts/pre-configure
@@ -6,7 +6,9 @@
[ -r /usr/include/inttypes.h ] && has_inttypes=define || has_inttypes=undef
- cat > ${WRKSRC}/config.sh << EOF
+[ -d ${WRKSRC}/shlib ] || mkdir ${WRKSRC}/shlib
+
+cat > ${WRKSRC}/config.sh << EOF
#!/bin/sh
# config.sh
# This file was produced by running the Configure script.
@@ -30,6 +32,7 @@ d_socket='define'
d_connect_reopen='undef'
d_netdb='define'
d_netinet_in='define'
+d_use_aton='define'
d_inttypes='$has_inttypes'
d_nointtypes='undef'
n='-n'
@@ -162,7 +165,7 @@ compress='/usr/bin/compress'
execmail=''
libswanted='sun nls c_s'
noaddlib='yes'
-c_date='Wed Feb 7 02:17:00 CET 2001'
+c_date='Sun May 13 02:00:14 CEST 2001'
d_ascii='undef'
d_broke_ctype='undef'
d_calendar='define'
@@ -215,7 +218,6 @@ d_ptem='undef'
d_putenv='define'
maxattempts='6'
d_setgid='define'
-d_savegrpmboxid='define'
mailermode='2755'
d_sigvec='undef'
d_sigvectr='undef'
@@ -238,6 +240,16 @@ d_strstr='define'
d_strtok='define'
d_subshell='define'
d_tempnam='define'
+d_setlinebuf='define'
+d_shared='define'
+d_shared_rev='${SO_REV}'
+d_dlopen_libs='define'
+shared_list='tls'
+d_dynamic_main='define'
+dynamic_opt='-rdynamic'
+dlopen_lib=''
+rpath_opt='-rpath '
+soname_opt='-shared -soname '
tempnamo=''
tempnamc=''
d_termio='undef'
@@ -260,14 +272,16 @@ d_systimekernel='undef'
i_unistd='define'
i_utime='define'
i_sysutime='undef'
-lib='${PREFIX}/lib/elm'
+lib='${PREFIX}/${LIB_SUBDIR}'
+shlib='${PREFIX}/${SHLIB_SUBDIR}'
+libdirname='lib'
libc='/usr/lib/libc.so'
linepr='/usr/bin/lp'
maildir='/var/mail'
mailer='/usr/sbin/sendmail'
mailgrp='mail'
-mansrc='${PREFIX}/man/man1'
-catmansrc='${PREFIX}/man/cat1'
+mansrc='${MAN1PREFIX}/man/man1'
+catmansrc='${MAN1PREFIX}/man/cat1'
manext='.1'
manext_choice='.1'
catmanext='.1'
@@ -312,6 +326,17 @@ special_path='/usr/bin'
special_path2='${PREFIX}/bin'
locale_dir='/usr/share/locale'
CONFIG=true
+tls_ok='define'
+EOF
+
+mv ${WRKSRC}/shared_libs/tls/README.ME+ ${WRKSRC}/shared_libs/tls/README.TLS
+
+cat > ${WRKSRC}/shared_libs/tls/config.res << EOF
+# Support for TLS
+tls_ok='define'
+tls_dir='system'
+tls_include_dir=''
+tls_lib_dir=''
EOF
exit 0