aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-10-27 05:04:21 +0800
committerswills <swills@FreeBSD.org>2014-10-27 05:04:21 +0800
commit1bef69b1cf78958e91373124e53110b701be5389 (patch)
tree43f8ad22dde713f3c4b00323750f35a4b326cce2 /mail
parentc01af5eee0eb1b0883d412ec76c6cb119b4d783c (diff)
downloadfreebsd-ports-gnome-1bef69b1cf78958e91373124e53110b701be5389.tar.gz
freebsd-ports-gnome-1bef69b1cf78958e91373124e53110b701be5389.tar.zst
freebsd-ports-gnome-1bef69b1cf78958e91373124e53110b701be5389.zip
Mark broken with Perl 5.18 and newer
Diffstat (limited to 'mail')
-rw-r--r--mail/maildirsync/Makefile8
-rw-r--r--mail/p5-MIME-Fast/Makefile8
-rw-r--r--mail/qar-bufo/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/mail/maildirsync/Makefile b/mail/maildirsync/Makefile
index 0b9a7ad9855a..4432d1427281 100644
--- a/mail/maildirsync/Makefile
+++ b/mail/maildirsync/Makefile
@@ -31,4 +31,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/contrib/mailbalance-0.2.0/* \
${STAGEDIR}${EXAMPLESDIR}/mailbalance
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-MIME-Fast/Makefile b/mail/p5-MIME-Fast/Makefile
index 88feb29dd7ca..5eae7e572508 100644
--- a/mail/p5-MIME-Fast/Makefile
+++ b/mail/p5-MIME-Fast/Makefile
@@ -19,4 +19,10 @@ USES= perl5
USE_PERL5= configure
CONFIGURE_ENV= PREFIX="${PREFIX}" CCFLAGS="${CCFLAGS} ${PTHREAD_CFLAGS}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/qar-bufo/Makefile b/mail/qar-bufo/Makefile
index 93284186be57..a9b27e763ad8 100644
--- a/mail/qar-bufo/Makefile
+++ b/mail/qar-bufo/Makefile
@@ -36,4 +36,10 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 \
${STAGEDIR}${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_VER} >= 5.18
+BROKEN= Does not build with Perl 5.18 or above
+.endif
+
+.include <bsd.port.post.mk>