aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2014-12-27 09:19:30 +0800
committermandree <mandree@FreeBSD.org>2014-12-27 09:19:30 +0800
commit280fcc9f19c601c60e4bd188c17bc0007cbb55a3 (patch)
tree05267e7ddf58cad8a5b6bc9e2432f35401cc914c /mail
parentaea7dadd114c2c2bae1ced9a62900398082e40ed (diff)
downloadfreebsd-ports-gnome-280fcc9f19c601c60e4bd188c17bc0007cbb55a3.tar.gz
freebsd-ports-gnome-280fcc9f19c601c60e4bd188c17bc0007cbb55a3.tar.zst
freebsd-ports-gnome-280fcc9f19c601c60e4bd188c17bc0007cbb55a3.zip
The rcfile now runs bin/check_perms so users have a visual clue in case
they installed the package without running scripts (pkg install -I). Clean up inconsistent image (=icon) installation. Reported by Alex Stangl. Makefile: Shuffle things around to please portlint. Makefile: Clean up muting: only mute RM, comments, MKDIR. Makefile: Move postfix checks into pkg-install. pkg-deinstall: drop workaround for traditional pkg_delete. pkg-deinstall: less verbose mail list reporting. pkg-deinstall: cleanups for last_mailman_version handling. pkg-install: defeat "Re-run..." line from check_perms to avoid confusing users. pkg-plist: cleanups and modernization. Sets directory permissions. NOTE: pkg 1.4.1 is unable to extract these on package installs, "make install" however should be fine.
Diffstat (limited to 'mail')
-rw-r--r--mail/mailman/Makefile38
-rw-r--r--mail/mailman/files/mailman.in1
-rw-r--r--mail/mailman/files/pkg-deinstall.in17
-rw-r--r--mail/mailman/files/pkg-install.in20
-rw-r--r--mail/mailman/files/pkg-message.in28
-rw-r--r--mail/mailman/pkg-plist317
6 files changed, 222 insertions, 199 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 75d994c20583..1bf5671ee6ae 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mailman
DISTVERSION= 2.1.18-1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_GNU} \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
@@ -11,6 +11,8 @@ MASTER_SITES= ${MASTER_SITE_GNU} \
MASTER_SITE_SUBDIR= ${PORTNAME}
DIST_SUBDIR= mailman
+PATCH_DIST_STRIP= -p1
+
MAINTAINER= mandree@FreeBSD.org
COMMENT= Mailing list manager with user-friendly web front-end
@@ -51,8 +53,6 @@ PLIST_SUB= MMDIR=${MM_DIR} IMGDIR=${IMGDIR} MM_USERNAME=${MM_USERNAME} MM_GROUPN
SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= MAILMANDIR=${MAILMANDIR} USER=${MM_USERNAME} GROUP=${MM_GROUPNAME}
-IMGFILES= PythonPowered.png mailman.jpg mm-icon.png
-
PORTDOCS= ACKNOWLEDGMENTS BUGS FAQ INSTALL NEWS README README-I18N.en \
README.CONTRIB README.NETSCAPE \
README.USERAGENT TODO UPGRADING \
@@ -112,7 +112,6 @@ PATCH_SITES+= http://www.openinfo.co.uk/mm/patches/444879/:patch1 \
http://www.openinfo.co.uk/mm/patches/444884/:patch2
PATCHFILES+= indexing-2.1.12-0.1.patch.gz:patch1 \
htdig-2.1.12-0.1.patch.gz:patch2
-PATCH_DIST_STRIP= -p1
PKGNAMESUFFIX+= -with-htdig
RUN_DEPENDS+= htdig:${PORTSDIR}/textproc/htdig
PLIST_SUB+= SUB_HTDIG=""
@@ -147,16 +146,16 @@ pre-everything::
@${ECHO} ""
post-patch:
- @${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
+ ${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
${WRKSRC}/Mailman/Defaults.py.in
- @${REINPLACE_CMD} -e 's/^0,5,10/#&/' ${WRKSRC}/cron/crontab.in.in
+ ${REINPLACE_CMD} -e 's/^0,5,10/#&/' ${WRKSRC}/cron/crontab.in.in
.if empty(PORT_OPTIONS:MNLS)
- @${REINPLACE_CMD} -e 's/messages//' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's/messages//' ${WRKSRC}/Makefile.in
.endif
.if ${PORT_OPTIONS:MPOSTFIX}
pre-configure:
- @${ECHO} "MTA = 'Postfix'" >> ${WRKSRC}/Mailman/mm_cfg.py.dist.in
+ ${ECHO} "MTA = 'Postfix'" >> ${WRKSRC}/Mailman/mm_cfg.py.dist.in
.endif
post-install:
@@ -177,34 +176,23 @@ post-install:
-d ${MAILMANDIR}/${dir} ${dir})
.endfor
@${RM} -f ${STAGEDIR}${MAILMANDIR}/pythonlib/*.egg-info
- # mm_cfg.py is handled by pkg-plist:
+ @# mm_cfg.py is handled by pkg-plist:
@${RM} -f ${STAGEDIR}${MAILMANDIR}/Mailman/mm_cfg.py
@${RM} -f ${STAGEDIR}${MAILMANDIR}/Mailman/mm_cfg.pyc
- ${MKDIR} ${STAGEDIR}${PREFIX}/${IMGDIR}
-.for imgfile in ${IMGFILES}
- ${CP} ${STAGEDIR}${MAILMANDIR}/icons/${imgfile} ${STAGEDIR}${PREFIX}/${IMGDIR}
-.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${IMGDIR}
+ ${CP} -p ${STAGEDIR}${MAILMANDIR}/icons/* ${STAGEDIR}${PREFIX}/${IMGDIR}
uudecode -p ${FILESDIR}/powerlogo.gif.uue > \
${STAGEDIR}${PREFIX}/${IMGDIR}/powerlogo.gif
.if ${PORT_OPTIONS:MDOCS}
${CP} -R ${WRKSRC}/doc/* ${WRKSRC}/
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${FILESDIR}/FreeBSD-post-install-notes ${STAGEDIR}${DOCSDIR}
.for docfile in ${PORTDOCS:NFreeBSD-post-install-notes}
${INSTALL_DATA} ${WRKSRC}/${docfile} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
- ${MKDIR} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+ @${MKDIR} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
${ECHO} "This marker file ensures that Python's upgrade-site-packages handles ${PKGNAME}." >${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/mailman-info.txt
-.if ${PORT_OPTIONS:MPOSTFIX}
- @if [ "x`${LOCALBASE}/sbin/postconf -h myhostname`" != "xlocalhost" ]; then \
- ${ECHO_CMD} ""; \
- ${ECHO_CMD} "Your Postfix hostname is non-default."; \
- ${ECHO_CMD} -n "You must add \"SMTPHOST = "; \
- ${ECHO_CMD} -n `${LOCALBASE}/sbin/postconf -h myhostname`; \
- ${ECHO_CMD} "\" to the bottom of mm_cfg.py."; \
- ${ECHO_CMD} ""; \
- fi
-.endif
+ ${INSTALL_SCRIPT} ${PKGINSTALL} ${STAGEDIR}${MAILMANDIR}/bin/FreeBSD-post-install
.include <bsd.port.mk>
diff --git a/mail/mailman/files/mailman.in b/mail/mailman/files/mailman.in
index 0ac5450c53d4..a28028ef4be6 100644
--- a/mail/mailman/files/mailman.in
+++ b/mail/mailman/files/mailman.in
@@ -27,6 +27,7 @@ status_cmd=${name}_status
extra_commands="reload status"
mailman_start() {
+ env LC_ALL=C %%MAILMANDIR%%/bin/check_perms
%%MAILMANDIR%%/bin/mailmanctl -s -q start
}
diff --git a/mail/mailman/files/pkg-deinstall.in b/mail/mailman/files/pkg-deinstall.in
index f8a389e8d545..62c2f27a9c17 100644
--- a/mail/mailman/files/pkg-deinstall.in
+++ b/mail/mailman/files/pkg-deinstall.in
@@ -39,14 +39,17 @@ DEINSTALL)
POST-DEINSTALL)
echo "---> Starting post-deinstall script"
- # try to kill all empty directories - necessary on pkg_add-based systems
- find "%%MAILMANDIR%%" -depth -type d -exec rmdir '{}' + >/dev/null 2>&1 || :
- if [ -d "%%MAILMANDIR%%" ]; then
- echo '---> %%MAILMANDIR%% is not empty - this installation may have active lists!'
- ls -lRB "%%MAILMANDIR%%" | head -n200 || :
+ set -- "%%MAILMANDIR%%/lists"/*
+ if [ $# -gt 1 ] || [ "x$1" != "x%%MAILMANDIR%%/lists/*" ] ; then
+ echo '---> %%MAILMANDIR%%/lists is not empty - this installation may have active lists! Listing max. 10:'
+ find "%%MAILMANDIR%%/lists" -mindepth 1 -maxdepth 1 | head -n 10 || :
echo "---> Restoring \"last_mailman_version\" file"
- /bin/mkdir -p "%%MAILMANDIR%%/data"
- /bin/mv -f /var/tmp/last_mailman_version "%%MAILMANDIR%%/data/"
+ if test -d "%%MAILMANDIR%%" ; then
+ /bin/mkdir -p "%%MAILMANDIR%%/data" && \
+ /bin/mv -f /var/tmp/last_mailman_version "%%MAILMANDIR%%/data/"
+ else
+ /bin/rm -f /var/tmp/last_mailman_version
+ fi
fi
;;
diff --git a/mail/mailman/files/pkg-install.in b/mail/mailman/files/pkg-install.in
index 53564cac299f..76858061f602 100644
--- a/mail/mailman/files/pkg-install.in
+++ b/mail/mailman/files/pkg-install.in
@@ -8,6 +8,8 @@ case $2 in
POST-INSTALL)
echo "---> Starting post-install script"
+ LC_ALL=C
+ export LC_ALL
MYTMP="$(mktemp -d "${TMPDIR-/tmp}/mminstall.XXXXXXXXXX")" || exit 1
trap "rm -rf \"$MYTMP\"" EXIT
@@ -41,7 +43,23 @@ POST-INSTALL)
rm -f "$MYTMP/crontab"
echo "---> Checking (and fixing) file and directory permissions"
- "%%MAILMANDIR%%/bin/check_perms" -f >/dev/null
+ output="$("%%MAILMANDIR%%/bin/check_perms" -f 2>&1)"
+ printf '%s\n' "$output" | egrep -v '^Re-run' || :
+
+ echo "---> Running assorted other checks"
+ if egrep -q "^[ \t]*MTA.*=.*Postfix" "%%MAILMANDIR%%/Mailman/mm_cfg.py" ; then
+ # run Postfix-specific checks
+ if [ "x`${PKG_PREFIX}/sbin/postconf -h myhostname`" != "xlocalhost" ] \
+ && ! egrep "^[ \t]*SMTPHOST.*=.*`${PKG_PREFIX}/sbin/postconf -h myhostname`" \
+ "%%MAILMANDIR%%/Mailman/mm_cfg.py"
+ then
+ echo ""
+ echo "Your Postfix hostname is non-default."
+ echo -n "You must add \"SMTPHOST = '`${PKG_PREFIX}/sbin/postconf -h myhostname`'"
+ echo "\" to the bottom of mm_cfg.py (without quotes)."
+ echo ""
+ fi
+ fi
;;
esac
diff --git a/mail/mailman/files/pkg-message.in b/mail/mailman/files/pkg-message.in
index 13ae430bbcf5..714741b7202d 100644
--- a/mail/mailman/files/pkg-message.in
+++ b/mail/mailman/files/pkg-message.in
@@ -1,6 +1,24 @@
----------------------------------------------------------------------------
Mailman has been installed, but requires further configuration before use!
+==========================================
+WARNING ATTENTION DANGER ATTENTION WARNING
+==========================================
+
+mail/mailman requires proper directory permissions to run; but due to
+pkg 1.4.1 or libarchive bugs, directory permissions can not be created
+properly.
+
+If you installed mailman with pkg -I, --no-script or --no-install-scripts,
+you MUST(!) run the post-install script now, as root:
+
+env "PKG_PREFIX=%%PREFIX%%" sh \
+ %%MAILMANDIR%%/bin/FreeBSD-post-install x POST-INSTALL
+
+==========================================
+WARNING ATTENTION DANGER ATTENTION WARNING
+==========================================
+
You will have to configure both your MTA (mail server) and web server to
integrate with Mailman. If the port's documentation has been installed,
extensive post-installation instructions may be found in:
@@ -29,10 +47,10 @@ installed in %%MAILMANDIR%%/bin.
Note (3): As of version 2.1, Mailman's queue runner runs as a daemon and
is started by a script in %%LOCALBASE%%/etc/rc.d
-In order to make private archives searchable with namazu2, you need copy
-or link %%LOCALBASE%%/libexec/namazu.cgi to
-%%MAILMANDIR%%/archives/private/<ML_name>/ and configure .namazurc
-to refer to %%LOCALBASE%%/etc/namazu/namazu-sample.
-You can also see the Japanese document in
+In order to make private archives searchable with namazu2, you need
+to copy or link %%LOCALBASE%%/libexec/namazu.cgi to
+%%MAILMANDIR%%/archives/private/<ML_name>/ and configure .namazurc.
+Refer to %%LOCALBASE%%/etc/namazu/namazu-sample.
+You can also see the document in Japanese language in
<http://www.python.jp/pipermail/mailman-users-jp/2004-August/001008.html>
----------------------------------------------------------------------------
diff --git a/mail/mailman/pkg-plist b/mail/mailman/pkg-plist
index 73ca5cf0e059..3235764d8007 100644
--- a/mail/mailman/pkg-plist
+++ b/mail/mailman/pkg-plist
@@ -1,19 +1,13 @@
-@stopdaemon mailman
@unexec if cmp -s %D/%%MMDIR%%/Mailman/mm_cfg.py %D/%%MMDIR%%/Mailman/mm_cfg.py.dist; then rm -f %D/%%MMDIR%%/Mailman/mm_cfg.py; fi
@unexec rm -f %D/%%MMDIR%%/Mailman/mm_cfg.pyc
-@exec mkdir -p %D/%%MMDIR%%/archives
-%%SUB_HTDIG%%@exec mkdir -p %D/%%MMDIR%%/archives/htdig
-@exec mkdir -p %D/%%MMDIR%%/archives/private
-@exec mkdir -p %D/%%MMDIR%%/archives/public
-@exec mkdir -p %D/%%MMDIR%%/lists
-@exec mkdir -p %D/%%MMDIR%%/locks
-@exec mkdir -p %D/%%MMDIR%%/logs
-@exec mkdir -p %D/%%MMDIR%%/qfiles
-@exec mkdir -p %D/%%MMDIR%%/spam
-%%IMGDIR%%/PythonPowered.png
+%%IMGDIR%%/%%MM_USERNAME%%-large.jpg
+%%IMGDIR%%/gnu-head-tiny.jpg
%%IMGDIR%%/mailman.jpg
+%%IMGDIR%%/mm-icon-large.ico
+%%IMGDIR%%/mm-icon.ico
%%IMGDIR%%/mm-icon.png
%%IMGDIR%%/powerlogo.gif
+%%IMGDIR%%/PythonPowered.png
@group %%MM_GROUPNAME%%
%%MMDIR%%/Mailman/Archiver/Archiver.py
%%MMDIR%%/Mailman/Archiver/Archiver.pyc
@@ -317,6 +311,7 @@
@exec [ -f %B/mm_cfg.py ] || cp %B/%f %B/mm_cfg.py
%%MMDIR%%/Mailman/versions.py
%%MMDIR%%/Mailman/versions.pyc
+%%MMDIR%%/bin/FreeBSD-post-install
%%MMDIR%%/bin/add_members
%%MMDIR%%/bin/arch
%%MMDIR%%/bin/b4b5-archfix
@@ -2259,154 +2254,154 @@
%%MMDIR%%/tests/test_smtp.py
%%MMDIR%%/tests/testall.py
%%PYTHON_SITELIBDIR%%/mailman-info.txt
-@comment @dirrmtry %%PYTHON_SITELIBDIR%%
-@dirrm %%MMDIR%%/tests/msgs
-@dirrm %%MMDIR%%/tests/bounces
-@dirrm %%MMDIR%%/tests
-%%NLS%%@dirrm %%MMDIR%%/templates/zh_TW
-%%NLS%%@dirrm %%MMDIR%%/templates/zh_CN
-%%NLS%%@dirrm %%MMDIR%%/templates/vi
-%%NLS%%@dirrm %%MMDIR%%/templates/uk
-%%NLS%%@dirrm %%MMDIR%%/templates/tr
-%%NLS%%@dirrm %%MMDIR%%/templates/sv
-%%NLS%%@dirrm %%MMDIR%%/templates/sr
-%%NLS%%@dirrm %%MMDIR%%/templates/sl
-%%NLS%%@dirrm %%MMDIR%%/templates/sk
-%%NLS%%@dirrm %%MMDIR%%/templates/ru
-%%NLS%%@dirrm %%MMDIR%%/templates/ro
-%%NLS%%@dirrm %%MMDIR%%/templates/pt_BR
-%%NLS%%@dirrm %%MMDIR%%/templates/pt
-%%NLS%%@dirrm %%MMDIR%%/templates/pl
-%%NLS%%@dirrm %%MMDIR%%/templates/no
-%%NLS%%@dirrm %%MMDIR%%/templates/nl
-%%NLS%%@dirrm %%MMDIR%%/templates/lt
-%%NLS%%@dirrm %%MMDIR%%/templates/ko
-%%NLS%%@dirrm %%MMDIR%%/templates/ja
-%%NLS%%@dirrm %%MMDIR%%/templates/it
-%%NLS%%@dirrm %%MMDIR%%/templates/ia
-%%NLS%%@dirrm %%MMDIR%%/templates/hu
-%%NLS%%@dirrm %%MMDIR%%/templates/hr
-%%NLS%%@dirrm %%MMDIR%%/templates/he
-%%NLS%%@dirrm %%MMDIR%%/templates/gl
-%%NLS%%@dirrm %%MMDIR%%/templates/fr
-%%NLS%%@dirrm %%MMDIR%%/templates/fi
-%%NLS%%@dirrm %%MMDIR%%/templates/fa
-%%NLS%%@dirrm %%MMDIR%%/templates/eu
-%%NLS%%@dirrm %%MMDIR%%/templates/et
-%%NLS%%@dirrm %%MMDIR%%/templates/es
-@dirrm %%MMDIR%%/templates/en
-%%NLS%%@dirrm %%MMDIR%%/templates/el
-%%NLS%%@dirrm %%MMDIR%%/templates/de
-%%NLS%%@dirrm %%MMDIR%%/templates/da
-%%NLS%%@dirrm %%MMDIR%%/templates/cs
-%%NLS%%@dirrm %%MMDIR%%/templates/ca
-%%NLS%%@dirrm %%MMDIR%%/templates/ast
-%%NLS%%@dirrm %%MMDIR%%/templates/ar
-@dirrm %%MMDIR%%/templates
-@dirrm %%MMDIR%%/scripts
-%%NLS%%@dirrm %%MMDIR%%/messages/ast/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/ast
-%%NLS%%@dirrm %%MMDIR%%/messages/zh_TW/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/zh_TW
-%%NLS%%@dirrm %%MMDIR%%/messages/zh_CN/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/zh_CN
-%%NLS%%@dirrm %%MMDIR%%/messages/vi/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/vi
-%%NLS%%@dirrm %%MMDIR%%/messages/uk/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/uk
-%%NLS%%@dirrm %%MMDIR%%/messages/tr/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/tr
-%%NLS%%@dirrm %%MMDIR%%/messages/sv/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/sv
-%%NLS%%@dirrm %%MMDIR%%/messages/sr/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/sr
-%%NLS%%@dirrm %%MMDIR%%/messages/sl/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/sl
-%%NLS%%@dirrm %%MMDIR%%/messages/sk/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/sk
-%%NLS%%@dirrm %%MMDIR%%/messages/ru/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/ru
-%%NLS%%@dirrm %%MMDIR%%/messages/ro/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/ro
-%%NLS%%@dirrm %%MMDIR%%/messages/pt_BR/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/pt_BR
-%%NLS%%@dirrm %%MMDIR%%/messages/pt/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/pt
-%%NLS%%@dirrm %%MMDIR%%/messages/pl/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/pl
-%%NLS%%@dirrm %%MMDIR%%/messages/no/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/no
-%%NLS%%@dirrm %%MMDIR%%/messages/nl/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/nl
-%%NLS%%@dirrm %%MMDIR%%/messages/lt/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/lt
-%%NLS%%@dirrm %%MMDIR%%/messages/ko/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/ko
-%%NLS%%@dirrm %%MMDIR%%/messages/ja/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/ja
-%%NLS%%@dirrm %%MMDIR%%/messages/it/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/it
-%%NLS%%@dirrm %%MMDIR%%/messages/ia/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/ia
-%%NLS%%@dirrm %%MMDIR%%/messages/hu/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/hu
-%%NLS%%@dirrm %%MMDIR%%/messages/hr/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/hr
-%%NLS%%@dirrm %%MMDIR%%/messages/he/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/he
-%%NLS%%@dirrm %%MMDIR%%/messages/gl/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/gl
-%%NLS%%@dirrm %%MMDIR%%/messages/fr/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/fr
-%%NLS%%@dirrm %%MMDIR%%/messages/fi/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/fi
-%%NLS%%@dirrm %%MMDIR%%/messages/fa/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/fa
-%%NLS%%@dirrm %%MMDIR%%/messages/eu/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/eu
-%%NLS%%@dirrm %%MMDIR%%/messages/et/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/et
-%%NLS%%@dirrm %%MMDIR%%/messages/es/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/es
-%%NLS%%@dirrm %%MMDIR%%/messages/el/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/el
-%%NLS%%@dirrm %%MMDIR%%/messages/de/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/de
-%%NLS%%@dirrm %%MMDIR%%/messages/da/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/da
-%%NLS%%@dirrm %%MMDIR%%/messages/cs/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/cs
-%%NLS%%@dirrm %%MMDIR%%/messages/ca/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/ca
-%%NLS%%@dirrm %%MMDIR%%/messages/ar/LC_MESSAGES
-%%NLS%%@dirrm %%MMDIR%%/messages/ar
-%%NLS%%@dirrm %%MMDIR%%/messages
-@dirrm %%MMDIR%%/mail
-@dirrm %%MMDIR%%/icons
-@dirrm %%MMDIR%%/cron
-@dirrmtry %%MMDIR%%/pythonlib
-@dirrm %%MMDIR%%/cgi-bin
-@dirrm %%MMDIR%%/bin
-@dirrm %%MMDIR%%/Mailman/Queue
-@dirrm %%MMDIR%%/Mailman/MTA
-@dirrm %%MMDIR%%/Mailman/Logging
-@dirrm %%MMDIR%%/Mailman/Handlers
-@dirrm %%MMDIR%%/Mailman/Gui
-@dirrm %%MMDIR%%/Mailman/Commands
-@dirrm %%MMDIR%%/Mailman/Cgi
-@dirrm %%MMDIR%%/Mailman/Bouncers
-@dirrm %%MMDIR%%/Mailman/Archiver
-@dirrmtry %%IMGDIR%%
-@dirrmtry %%MMDIR%%/spam
-@dirrmtry %%MMDIR%%/qfiles
-@dirrmtry %%MMDIR%%/logs
-@dirrmtry %%MMDIR%%/locks
-@dirrmtry %%MMDIR%%/lists
-@dirrmtry %%MMDIR%%/data
-@dirrmtry %%MMDIR%%/archives/public
-@dirrmtry %%MMDIR%%/archives/private
-%%SUB_HTDIG%%@dirrmtry %%MMDIR%%/archives/htdig
-@dirrmtry %%MMDIR%%/archives
-@dirrmtry %%MMDIR%%/Mailman
-@dirrmtry %%MMDIR%%
+@comment @dir %%PYTHON_SITELIBDIR%%
+@dir %%MMDIR%%/tests/msgs
+@dir %%MMDIR%%/tests/bounces
+@dir %%MMDIR%%/tests
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/zh_TW
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/zh_CN
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/vi
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/uk
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/tr
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/sv
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/sr
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/sl
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/sk
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/ru
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/ro
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/pt_BR
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/pt
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/pl
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/no
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/nl
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/lt
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/ko
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/ja
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/it
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/ia
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/hu
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/hr
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/he
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/gl
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/fr
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/fi
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/fa
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/eu
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/et
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/es
+@dir(,,02775) %%MMDIR%%/templates/en
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/el
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/de
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/da
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/cs
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/ca
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/ast
+%%NLS%%@dir(,,02775) %%MMDIR%%/templates/ar
+@dir %%MMDIR%%/templates
+@dir %%MMDIR%%/scripts
+%%NLS%%@dir %%MMDIR%%/messages/ast/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/ast
+%%NLS%%@dir %%MMDIR%%/messages/zh_TW/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/zh_TW
+%%NLS%%@dir %%MMDIR%%/messages/zh_CN/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/zh_CN
+%%NLS%%@dir %%MMDIR%%/messages/vi/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/vi
+%%NLS%%@dir %%MMDIR%%/messages/uk/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/uk
+%%NLS%%@dir %%MMDIR%%/messages/tr/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/tr
+%%NLS%%@dir %%MMDIR%%/messages/sv/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/sv
+%%NLS%%@dir %%MMDIR%%/messages/sr/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/sr
+%%NLS%%@dir %%MMDIR%%/messages/sl/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/sl
+%%NLS%%@dir %%MMDIR%%/messages/sk/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/sk
+%%NLS%%@dir %%MMDIR%%/messages/ru/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/ru
+%%NLS%%@dir %%MMDIR%%/messages/ro/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/ro
+%%NLS%%@dir %%MMDIR%%/messages/pt_BR/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/pt_BR
+%%NLS%%@dir %%MMDIR%%/messages/pt/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/pt
+%%NLS%%@dir %%MMDIR%%/messages/pl/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/pl
+%%NLS%%@dir %%MMDIR%%/messages/no/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/no
+%%NLS%%@dir %%MMDIR%%/messages/nl/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/nl
+%%NLS%%@dir %%MMDIR%%/messages/lt/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/lt
+%%NLS%%@dir %%MMDIR%%/messages/ko/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/ko
+%%NLS%%@dir %%MMDIR%%/messages/ja/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/ja
+%%NLS%%@dir %%MMDIR%%/messages/it/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/it
+%%NLS%%@dir %%MMDIR%%/messages/ia/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/ia
+%%NLS%%@dir %%MMDIR%%/messages/hu/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/hu
+%%NLS%%@dir %%MMDIR%%/messages/hr/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/hr
+%%NLS%%@dir %%MMDIR%%/messages/he/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/he
+%%NLS%%@dir %%MMDIR%%/messages/gl/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/gl
+%%NLS%%@dir %%MMDIR%%/messages/fr/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/fr
+%%NLS%%@dir %%MMDIR%%/messages/fi/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/fi
+%%NLS%%@dir %%MMDIR%%/messages/fa/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/fa
+%%NLS%%@dir %%MMDIR%%/messages/eu/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/eu
+%%NLS%%@dir %%MMDIR%%/messages/et/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/et
+%%NLS%%@dir %%MMDIR%%/messages/es/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/es
+%%NLS%%@dir %%MMDIR%%/messages/el/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/el
+%%NLS%%@dir %%MMDIR%%/messages/de/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/de
+%%NLS%%@dir %%MMDIR%%/messages/da/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/da
+%%NLS%%@dir %%MMDIR%%/messages/cs/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/cs
+%%NLS%%@dir %%MMDIR%%/messages/ca/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/ca
+%%NLS%%@dir %%MMDIR%%/messages/ar/LC_MESSAGES
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages/ar
+%%NLS%%@dir(,,02775) %%MMDIR%%/messages
+@dir %%MMDIR%%/mail
+@dir %%MMDIR%%/icons
+@dir %%MMDIR%%/cron
+@dir %%MMDIR%%/pythonlib
+@dir %%MMDIR%%/cgi-bin
+@dir %%MMDIR%%/bin
+@dir %%MMDIR%%/Mailman/Queue
+@dir %%MMDIR%%/Mailman/MTA
+@dir %%MMDIR%%/Mailman/Logging
+@dir %%MMDIR%%/Mailman/Handlers
+@dir %%MMDIR%%/Mailman/Gui
+@dir %%MMDIR%%/Mailman/Commands
+@dir %%MMDIR%%/Mailman/Cgi
+@dir %%MMDIR%%/Mailman/Bouncers
+@dir %%MMDIR%%/Mailman/Archiver
+@dir %%IMGDIR%%
+@dir %%MMDIR%%/spam
+@dir %%MMDIR%%/qfiles
+@dir %%MMDIR%%/logs
+@dir %%MMDIR%%/locks
+@dir %%MMDIR%%/lists
+@dir %%MMDIR%%/data
+@dir %%MMDIR%%/archives/public
+@dir %%MMDIR%%/archives/private
+%%SUB_HTDIG%%@dir %%MMDIR%%/archives/htdig
+@dir %%MMDIR%%/archives
+@dir %%MMDIR%%/Mailman
+@dir(,,02775) %%MMDIR%%
@group