aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2014-09-12 23:29:24 +0800
committermandree <mandree@FreeBSD.org>2014-09-12 23:29:24 +0800
commit2dfad8f9706f9eeb5d1cebcf35a3ad1a12741fd0 (patch)
tree6378dfa3f9407def67bd0e7b068e2dd94f215eb0 /mail
parent8033ca677bcb46c57d4ec521c876892fcb63e233 (diff)
downloadfreebsd-ports-gnome-2dfad8f9706f9eeb5d1cebcf35a3ad1a12741fd0.tar.gz
freebsd-ports-gnome-2dfad8f9706f9eeb5d1cebcf35a3ad1a12741fd0.tar.zst
freebsd-ports-gnome-2dfad8f9706f9eeb5d1cebcf35a3ad1a12741fd0.zip
Mark broken on GCC-based systems.
Approved by: bapt
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 0a4a0b627e05..657dcc3a9407 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -44,7 +44,7 @@ USE_QT5= # empty
QT_NONSTANDARD= yes
ALL_TARGET= default
USE_GL= gl
-USES= dos2unix tar:bzip2
+USES= dos2unix tar:bzip2 compiler:features
DOS2UNIX_FILES= mozilla/media/webrtc/trunk/webrtc/system_wrappers/source/spreadsortlib/spreadsort.hpp
MOZ_OPTIONS= --program-transform-name='s/thunderbird/${MOZILLA}/' \
@@ -74,6 +74,10 @@ OPTIONS_DEFAULT:=${OPTIONS_DEFAULT:S/GSTREAMER//}
.include <bsd.port.pre.mk>
+.if ${COMPILER_TYPE} == gcc
+BROKEN= run-time link paths not set on gcc-based systems
+.endif
+
WRKSRC= ${WRKDIR}/comm-esr31
MOZSRC:= ${WRKSRC}/mozilla