aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2007-02-17 15:45:53 +0800
committermbr <mbr@FreeBSD.org>2007-02-17 15:45:53 +0800
commit40795a302fc0dc62b638e7961996f41e1b510987 (patch)
tree39794f65cfaa155a181946f12ac85406eeda8295 /mail
parent435aecb91e2a97d962c7db8d73c07d47ea724e9c (diff)
downloadfreebsd-ports-gnome-40795a302fc0dc62b638e7961996f41e1b510987.tar.gz
freebsd-ports-gnome-40795a302fc0dc62b638e7961996f41e1b510987.tar.zst
freebsd-ports-gnome-40795a302fc0dc62b638e7961996f41e1b510987.zip
Fix clamscan 0.90 fallback and remove the --mbox option
Add another fallback case for clamd 0.90 Bump portrevision Approved by: wes
Diffstat (limited to 'mail')
-rw-r--r--mail/mimedefang/Makefile1
-rw-r--r--mail/mimedefang/files/patch-mimedefang.pl.in44
2 files changed, 45 insertions, 0 deletions
diff --git a/mail/mimedefang/Makefile b/mail/mimedefang/Makefile
index f2e0269a6614..992ba1a05d55 100644
--- a/mail/mimedefang/Makefile
+++ b/mail/mimedefang/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mimedefang
PORTVERSION= 2.61
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.mimedefang.org/static/
diff --git a/mail/mimedefang/files/patch-mimedefang.pl.in b/mail/mimedefang/files/patch-mimedefang.pl.in
index df69d945552d..19be7a949f9c 100644
--- a/mail/mimedefang/files/patch-mimedefang.pl.in
+++ b/mail/mimedefang/files/patch-mimedefang.pl.in
@@ -9,3 +9,47 @@
$TrophieSock = "@SPOOLDIR@/trophie";
package MIME::Parser::ParanoidFiler;
+@@ -3669,7 +3669,7 @@
+
+ # Run clamscan
+ my($code, $category, $action) =
+- run_virus_scanner($Features{'Virus:CLAMAV'} . " --mbox --stdout --disable-summary --infected $path 2>&1");
++ run_virus_scanner($Features{'Virus:CLAMAV'} . " --stdout --disable-summary --infected $path 2>&1");
+ if ($action ne 'proceed') {
+ return (wantarray ? ($code, $category, $action) : $code);
+ }
+@@ -3693,7 +3693,7 @@
+
+ # Run clamscan
+ my($code, $category, $action) =
+- run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --mbox --stdout --disable-summary --infected ./Work 2>&1");
++ run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --stdout --disable-summary --infected ./Work 2>&1");
+ if ($action ne 'proceed') {
+ return (wantarray ? ($code, $category, $action) : $code);
+ }
+@@ -4506,10 +4506,10 @@
+ md_syslog('err', "$MsgID: Clamd returned error: $err_detail");
+ # If it's a zip module failure, try falling back on clamscan.
+ # This is despicable, but it might work
+- if ($err_detail =~ /zip module failure/i &&
++ if ($err_detail =~ /(?:zip module failure|Not supported data format)/i &&
+ $Features{'Virus:CLAMAV'}) {
+ my ($code, $category, $action) =
+- run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --unzip --mbox --stdout --disable-summary --infected $CWD/Work 2>&1");
++ run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --unzip --stdout --disable-summary --infected $CWD/Work 2>&1");
+ if ($action ne 'proceed') {
+ return (wantarray ? ($code, $category, $action) : $code);
+ }
+@@ -4603,10 +4603,10 @@
+ md_syslog('err', "$MsgID: Clamd returned error: $err_detail");
+ # If it's a zip module failure, try falling back on clamscan.
+ # This is despicable, but it might work
+- if ($err_detail =~ /zip module failure/i &&
++ if ($err_detail =~ /(?:zip module failure|Not supported data format)/i &&
+ $Features{'Virus:CLAMAV'}) {
+ my ($code, $category, $action) =
+- run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --unzip --mbox --stdout --disable-summary --infected $CWD/Work 2>&1");
++ run_virus_scanner($Features{'Virus:CLAMAV'} . " -r --unzip --stdout --disable-summary --infected $CWD/Work 2>&1");
+ if ($action ne 'proceed') {
+ return (wantarray ? ($code, $category, $action) : $code);
+ }