aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-02-19 05:08:56 +0800
committernetchild <netchild@FreeBSD.org>2005-02-19 05:08:56 +0800
commit41c80d99fd014ead1e7a389b281f6559e3f4db39 (patch)
treea9f673d6b08d5c88e9c8b2c1e16388bb1ddfb149 /mail
parent68e06aeb7735cd775d67884bea7cf9d5f54e3034 (diff)
downloadfreebsd-ports-gnome-41c80d99fd014ead1e7a389b281f6559e3f4db39.tar.gz
freebsd-ports-gnome-41c80d99fd014ead1e7a389b281f6559e3f4db39.tar.zst
freebsd-ports-gnome-41c80d99fd014ead1e7a389b281f6559e3f4db39.zip
Link with PTHREAD libs (unconditionally) for the benefit of plugins which
need them (e.g. the clamav plugin). Tested by: Ion-Mihai Tetcu <itetcu@people.tecnik93.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/claws-mail/Makefile5
-rw-r--r--mail/sylpheed-claws/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 9ae7d81da28e..6ab7cd0bd3ec 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -66,8 +67,8 @@ PLIST_SUB+= GNOME="@comment "
CONFIGURE_ARGS+= --program-suffix="-claws" --enable-ipv6
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.if exists(${LOCALBASE}/include/clamav.h)
WITH_CLAMAV= yes
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 9ae7d81da28e..6ab7cd0bd3ec 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -66,8 +67,8 @@ PLIST_SUB+= GNOME="@comment "
CONFIGURE_ARGS+= --program-suffix="-claws" --enable-ipv6
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.if exists(${LOCALBASE}/include/clamav.h)
WITH_CLAMAV= yes